summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2013-01-21 13:28:54 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2013-01-21 13:28:54 +0000
commit29656557078b3e162b5a031db0be6e1b32750dac (patch)
tree3f5dca6f523fa601f02fb875ae46e24403a6e72b /dev-libs
parentRemove ancient/unused USE flags. (diff)
downloadgentoo-2-29656557078b3e162b5a031db0be6e1b32750dac.tar.gz
gentoo-2-29656557078b3e162b5a031db0be6e1b32750dac.tar.bz2
gentoo-2-29656557078b3e162b5a031db0be6e1b32750dac.zip
Version bump fix #449120
(Portage version: 2.1.11.41/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/mongo-c-driver/ChangeLog9
-rw-r--r--dev-libs/mongo-c-driver/mongo-c-driver-0.7.1.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/dev-libs/mongo-c-driver/ChangeLog b/dev-libs/mongo-c-driver/ChangeLog
index 269c5061ac2d..1b967ddfe2ed 100644
--- a/dev-libs/mongo-c-driver/ChangeLog
+++ b/dev-libs/mongo-c-driver/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/mongo-c-driver
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/mongo-c-driver/ChangeLog,v 1.2 2012/10/29 10:00:12 ultrabug Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mongo-c-driver/ChangeLog,v 1.3 2013/01/21 13:28:54 ultrabug Exp $
+
+*mongo-c-driver-0.7.1 (21 Jan 2013)
+
+ 21 Jan 2013; Ultrabug <ultrabug@gentoo.org> +mongo-c-driver-0.7.1.ebuild:
+ Version bump fix #449120
29 Oct 2012; Ultrabug <ultrabug@gentoo.org> metadata.xml:
Add myself as maintainer to keep track of this ebuild.
diff --git a/dev-libs/mongo-c-driver/mongo-c-driver-0.7.1.ebuild b/dev-libs/mongo-c-driver/mongo-c-driver-0.7.1.ebuild
new file mode 100644
index 000000000000..472b4a76f371
--- /dev/null
+++ b/dev-libs/mongo-c-driver/mongo-c-driver-0.7.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/mongo-c-driver/mongo-c-driver-0.7.1.ebuild,v 1.1 2013/01/21 13:28:54 ultrabug Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit multilib python
+
+DESCRIPTION="C Driver for MongoDB"
+HOMEPAGE="http://www.mongodb.org/ https://github.com/mongodb/mongo-c-driver"
+SRC_URI="https://github.com/mongodb/${PN}/tarball/v${PV/_/} -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc static-libs"
+
+# tests fails to build
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="doc? ( dev-python/sphinx )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}
+
+src_compile() {
+ emake
+ use doc && make -C docs/source/sphinx html
+}
+
+src_install() {
+ emake install \
+ INSTALL_LIBRARY_PATH="${D}/usr/$(get_libdir)" \
+ INSTALL_INCLUDE_PATH="${D}/usr/include"
+
+ use static-libs || find "${ED}" -name '*.a' -exec rm -f {} +
+
+ use doc && dohtml -r docs/source/sphinx/build/html/*
+}