summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTuan Van <langthang@gentoo.org>2006-05-25 18:18:50 +0000
committerTuan Van <langthang@gentoo.org>2006-05-25 18:18:50 +0000
commit29d8769ea0582c4e1c75ad1fe2ae964df314bd5a (patch)
treeab5b8b36fc02a2f7b3d2142c1a8ee12729dbf40e /dev-libs
parentStable on hppa. (diff)
downloadgentoo-2-29d8769ea0582c4e1c75ad1fe2ae964df314bd5a.tar.gz
gentoo-2-29d8769ea0582c4e1c75ad1fe2ae964df314bd5a.tar.bz2
gentoo-2-29d8769ea0582c4e1c75ad1fe2ae964df314bd5a.zip
Add --enable-auth-sasldb to myconf. Requested by Gary Richards <gary_gentoo@dsnine.co.uk>, bug #129170.
Add patch to support as-needed. Report by Prakash Punnoor <prakashp@arcor.de>, bug #116458. Do not generate /etc/sasl2/sasldb2 if found. Some tidy. NOTE: imtest from cyrus-imapd <2.3.6 is not compatible with this release. (Portage version: 2.1_rc1-r2)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/cyrus-sasl/ChangeLog13
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-2.1.22.ebuild274
-rw-r--r--dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.22-as-needed.patch11
-rw-r--r--dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.226
4 files changed, 303 insertions, 1 deletions
diff --git a/dev-libs/cyrus-sasl/ChangeLog b/dev-libs/cyrus-sasl/ChangeLog
index 1be6de553e27..425756ff03cb 100644
--- a/dev-libs/cyrus-sasl/ChangeLog
+++ b/dev-libs/cyrus-sasl/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for dev-libs/cyrus-sasl
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.145 2006/04/27 16:22:14 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.146 2006/05/25 18:18:50 langthang Exp $
+
+*cyrus-sasl-2.1.22 (25 May 2006)
+
+ 25 May 2006; Tuấn Văn <langthang@gentoo.org>
+ +files/cyrus-sasl-2.1.22-as-needed.patch, +cyrus-sasl-2.1.22.ebuild:
+ Add --enable-auth-sasldb to myconf.
+ Requested by Gary Richards <gary_gentoo@dsnine.co.uk>, bug #129170.
+ Add patch to support as-needed.
+ Report by Prakash Punnoor <prakashp@arcor.de>, bug #116458.
+ Do not generate /etc/sasl2/sasldb2 if found. Tidy.
+ NOTE: imtest from cyrus-imapd <2.3.6 is not compatible with this release.
27 Apr 2006; Marien Zwart <marienz@gentoo.org>
files/digest-cyrus-sasl-2.1.18-r2, files/digest-cyrus-sasl-2.1.19-r1,
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.22.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.22.ebuild
new file mode 100644
index 000000000000..f91cc4720e02
--- /dev/null
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.22.ebuild
@@ -0,0 +1,274 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.22.ebuild,v 1.1 2006/05/25 18:18:50 langthang Exp $
+
+inherit eutils gnuconfig flag-o-matic java-pkg multilib
+
+ntlm_patch=${P}-ntlm_impl-spnego.patch.gz
+SASLAUTHD_CONF_VER=2.1.21
+
+DESCRIPTION="The Cyrus SASL (Simple Authentication and Security Layer)"
+HOMEPAGE="http://asg.web.cmu.edu/sasl/"
+SRC_URI="ftp://ftp.andrew.cmu.edu/pub/cyrus-mail/${P}.tar.gz
+ ntlm_unsupported_patch? ( mirror://gentoo/${ntlm_patch} )"
+
+LICENSE="as-is"
+SLOT="2"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+# Removed 'static' USE flag because it is broken upstream, Bug #94137
+IUSE="berkdb crypt gdbm ldap mysql postgres kerberos ssl java pam
+ authdaemond sample urandom srp ntlm_unsupported_patch"
+
+RDEPEND="virtual/libc
+ berkdb? ( >=sys-libs/db-3.2 )
+ gdbm? ( >=sys-libs/gdbm-1.8.0 )
+ ldap? ( >=net-nds/openldap-2.0.25 )
+ mysql? ( >=dev-db/mysql-3.23.51 )
+ postgres? ( >=dev-db/postgresql-7.2 )
+ pam? ( virtual/pam )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ kerberos? ( virtual/krb5 )
+ authdaemond? (
+ || (
+ >=net-mail/courier-imap-3.0.7
+ >=mail-mta/courier-0.46
+ )
+ )
+ java? ( virtual/jdk )
+ ntlm_unsupported_patch? ( >=net-fs/samba-3.0.9 )"
+
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ >=sys-devel/autoconf-2.58
+ sys-devel/automake
+ sys-devel/libtool"
+
+pkg_setup() {
+
+ if use gdbm && use berkdb; then
+ echo
+ ewarn "You have both \"gdbm\" and \"berkdb\" in your USE flags."
+ ewarn "Will default to GNU DB as your SASLdb database backend."
+ ewarn "If you want to build with Berkeley DB support; hit Control-C now."
+ ewarn "Change your USE flag -gdbm and emerge again."
+ echo
+ has_version ">=sys-apps/portage-2.0.50" && (
+ einfo "It would be best practice to add the set of USE flags that you use for this"
+ einfo "package to the file: /etc/portage/package.use. Example:"
+ einfo "\`echo \"dev-libs/cyrus-sasl -gdbm berkdb\" >> /etc/portage/package.use\`"
+ einfo "to build cyrus-sasl with Berkeley database as your SASLdb backend."
+ )
+ echo
+ ewarn "Waiting 10 seconds before starting..."
+ ewarn "(Control-C to abort)..."
+ epause 10
+ fi
+}
+
+src_unpack() {
+ unpack ${A} && cd "${S}"
+
+
+ # Fix default port name for rimap auth mechanism.
+ sed -e '/define DEFAULT_REMOTE_SERVICE/s:imap:imap2:' \
+ -i saslauthd/auth_rimap.c || die "sed failed"
+
+ # Fixed upstream. Add openldap 2.3 compile patch - bug #113914
+ # epatch "${FILESDIR}/${PN}-2.1.21-configure.patch"
+
+ # Fixed upstream. Add configdir support.
+ # epatch "${FILESDIR}/${PN}-2.1.20-configdir.patch"
+
+ # Fix include path for newer PostgreSQL versions.
+ epatch "${FILESDIR}/${PN}-2.1.17-pgsql-include.patch"
+
+ # Fixed upstream. Fix for gcc-4.0
+ # epatch "${FILESDIR}/${PN}-2.1.20-gcc4.patch"
+
+ # UNSUPPORTED ntlm patch. Bug #81342
+ use ntlm_unsupported_patch && epatch "${DISTDIR}/${ntlm_patch}"
+
+ # --as-needed.
+ epatch "${FILESDIR}/${P}-as-needed.patch"
+
+ # Support for crypted passwords. Bug #45181
+ use crypt && epatch "${FILESDIR}/cyrus-sasl-2.1.19-checkpw.c.patch"
+
+ # Upstream doesn't even honor their own configure options... grumble
+ sed -i 's:^sasldir = .*$:sasldir = $(plugindir):' "${S}/plugins/Makefile.{am,in}"
+
+ # Recreate configure.
+ export WANT_AUTOCONF="2.5"
+ rm -rf configure config.h.in autom4te.cache
+ ebegin "Recreating configure"
+ aclocal -I "${S}/cmulocal" -I "${S}/config" && autoheader && autoconf || \
+ die "recreate configure failed"
+ eend $?
+
+ # Recreate configure in saslauthd.
+ cd "${S}/saslauthd" || die "cd ${S}/saslauthd failed"
+ rm -rf configure config.h.in autom4te.cache
+ ebegin "Recreating configure in saslauthd"
+ aclocal -I "${S}/cmulocal" -I "${S}/config" && autoheader && autoconf || \
+ die "recreate configure failed"
+ eend $?
+
+}
+
+src_compile() {
+ local myconf="--enable-login --enable-ntlm --enable-auth-sasldb --disable-krb4 --disable-otp"
+# myconf="${myconf} `use_enable static`" -- doesn't work upstream Bug #94137
+ myconf="${myconf} `use_with ssl openssl`"
+ myconf="${myconf} `use_with pam`"
+ myconf="${myconf} `use_with ldap`"
+ myconf="${myconf} `use_enable ldap ldapdb`"
+ myconf="${myconf} `use_enable sample`"
+ myconf="${myconf} `use_enable kerberos gssapi`"
+ myconf="${myconf} `use_with mysql` `use_enable mysql`"
+ myconf="${myconf} `use_with postgres pgsql` `use_enable postgres`"
+ # Add use srp. Bug #81970.
+ myconf="${myconf} `use_enable srp`"
+ myconf="${myconf} `use_enable java` `use_with java javahome ${JAVA_HOME}`"
+ # bug #56523. add authdaemond support.
+ myconf="${myconf} `use_with authdaemond`"
+
+ # fix for bug #59634. langthang 20040810.
+ if ! use ssl; then
+ myconf="${myconf} --without-des"
+ fi
+
+ if use mysql || use postgres ; then
+ myconf="${myconf} --enable-sql"
+ else
+ myconf="${myconf} --disable-sql"
+ fi
+
+ # default to GDBM if both 'gdbm' and 'berkdb' present.
+ if use gdbm; then
+ einfo "build with GNU DB as database backend for your SASLdb."
+ myconf="${myconf} --with-dblib=gdbm"
+ elif use berkdb ; then
+ einfo "build with Berkeley DB as database backend for your SASLdb."
+ myconf="${myconf} --with-dblib=berkeley"
+ else
+ einfo "build without SASLdb support"
+ myconf="${myconf} --with-dblib=none"
+ fi
+
+ # Use /dev/urandom instead of /dev/random. Bug #46038
+ use urandom && myconf="${myconf} --with-devrandom=/dev/urandom"
+
+ # Detect mips systems properly.
+ gnuconfig_update
+
+ econf \
+ --with-saslauthd=/var/lib/sasl2 \
+ --with-pwcheck=/var/lib/sasl2 \
+ --with-configdir=/etc/sasl2 \
+ --with-plugindir=/usr/$(get_libdir)/sasl2 \
+ --with-dbpath=/etc/sasl2/sasldb2 \
+ ${myconf} || die "econf failed"
+
+ # Upstream doesn't even honor their own configure options... grumble
+ # We sed'd Makefile.in already. Remove this block after testing period.
+ # sed -i 's:^sasldir = .*$:sasldir = $(plugindir):' ${S}/plugins/Makefile
+
+ # we force -j1 for bug #110066
+ emake -j1 || die "compile problem"
+
+ # Bug #60769. Default location for java classes breaks OpenOffice.
+ # Thanks to axxo@gentoo.org for the solution.
+ cd "${S}"
+ if use java; then
+ jar -cvf ${PN}.jar -C java $(find java -name "*.class")
+ fi
+
+ # Bug #58768. Add testsaslauthd.
+ cd "${S}/saslauthd"
+ emake testsaslauthd || die "failed to make"
+}
+
+src_install () {
+ #einstall
+ make DESTDIR=${D} install || die "failed to install."
+ keepdir /var/lib/sasl2 /etc/sasl2
+
+ # Install everything necessary so user can build sample client/server
+ # (bug #64733)
+ if use sample; then
+ insinto /usr/share/${PN}-2/examples
+ doins aclocal.m4 config.h config.status configure.in
+ dosym /usr/include/sasl /usr/share/${PN}-2/examples/include
+ exeinto /usr/share/${PN}-2/examples
+ doexe libtool
+ insinto /usr/share/${PN}-2/examples/sample
+ doins sample/*.{c,h} sample/*Makefile*
+ insinto /usr/share/${PN}-2/examples/sample/.deps
+ doins sample/.deps/*
+ dodir /usr/share/${PN}-2/examples/lib
+ dosym /usr/$(get_libdir)/libsasl2.la /usr/share/${PN}-2/examples/lib/libsasl2.la
+ dodir /usr/share/${PN}-2/examples/lib/.libs
+ dosym /usr/$(get_libdir)/libsasl2.so /usr/share/${PN}-2/examples/lib/.libs/libsasl2.so
+ fi
+
+ # Bug #60769. Default location for java classes breaks OpenOffice.
+ if use java; then
+ java-pkg_dojar ${PN}.jar
+ #hackish, don't wanna dig though makefile
+ rm -rf "${D}/usr/$(get_libdir)/java"
+ docinto java
+ dodoc "${S}/java/README" "${FILESDIR}/java.README.gentoo" "${S}"/java/doc/*
+ mkdir "${D}/usr/share/doc/${PF}/java/Test/" \
+ || die "failed to create ${D}/usr/share/doc/${PF}/java/Test/"
+ cp "${S}"/java/Test/*.java "${D}/usr/share/doc/${PF}/java/Test/" \
+ || die "failed to copy java files to ${D}/usr/share/doc/${PF}/java/Test/"
+ fi
+
+ # Generate an empty sasldb2 with correct permissions.
+ if ( use berkdb || use gdbm ) && [[ ! -f "${ROOT}/etc/sasl2/sasldb2" ]]; then
+ LD_OLD="${LD_LIBRARY_PATH}"
+ export LD_LIBRARY_PATH="${D}/usr/$(get_libdir)" SASL_PATH="${D}/usr/$(get_libdir)/sasl2"
+ einfo "Generate an empty sasldb2 with correct permissions."
+ echo "p" | "${D}/usr/sbin/saslpasswd2" -f "${D}/etc/sasl2/sasldb2" -p login \
+ || die "failed to generate sasldb2"
+ "${D}/usr/sbin/saslpasswd2" -f "${D}/etc/sasl2/sasldb2" -d login
+ export LD_LIBRARY_PATH="${LD_OLD}"
+ chown root:mail "${D}/etc/sasl2/sasldb2"
+ chmod 0640 "${D}/etc/sasl2/sasldb2"
+ fi
+
+ docinto ""
+ dodoc AUTHORS COPYING ChangeLog NEWS README doc/TODO doc/*.txt
+ newdoc pwcheck/README README.pwcheck
+ dohtml doc/*.html
+
+ docinto saslauthd
+ dodoc saslauthd/{AUTHORS,COPYING,ChangeLog,LDAP_SASLAUTHD,NEWS,README}
+
+ newpamd "${FILESDIR}/saslauthd.pam-include" saslauthd
+ newinitd "${FILESDIR}/pwcheck.rc6" pwcheck || \
+ die "failed to install pwcheck to /etc/init.d"
+ newinitd "${FILESDIR}/saslauthd2.rc6" saslauthd || \
+ die "failed to install saslauthd to /etc/init.d"
+ newconfd "${FILESDIR}/saslauthd-${SASLAUTHD_CONF_VER}.conf" saslauthd || \
+ die "failed to install /etc/conf.d/saslauthd"
+
+ exeinto "${ROOT}/usr/sbin"
+ newexe "${S}/saslauthd/testsaslauthd" testsaslauthd || \
+ die "failed to install testsaslauthd."
+}
+
+pkg_postinst () {
+ if use sample; then
+ einfo "You have chosen to install sources for example client and server."
+ einfo "To build these, please type:"
+ einfo "\tcd /usr/share/${PN}-2/examples/sample && make"
+ fi
+
+ if use authdaemond; then
+ ewarn "You need to add a user running a service using Courier's"
+ ewarn "authdaemon to the 'mail' group. For example, do:"
+ echo " gpasswd -a postfix mail"
+ ewarn "to add postfix to 'mail' group."
+ fi
+}
diff --git a/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.22-as-needed.patch b/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.22-as-needed.patch
new file mode 100644
index 000000000000..1294cb507783
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/cyrus-sasl-2.1.22-as-needed.patch
@@ -0,0 +1,11 @@
+--- saslauthd/configure.in.orig 2006-05-23 15:53:17.000000000 -0700
++++ saslauthd/configure.in 2006-05-23 15:53:33.000000000 -0700
+@@ -77,7 +77,7 @@
+ AC_DEFINE(AUTH_SASLDB,[],[Include SASLdb Support])
+ SASL_DB_PATH_CHECK()
+ SASL_DB_CHECK()
+- SASL_DB_LIB="$SASL_DB_LIB ../sasldb/.libs/libsasldb.al"
++ SASL_DB_LIB="../sasldb/.libs/libsasldb.a $SASL_DB_LIB"
+ fi
+
+ AC_ARG_ENABLE(httpform, [ --enable-httpform enable HTTP form authentication [[no]] ],
diff --git a/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.22 b/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.22
new file mode 100644
index 000000000000..5b2ad91fb88b
--- /dev/null
+++ b/dev-libs/cyrus-sasl/files/digest-cyrus-sasl-2.1.22
@@ -0,0 +1,6 @@
+MD5 2e039a5b53e8934a3ca7107808acd7e1 cyrus-sasl-2.1.22-ntlm_impl-spnego.patch.gz 7466
+RMD160 70e498d2ca27289bd729563793dcdabe650ffac4 cyrus-sasl-2.1.22-ntlm_impl-spnego.patch.gz 7466
+SHA256 a696dddc27d46ab1950b546fcf49efc1a03a8380ecc4537d085d8daacb88ccf0 cyrus-sasl-2.1.22-ntlm_impl-spnego.patch.gz 7466
+MD5 45dde9d19193ae9dd388eb68b2027bc9 cyrus-sasl-2.1.22.tar.gz 1609278
+RMD160 086e20d01588cb86decad001244b72a37223354c cyrus-sasl-2.1.22.tar.gz 1609278
+SHA256 c69e3853f35b14ee2c3f6e876e42d880927258ff4678aa052e5f0853db209962 cyrus-sasl-2.1.22.tar.gz 1609278