summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2007-06-13 18:10:34 +0000
committerChristian Heim <phreak@gentoo.org>2007-06-13 18:10:34 +0000
commit546cf71c50b01c2edd641e3f9f751ed4cd8003fc (patch)
tree6b553a66ef9e527f02c26f68ad3881610ec2203f /dev-libs
parentReplace pointless "einstall install" by "einstall". (diff)
downloadgentoo-2-546cf71c50b01c2edd641e3f9f751ed4cd8003fc.tar.gz
gentoo-2-546cf71c50b01c2edd641e3f9f751ed4cd8003fc.tar.bz2
gentoo-2-546cf71c50b01c2edd641e3f9f751ed4cd8003fc.zip
Fixing cross compilation, thanks to Michal Januszewski in #181560.
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/klibc/ChangeLog5
-rw-r--r--dev-libs/klibc/klibc-1.5.ebuild10
2 files changed, 9 insertions, 6 deletions
diff --git a/dev-libs/klibc/ChangeLog b/dev-libs/klibc/ChangeLog
index fba3a1aedd44..1ba6c9597e2e 100644
--- a/dev-libs/klibc/ChangeLog
+++ b/dev-libs/klibc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/klibc
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/ChangeLog,v 1.42 2007/05/17 11:31:44 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/ChangeLog,v 1.43 2007/06/13 18:10:34 phreak Exp $
+
+ 13 Jun 2007; Christian Heim <phreak@gentoo.org> klibc-1.5.ebuild:
+ Fixing cross compilation, thanks to Michal Januszewski in #181560.
*klibc-1.5 (17 May 2007)
diff --git a/dev-libs/klibc/klibc-1.5.ebuild b/dev-libs/klibc/klibc-1.5.ebuild
index 355725a00004..eb51c0a699ef 100644
--- a/dev-libs/klibc/klibc-1.5.ebuild
+++ b/dev-libs/klibc/klibc-1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/klibc-1.5.ebuild,v 1.1 2007/05/17 11:31:44 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/klibc-1.5.ebuild,v 1.2 2007/06/13 18:10:34 phreak Exp $
inherit eutils linux-info multilib toolchain-funcs
@@ -103,8 +103,8 @@ src_compile() {
if tc-is-cross-compiler ; then
einfo "ARCH = \"$(guess_arch)\""
einfo "CROSS = \"${CTARGET}-\""
- emake ARCH=$(guess_arch) \
- CROSS="${CTARGET}-" \
+ emake KLIBCARCH=$(guess_arch) \
+ CROSS_COMPILE="${CTARGET}-" \
EXTRA_KLIBCAFLAGS="-Wa,--noexecstack" \
EXTRA_KLIBCLDFLAGS="-z,noexecstack" \
libdir="/usr/$(get_libdir)" \
@@ -140,8 +140,8 @@ src_install() {
EXTRA_KLIBCAFLAGS="-Wa,--noexecstack" \
EXTRA_KLIBCLDFLAGS="-z,noexecstack" \
INSTALLROOT="${D}" \
- ARCH=$(guess_arch) \
- CROSS="${CTARGET}-" \
+ KLIBCARCH=$(guess_arch) \
+ CROSS_COMPILE="${CTARGET}-" \
libdir="/usr/$(get_libdir)" \
SHLIBDIR="/$(get_libdir)" \
mandir="/usr/share/man" \