summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2006-06-09 18:33:37 +0000
committerJory Pratt <anarchy@gentoo.org>2006-06-09 18:33:37 +0000
commit5efdcc7eae4d679a8fdaab3d70216517475ae355 (patch)
treeff357e7811743813a6ab0f4799eb0d788742c416 /dev-libs
parentDon't alias the fortran compilers. (diff)
downloadgentoo-2-5efdcc7eae4d679a8fdaab3d70216517475ae355.tar.gz
gentoo-2-5efdcc7eae4d679a8fdaab3d70216517475ae355.tar.bz2
gentoo-2-5efdcc7eae4d679a8fdaab3d70216517475ae355.zip
perl -e cleanup, small clean up to tree
(Portage version: 2.1)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/nss/ChangeLog9
-rw-r--r--dev-libs/nss/files/digest-nss-3.11.1-r13
-rw-r--r--dev-libs/nss/files/nss-3.11.1-perl.patch45
-rw-r--r--dev-libs/nss/nss-3.11.1-r1.ebuild110
4 files changed, 166 insertions, 1 deletions
diff --git a/dev-libs/nss/ChangeLog b/dev-libs/nss/ChangeLog
index d441021af255..137eb415a567 100644
--- a/dev-libs/nss/ChangeLog
+++ b/dev-libs/nss/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/nss
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nss/ChangeLog,v 1.57 2006/06/03 17:48:42 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nss/ChangeLog,v 1.58 2006/06/09 18:33:37 anarchy Exp $
+
+*nss-3.11.1-r1 (09 Jun 2006)
+
+ 09 Jun 2006; Jory A. Pratt <anarchy@gentoo.org>
+ +files/nss-3.11.1-perl.patch, -files/nss-3.11.1-zdefs.patch,
+ -nss-3.11.ebuild, -nss-3.11.1.ebuild, +nss-3.11.1-r1.ebuild:
+ perl -e cleanup, small clean up to tree
03 Jun 2006; Guy Martin <gmsoft@gentoo.org> nss-3.11-r1.ebuild:
Stable on hppa.
diff --git a/dev-libs/nss/files/digest-nss-3.11.1-r1 b/dev-libs/nss/files/digest-nss-3.11.1-r1
new file mode 100644
index 000000000000..ae13c9b2bb79
--- /dev/null
+++ b/dev-libs/nss/files/digest-nss-3.11.1-r1
@@ -0,0 +1,3 @@
+MD5 5cb32527df232a62a7aed61336c8c373 nss-3.11.1.tar.gz 3650552
+RMD160 e6569ab941b08a59d2a459014389fd4581460aac nss-3.11.1.tar.gz 3650552
+SHA256 3f29d1f77f8f4fb9dc59d3a2fd13587e9be373a1cc8528e39c5d17f30807dc50 nss-3.11.1.tar.gz 3650552
diff --git a/dev-libs/nss/files/nss-3.11.1-perl.patch b/dev-libs/nss/files/nss-3.11.1-perl.patch
new file mode 100644
index 000000000000..194525095194
--- /dev/null
+++ b/dev-libs/nss/files/nss-3.11.1-perl.patch
@@ -0,0 +1,45 @@
+--- .pc/make-perl-problem-in-coreconf.diff/security/coreconf/rules.mk 2006-01-31 00:06:21.000000000 +0100
++++ security/coreconf/rules.mk 2006-01-31 00:31:37.000000000 +0100
+@@ -865,18 +865,18 @@ endif
+
+
+ ################################################################################
+
+ -include $(DEPENDENCIES)
+
+ ifneq (,$(filter-out OpenVMS OS2 WIN%,$(OS_TARGET)))
+ # Can't use sed because of its 4000-char line length limit, so resort to perl
+-.DEFAULT:
+- @perl -e ' \
++
++PERL_DEPENDENCIES_PROGRAM=\
+ open(MD, "< $(DEPENDENCIES)"); \
+ while (<MD>) { \
+ if (m@ \.*/*$< @) { \
+ $$found = 1; \
+ last; \
+ } \
+ } \
+ if ($$found) { \
+@@ -893,17 +893,20 @@ ifneq (,$(filter-out OpenVMS OS2 WIN%,$(
+ } \
+ close(TMD); \
+ if (!rename($$tmpname, "$(DEPENDENCIES)")) { \
+ unlink(($$tmpname)); \
+ } \
+ } elsif ("$<" ne "$(DEPENDENCIES)") { \
+ print "$(MAKE): *** No rule to make target $<. Stop.\n"; \
+ exit(1); \
+- }'
++ }
++
++.DEFAULT:
++ @perl -e '$(PERL_DEPENDENCIES_PROGRAM)'
+ endif
+
+ #############################################################################
+ # X dependency system
+ #############################################################################
+
+ ifdef MKDEPENDENCIES
+
diff --git a/dev-libs/nss/nss-3.11.1-r1.ebuild b/dev-libs/nss/nss-3.11.1-r1.ebuild
new file mode 100644
index 000000000000..1ce01d8c920d
--- /dev/null
+++ b/dev-libs/nss/nss-3.11.1-r1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nss/nss-3.11.1-r1.ebuild,v 1.1 2006/06/09 18:33:37 anarchy Exp $
+
+inherit eutils
+
+NSPR_VER="4.6.2"
+RTM_NAME="NSS_${PV//./_}_RTM"
+DESCRIPTION="Mozilla's Netscape Security Services Library that implements PKI support"
+HOMEPAGE="http://www.mozilla.org/projects/security/pki/nss/"
+SRC_URI="ftp://ftp.mozilla.org/pub/mozilla.org/security/nss/releases/${RTM_NAME}/src/${P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc
+ app-arch/zip
+ >=dev-libs/nspr-${NSPR_VER}"
+
+src_unpack() {
+ unpack ${A}
+
+ # hack nspr paths
+ echo 'INCLUDES += -I${ROOT}/usr/include/nspr -I$(DIST)/include/dbm' \
+ >> ${S}/mozilla/security/coreconf/headers.mk || die "failed to append include"
+
+ # cope with nspr being in /usr/$(get_libdir)/nspr
+ sed -e 's:$(DIST)/lib:${ROOT}/usr/'"$(get_libdir)"/nspr':' \
+ -i ${S}/mozilla/security/coreconf/location.mk
+
+ # modify install path
+ sed -e 's:SOURCE_PREFIX = $(CORE_DEPTH)/\.\./dist:SOURCE_PREFIX = $(CORE_DEPTH)/dist:' \
+ -i ${S}/mozilla/security/coreconf/source.mk
+
+ cd ${S}/mozilla
+ epatch ${FILESDIR}/${PN}-${PV}-perl.patch
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-3.11-config.patch
+ epatch ${FILESDIR}/${PN}-3.11-config-1.patch
+ epatch ${FILESDIR}/${PN}-mips64.patch
+}
+
+src_compile() {
+ if use amd64 || use ppc64 || use ia64 || use s390; then
+ export USE_64=1
+ fi
+ export NSDISTMODE=copy
+ cd ${S}/mozilla/security/coreconf
+ emake -j1 BUILD_OPT=1 || die "coreconf make failed"
+ cd ${S}/mozilla/security/dbm
+ emake -j1 BUILD_OPT=1 || die "dbm make failed"
+ cd ${S}/mozilla/security/nss
+ emake -j1 BUILD_OPT=1 || die "nss make failed"
+}
+
+src_install () {
+ MINOR_VERSION=11
+ cd ${S}/mozilla/security/dist
+
+ # put all *.a files in /usr/lib/nss (because some have conflicting names
+ # with existing libraries)
+ dodir /usr/$(get_libdir)/nss
+ cp -L */lib/*.so ${D}/usr/$(get_libdir)/nss || die "copying shared libs failed"
+ cp -L */lib/*.chk ${D}/usr/$(get_libdir)/nss || die "copying chk files failed"
+ cp -L */lib/*.a ${D}/usr/$(get_libdir)/nss || die "copying libs failed"
+
+ # all the include files
+ insinto /usr/include/nss
+ doins private/nss/*.h
+ doins public/nss/*.h
+ cd ${D}/usr/$(get_libdir)/nss
+ for file in *.so; do
+ mv ${file} ${file}.${MINOR_VERSION}
+ ln -s ${file}.${MINOR_VERSION} ${file}
+ done
+
+ # coping with nss being in a different path. We move up priority to
+ # ensure that nss/nspr are used specifically before searching elsewhere.
+ dodir /etc/env.d
+ echo "LDPATH=/usr/$(get_libdir)/nss" > ${D}/etc/env.d/08nss
+
+ dodir /usr/bin
+ dodir /usr/$(get_libdir)/pkgconfig
+ cp ${FILESDIR}/nss-config.in ${D}/usr/bin/nss-config
+ cp ${FILESDIR}/nss.pc.in ${D}/usr/$(get_libdir)/pkgconfig/nss.pc
+ NSS_VMAJOR=`cat ${S}/mozilla/security/nss/lib/nss/nss.h | grep "#define.*NSS_VMAJOR" | awk '{print $3}'`
+ NSS_VMINOR=`cat ${S}/mozilla/security/nss/lib/nss/nss.h | grep "#define.*NSS_VMINOR" | awk '{print $3}'`
+ NSS_VPATCH=`cat ${S}/mozilla/security/nss/lib/nss/nss.h | grep "#define.*NSS_VPATCH" | awk '{print $3}'`
+
+ sed -e "s,@libdir@,/usr/"$(get_libdir)"/nss,g" \
+ -e "s,@prefix@,/usr,g" \
+ -e "s,@exec_prefix@,\$\{prefix},g" \
+ -e "s,@includedir@,\$\{prefix}/include/nss,g" \
+ -e "s,@MOD_MAJOR_VERSION@,$NSS_VMAJOR,g" \
+ -e "s,@MOD_MINOR_VERSION@,$NSS_VMINOR,g" \
+ -e "s,@MOD_PATCH_VERSION@,$NSS_VPATCH,g" \
+ -i ${D}/usr/bin/nss-config
+ chmod 755 ${D}/usr/bin/nss-config
+
+ sed -e "s,@libdir@,/usr/"$(get_libdir)"/nss,g" \
+ -e "s,@prefix@,/usr,g" \
+ -e "s,@exec_prefix@,\$\{prefix},g" \
+ -e "s,@includedir@,\$\{prefix}/include/nss," \
+ -e "s,@NSPR_VERSION@,`nspr-config --version`,g" \
+ -e "s,@NSS_VERSION@,$NSS_VMAJOR.$NSS_VMINOR.$NSS_VPATCH,g" \
+ -i ${D}/usr/$(get_libdir)/pkgconfig/nss.pc
+ chmod 644 ${D}/usr/$(get_libdir)/pkgconfig/nss.pc
+}