summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2013-02-06 14:21:39 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2013-02-06 14:21:39 +0000
commit8637bab053f4d95385c16f7d5bc3366134998f53 (patch)
tree565a99ca9d6e4f6ca1a649291664815ddf1b594d /dev-libs
parentVersion bump to latest snapshot. (diff)
downloadgentoo-2-8637bab053f4d95385c16f7d5bc3366134998f53.tar.gz
gentoo-2-8637bab053f4d95385c16f7d5bc3366134998f53.tar.bz2
gentoo-2-8637bab053f4d95385c16f7d5bc3366134998f53.zip
Version bump for the latest, should fix few regressions of 50.1.1 where i tested.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/icu/ChangeLog8
-rw-r--r--dev-libs/icu/icu-50.1.2.ebuild118
2 files changed, 125 insertions, 1 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
index a0a65509738b..58d8a3334eec 100644
--- a/dev-libs/icu/ChangeLog
+++ b/dev-libs/icu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/icu
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.225 2013/02/02 10:53:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.226 2013/02/06 14:21:39 scarabeus Exp $
+
+*icu-50.1.2 (06 Feb 2013)
+
+ 06 Feb 2013; Tomáš Chvátal <scarabeus@gentoo.org> +icu-50.1.2.ebuild:
+ Version bump for the latest, should fix few regressions of 50.1.1 where i
+ tested.
02 Feb 2013; Alexis Ballier <aballier@gentoo.org> icu-50.1-r1.ebuild,
icu-50.1-r2.ebuild, icu-50.1.1.ebuild:
diff --git a/dev-libs/icu/icu-50.1.2.ebuild b/dev-libs/icu/icu-50.1.2.ebuild
new file mode 100644
index 000000000000..0bdd5630bd59
--- /dev/null
+++ b/dev-libs/icu/icu-50.1.2.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-50.1.2.ebuild,v 1.1 2013/02/06 14:21:39 scarabeus Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs base autotools
+
+DESCRIPTION="International Components for Unicode"
+HOMEPAGE="http://www.icu-project.org/"
+SRC_URI="http://download.icu-project.org/files/icu4c/${PV/_/}/icu4c-${PV//./_}-src.tgz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 -amd64-fbsd -x86-fbsd"
+IUSE="debug doc examples static-libs"
+
+DEPEND="
+ doc? (
+ app-doc/doxygen[dot]
+ )
+"
+
+S="${WORKDIR}/${PN}/source"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.8.1-fix_binformat_fonts.patch"
+ "${FILESDIR}/${PN}-4.8.1.1-fix_ltr.patch"
+)
+
+src_prepare() {
+ local variable
+
+ base_src_prepare
+
+ # Do not hardcode flags in icu-config and icu-*.pc files.
+ # https://ssl.icu-project.org/trac/ticket/6102
+ for variable in CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
+ sed \
+ -e "/^${variable} =.*/s: *@${variable}@\( *$\)\?::" \
+ -i config/icu.pc.in \
+ -i config/Makefile.inc.in \
+ || die
+ done
+
+ # Disable renaming as it is stupind thing to do
+ sed -i \
+ -e "s/#define U_DISABLE_RENAMING 0/#define U_DISABLE_RENAMING 1/" \
+ common/unicode/uconfig.h || die
+
+ # Fix linking of icudata
+ sed -i \
+ -e "s:LDFLAGSICUDT=-nodefaultlibs -nostdlib:LDFLAGSICUDT=:" \
+ config/mh-linux || die
+
+ # Append doxygen configuration to configure
+ sed -i \
+ -e 's:icudefs.mk:icudefs.mk Doxyfile:' \
+ configure.in || die
+ eautoreconf
+}
+
+src_configure() {
+ local cross_opts
+
+ # bootstrap for cross compilation
+ if tc-is-cross-compiler; then
+ CFLAGS="" CXXFLAGS="" ASFLAGS="" LDFLAGS="" \
+ CC="$(tc-getBUILD_CC)" CXX="$(tc-getBUILD_CXX)" AR="$(tc-getBUILD_AR)" \
+ RANLIB="$(tc-getBUILD_RANLIB)" LD="$(tc-getBUILD_LD)" \
+ ./configure --disable-renaming --disable-debug \
+ --disable-samples --enable-static || die
+ emake
+ mkdir -p "${WORKDIR}/host/"
+ cp -a {bin,lib,config,tools} "${WORKDIR}/host/"
+ emake clean
+
+ cross_opts="--with-cross-build=${WORKDIR}/host"
+ fi
+
+ econf \
+ --disable-renaming \
+ $(use_enable debug) \
+ $(use_enable examples samples) \
+ $(use_enable static-libs static) \
+ ${cross_opts}
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen -u Doxyfile || die
+ doxygen Doxyfile || die
+ fi
+}
+
+src_test() {
+ # INTLTEST_OPTS: intltest options
+ # -e: Exhaustive testing
+ # -l: Reporting of memory leaks
+ # -v: Increased verbosity
+ # IOTEST_OPTS: iotest options
+ # -e: Exhaustive testing
+ # -v: Increased verbosity
+ # CINTLTST_OPTS: cintltst options
+ # -e: Exhaustive testing
+ # -v: Increased verbosity
+ emake -j1 VERBOSE="1" check
+}
+
+src_install() {
+ default
+
+ dohtml ../readme.html
+
+ use doc && dohtml -p api -r doc/html/
+}