summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-08-30 20:26:09 +0000
committerPacho Ramos <pacho@gentoo.org>2010-08-30 20:26:09 +0000
commit8ae80e16c72d9adbdb800af12cee24cd136838c7 (patch)
tree4ce015fe30ed8b1affb1d5e7d9549997bac9499f /dev-libs
parentRemove unneeded RDEPEND, per configure and clean up unneeded src_prepare chan... (diff)
downloadgentoo-2-8ae80e16c72d9adbdb800af12cee24cd136838c7.tar.gz
gentoo-2-8ae80e16c72d9adbdb800af12cee24cd136838c7.tar.bz2
gentoo-2-8ae80e16c72d9adbdb800af12cee24cd136838c7.zip
Execute tests with emake instead of plain make and use ewarn instead of einfo.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libjit/ChangeLog6
-rw-r--r--dev-libs/libjit/libjit-0.1.2.ebuild10
2 files changed, 10 insertions, 6 deletions
diff --git a/dev-libs/libjit/ChangeLog b/dev-libs/libjit/ChangeLog
index e2f38101542a..a8ab8482911a 100644
--- a/dev-libs/libjit/ChangeLog
+++ b/dev-libs/libjit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/libjit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libjit/ChangeLog,v 1.13 2010/08/03 08:45:44 ali_bush Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libjit/ChangeLog,v 1.14 2010/08/30 20:26:09 pacho Exp $
+
+ 30 Aug 2010; Pacho Ramos <pacho@gentoo.org> libjit-0.1.2.ebuild:
+ Execute tests with emake instead of plain make and use ewarn instead of
+ einfo.
03 Aug 2010; Alistair Bush <ali_bush@gentoo.org> libjit-0.1.2.ebuild:
Fix tests and cleanup. See bug #327297.
diff --git a/dev-libs/libjit/libjit-0.1.2.ebuild b/dev-libs/libjit/libjit-0.1.2.ebuild
index a377cf716d49..f66cc43ea756 100644
--- a/dev-libs/libjit/libjit-0.1.2.ebuild
+++ b/dev-libs/libjit/libjit-0.1.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libjit/libjit-0.1.2.ebuild,v 1.2 2010/08/03 08:45:44 ali_bush Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libjit/libjit-0.1.2.ebuild,v 1.3 2010/08/30 20:26:09 pacho Exp $
EAPI=2
@@ -45,11 +45,11 @@ src_compile() {
src_test () {
if use interpreter || use long-double ; then
- make check || die "Tests failed."
+ emake check || die "Tests failed."
else
- ewarn "Skipping Tests due to missing use flags"
- einfo "Please enable either the interpreter or long-double use flags"
- einfo "if you want to run tests."
+ ewarn "Skipping Tests due to missing use flags:"
+ ewarn "Please enable either the interpreter or long-double use flags"
+ ewarn "if you want to run tests."
fi
}