summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Parpart <trapni@gentoo.org>2007-02-02 07:35:40 +0000
committerChristian Parpart <trapni@gentoo.org>2007-02-02 07:35:40 +0000
commitb25d7e4c7420761ecc1da5d635c7d7e245f8575c (patch)
treed2ef448e11362c540d28821c8289269e83b921f5 /dev-libs
parentstable x86; bug #153726 (diff)
downloadgentoo-2-b25d7e4c7420761ecc1da5d635c7d7e245f8575c.tar.gz
gentoo-2-b25d7e4c7420761ecc1da5d635c7d7e245f8575c.tar.bz2
gentoo-2-b25d7e4c7420761ecc1da5d635c7d7e245f8575c.zip
snapshot bump
(Portage version: 2.1.2-r5)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/swl/ChangeLog8
-rw-r--r--dev-libs/swl/files/digest-swl-0.5.0_pre200702023
-rw-r--r--dev-libs/swl/metadata.xml2
-rw-r--r--dev-libs/swl/swl-0.5.0_pre20070202.ebuild84
4 files changed, 95 insertions, 2 deletions
diff --git a/dev-libs/swl/ChangeLog b/dev-libs/swl/ChangeLog
index 2817ee345912..bff4d837c7e6 100644
--- a/dev-libs/swl/ChangeLog
+++ b/dev-libs/swl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/swl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/swl/ChangeLog,v 1.10 2007/01/31 19:49:21 trapni Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/swl/ChangeLog,v 1.11 2007/02/02 07:35:40 trapni Exp $
+
+*swl-0.5.0_pre20070202 (02 Feb 2007)
+
+ 02 Feb 2007; Christian Parpart <trapni@gentoo.org>
+ +swl-0.5.0_pre20070202.ebuild:
+ snapshot bump
31 Jan 2007; Christian Parpart <trapni@gentoo.org> -swl-0.4.0_rc4.ebuild,
-swl-0.4.0_rc5.ebuild, -swl-0.4.0_rc5-r1.ebuild, -swl-0.4.0_rc5-r2.ebuild:
diff --git a/dev-libs/swl/files/digest-swl-0.5.0_pre20070202 b/dev-libs/swl/files/digest-swl-0.5.0_pre20070202
new file mode 100644
index 000000000000..5d70feb0a6be
--- /dev/null
+++ b/dev-libs/swl/files/digest-swl-0.5.0_pre20070202
@@ -0,0 +1,3 @@
+MD5 dcbcac55d0aee2abea4626dd501e71b3 swl-0.5.0_pre20070202.tar.bz2 573173
+RMD160 421d0a1ab6b9b9d808f7f16b7d962752e8f9f6d4 swl-0.5.0_pre20070202.tar.bz2 573173
+SHA256 20f75c288b0b29fd1cf9fc4c3f2e092d290e76373a5d4e6b36e04f1c205d9fb2 swl-0.5.0_pre20070202.tar.bz2 573173
diff --git a/dev-libs/swl/metadata.xml b/dev-libs/swl/metadata.xml
index c30689c01a20..941f0afc3183 100644
--- a/dev-libs/swl/metadata.xml
+++ b/dev-libs/swl/metadata.xml
@@ -7,7 +7,7 @@
</maintainer>
<longdescription>
The purpose of the SurakWare Base Library (SWL/libswl) is to serve as a platform
-independent framework for C++ and QPascal. The SWL includes both thin layers
+independent framework for C++ (and QPascal). The SWL includes both thin layers
over functionality exposed by the Linux and Windows operating systems as well as
higher level classes for many purposes. Save for a few exceptions, the SWL is
completely indpedenent from the STL and the C/C++ runtime library. Platform
diff --git a/dev-libs/swl/swl-0.5.0_pre20070202.ebuild b/dev-libs/swl/swl-0.5.0_pre20070202.ebuild
new file mode 100644
index 000000000000..161646460e58
--- /dev/null
+++ b/dev-libs/swl/swl-0.5.0_pre20070202.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/swl/swl-0.5.0_pre20070202.ebuild,v 1.1 2007/02/02 07:35:40 trapni Exp $
+
+inherit flag-o-matic multilib
+
+DESCRIPTION="SWL is a C++ cross platform library."
+HOMEPAGE="http://battousai.mylair.de/swl/"
+SRC_URI="http://battousai.mylair.de/dist/swl/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+SLOT="0.5"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug doc"
+
+RDEPEND=">=sys-devel/gcc-3.4.3
+ >=sys-libs/glibc-2.3.4"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-1.5.22
+ >=sys-devel/automake-1.9.6
+ >=sys-devel/autoconf-2.59
+ doc? ( >=app-doc/doxygen-1.3.9.1 )"
+
+SWL_MODULES=(Core System System.Xml)
+
+src_unpack() {
+ unpack ${A} || die
+ cd ${S} || die
+}
+
+src_compile() {
+ use debug && append-flags -O0 -g3
+ use debug || append-flags -DNDEBUG=1
+
+ for module in ${SWL_MODULES[@]}; do
+ pushd ${module} || die
+
+ ./autogen.sh || die "autogen.sh failed"
+
+ ./configure \
+ --prefix="/usr" \
+ --host="${CHOST}" \
+ --libdir="/usr/$(get_libdir)" \
+ --without-tests \
+ --without-examples \
+ || die "./configure for ABI ${ABI} failed"
+
+ emake || die "make for ABI ${ABI} failed"
+
+ if use doc; then
+ #ewarn "TODO: generate docs {html,man} via doxygen"
+ #make -C doc api-docs
+ # XXX: install example/test files?
+ true
+ fi
+ popd
+ done
+}
+
+src_install() {
+ for module in ${SWL_MODULES[@]}; do
+ pushd ${module} || die
+
+ make install DESTDIR="${D}" || die
+
+ if use doc; then
+ #ewarn "TODO: install man-pages and html version via doxygen"
+ #dodoc -r doc/html
+ true
+ fi
+
+ for doc in AUTHORS ChangeLog* NEWS README* TODO; do
+ [[ -f $doc ]] || continue
+
+ mv ${doc}{,.${module}}
+
+ dodoc $doc.$module
+ done
+
+ popd
+ done
+}
+
+# vim:ai:noet:ts=4:nowrap