summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-02-14 23:50:43 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-02-14 23:50:43 +0000
commiteb5fd730972f2e9d19cd84a2dc5525b2bee022ca (patch)
tree5fcc243a176e5ff23e8037ec8a2daa4669a98876 /dev-libs
parentDTD is actually needed for build, bug #296717. Clean up old revision. (diff)
downloadgentoo-2-eb5fd730972f2e9d19cd84a2dc5525b2bee022ca.tar.gz
gentoo-2-eb5fd730972f2e9d19cd84a2dc5525b2bee022ca.tar.bz2
gentoo-2-eb5fd730972f2e9d19cd84a2dc5525b2bee022ca.zip
Version bump. Pass -fno-strict-aliasing to workaround gcc misoptimizations. Fix in :2.4 to avoid possible buffer overflows.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/gmime/ChangeLog10
-rw-r--r--dev-libs/gmime/gmime-2.2.25.ebuild (renamed from dev-libs/gmime/gmime-2.4.11.ebuild)34
-rw-r--r--dev-libs/gmime/gmime-2.4.15.ebuild (renamed from dev-libs/gmime/gmime-2.4.13.ebuild)2
3 files changed, 26 insertions, 20 deletions
diff --git a/dev-libs/gmime/ChangeLog b/dev-libs/gmime/ChangeLog
index 2b8a58fad3d0..5bb067677185 100644
--- a/dev-libs/gmime/ChangeLog
+++ b/dev-libs/gmime/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/gmime
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/ChangeLog,v 1.104 2010/01/21 22:25:43 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/ChangeLog,v 1.105 2010/02/14 23:50:43 eva Exp $
+
+*gmime-2.4.15 (14 Feb 2010)
+*gmime-2.2.25 (14 Feb 2010)
+
+ 14 Feb 2010; Gilles Dartiguelongue <eva@gentoo.org> +gmime-2.2.25.ebuild,
+ -gmime-2.4.11.ebuild, -gmime-2.4.13.ebuild, +gmime-2.4.15.ebuild:
+ Version bump. Pass -fno-strict-aliasing to workaround gcc
+ misoptimizations. Fix in :2.4 to avoid possible buffer overflows.
*gmime-2.4.13 (21 Jan 2010)
diff --git a/dev-libs/gmime/gmime-2.4.11.ebuild b/dev-libs/gmime/gmime-2.2.25.ebuild
index ab1b98981163..3593ff0b3357 100644
--- a/dev-libs/gmime/gmime-2.4.11.ebuild
+++ b/dev-libs/gmime/gmime-2.2.25.ebuild
@@ -1,24 +1,26 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/gmime-2.4.11.ebuild,v 1.4 2010/01/10 15:22:43 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/gmime-2.2.25.ebuild,v 1.1 2010/02/14 23:50:43 eva Exp $
-inherit gnome2 eutils mono libtool
+inherit gnome2 eutils mono libtool autotools
DESCRIPTION="Utilities for creating and parsing messages using MIME"
+#SRC_URI="http://spruce.sourceforge.net/${PN}/sources/v${PV%.*}/${P}.tar.gz"
HOMEPAGE="http://spruce.sourceforge.net/gmime/"
-SLOT="2.4"
+SLOT="0"
LICENSE="LGPL-2.1"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="doc mono"
-RDEPEND=">=dev-libs/glib-2.12
+RDEPEND=">=dev-libs/glib-2
sys-libs/zlib
mono? (
dev-lang/mono
>=dev-dotnet/gtk-sharp-2.4.0 )"
DEPEND="${RDEPEND}
dev-util/pkgconfig
+ dev-util/gtk-doc-am
doc? (
>=dev-util/gtk-doc-1.0
app-text/docbook-sgml-utils )
@@ -29,9 +31,10 @@ DOCS="AUTHORS ChangeLog COPYING INSTALL NEWS PORTING README TODO doc/html/"
src_unpack() {
unpack ${A}
cd "${S}"
-
+ epatch "${FILESDIR}/gmime-2.2.23-sign-assembly.patch"
+ cp "${FILESDIR}/gmime-sharp.snk" mono/
if use doc ; then
- # db2html should be docbook2html
+ #db2html should be docbook2html
sed -i -e 's:db2html:docbook2html -o gmime-tut:g' \
docs/tutorial/Makefile.am docs/tutorial/Makefile.in \
|| die "sed failed (1)"
@@ -40,23 +43,17 @@ src_unpack() {
gtk-doc.make docs/reference/Makefile.in || die "sed failed (3)"
fi
- # Use correct libdir for mono assembly
- sed -i -e 's:^libdir.*:libdir=@libdir@:' \
- -e 's:^prefix=:exec_prefix=:' \
- -e 's:prefix)/lib:libdir):' \
- mono/gmime-sharp-2.4.pc.in mono/Makefile.{am,in} || die "sed failed (2)"
-
+ eautoreconf
elibtoolize
}
src_compile() {
econf $(use_enable mono) $(use_enable doc gtk-doc)
- MONO_PATH="${S}" emake || die "emake failed"
+ MONO_PATH="${S}" emake || die "make failed"
}
src_install() {
- emake GACUTIL_FLAGS="/root '${D}/usr/$(get_libdir)' /gacdir /usr/$(get_libdir) /package ${PN}" \
- DESTDIR="${D}" install || die "installation failed"
+ emake DESTDIR="${D}" install || die "installation failed"
if use doc ; then
# we don't use docinto/dodoc, because we don't want html doc gzipped
@@ -66,6 +63,7 @@ src_install() {
# rename these two, so they don't conflict with app-arch/sharutils
# (bug #70392) Ticho, 2004-11-10
- mv "${D}/usr/bin/uuencode" "${D}/usr/bin/gmime-uuencode-${SLOT}"
- mv "${D}/usr/bin/uudecode" "${D}/usr/bin/gmime-uudecode-${SLOT}"
+ mv "${D}/usr/bin/uuencode" "${D}/usr/bin/gmime-uuencode"
+ mv "${D}/usr/bin/uudecode" "${D}/usr/bin/gmime-uudecode"
+ mono_multilib_comply
}
diff --git a/dev-libs/gmime/gmime-2.4.13.ebuild b/dev-libs/gmime/gmime-2.4.15.ebuild
index bc363522c252..64c8a59bde58 100644
--- a/dev-libs/gmime/gmime-2.4.13.ebuild
+++ b/dev-libs/gmime/gmime-2.4.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/gmime-2.4.13.ebuild,v 1.1 2010/01/21 22:25:43 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmime/gmime-2.4.15.ebuild,v 1.1 2010/02/14 23:50:43 eva Exp $
inherit gnome2 eutils mono libtool