summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-11-21 09:24:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-11-21 09:24:32 +0000
commitfc598573d0b125e7b3036f17d08da5187da11171 (patch)
tree414b784e65f2249c9c73b18b4a4f6a2677290fa7 /dev-libs
parentVersion bump. (diff)
downloadgentoo-2-fc598573d0b125e7b3036f17d08da5187da11171.tar.gz
gentoo-2-fc598573d0b125e7b3036f17d08da5187da11171.tar.bz2
gentoo-2-fc598573d0b125e7b3036f17d08da5187da11171.zip
Bump, fixes #293915
(Portage version: 2.2_rc51/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libelf/ChangeLog7
-rw-r--r--dev-libs/libelf/libelf-0.8.12.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-libs/libelf/ChangeLog b/dev-libs/libelf/ChangeLog
index 6c88312c057e..43653bc45b4d 100644
--- a/dev-libs/libelf/ChangeLog
+++ b/dev-libs/libelf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libelf
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/ChangeLog,v 1.27 2009/05/22 14:58:20 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/ChangeLog,v 1.28 2009/11/21 09:24:32 patrick Exp $
+
+*libelf-0.8.12 (21 Nov 2009)
+
+ 21 Nov 2009; Patrick Lauer <patrick@gentoo.org> +libelf-0.8.12.ebuild:
+ Bump, fixes #293915
22 May 2009; Alexis Ballier <aballier@gentoo.org> libelf-0.8.10.ebuild:
keyword ~sparc-fbsd
diff --git a/dev-libs/libelf/libelf-0.8.12.ebuild b/dev-libs/libelf/libelf-0.8.12.ebuild
new file mode 100644
index 000000000000..0e66d0893be7
--- /dev/null
+++ b/dev-libs/libelf/libelf-0.8.12.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libelf/libelf-0.8.12.ebuild,v 1.1 2009/11/21 09:24:32 patrick Exp $
+
+inherit multilib eutils
+
+DESCRIPTION="A ELF object file access library"
+HOMEPAGE="http://www.mr511.de/software/"
+SRC_URI="http://www.mr511.de/software/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="debug nls elibc_FreeBSD"
+
+DEPEND="!dev-libs/elfutils
+ nls? ( sys-devel/gettext )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use elibc_FreeBSD; then
+ # Stop libelf from stamping on the system nlist.h
+ sed -i -e 's:nlist.h::g' lib/Makefile.in || die
+
+ # Enable shared libs
+ sed -i \
+ -e 's:\*-linux\*\|\*-gnu\*:\*-linux\*\|\*-gnu\*\|\*-freebsd\*:' \
+ configure || die
+ fi
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ --enable-shared \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake -j1 \
+ prefix="${D}"/usr \
+ libdir="${D}"usr/$(get_libdir) \
+ install \
+ install-compat || die "emake install failed"
+ dodoc ChangeLog VERSION README
+}