summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2014-02-19 12:27:25 +0000
committerSergey Popov <pinkbyte@gentoo.org>2014-02-19 12:27:25 +0000
commitfd5b3b594d329d4e4932fc447d005460fecbf05c (patch)
treed84bd611b07acfc17b8ee857dbf65988c7d5e639 /dev-libs
parentsparc stable wrt bug #492104 (diff)
downloadgentoo-2-fd5b3b594d329d4e4932fc447d005460fecbf05c.tar.gz
gentoo-2-fd5b3b594d329d4e4932fc447d005460fecbf05c.tar.bz2
gentoo-2-fd5b3b594d329d4e4932fc447d005460fecbf05c.zip
Respect compiler, skip mono tests cause they are badly broken, bug #498484
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/Ice/ChangeLog5
-rw-r--r--dev-libs/Ice/Ice-3.5.1.ebuild21
2 files changed, 17 insertions, 9 deletions
diff --git a/dev-libs/Ice/ChangeLog b/dev-libs/Ice/ChangeLog
index 80e7f7e9b438..51e0c379d880 100644
--- a/dev-libs/Ice/ChangeLog
+++ b/dev-libs/Ice/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-libs/Ice
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/Ice/ChangeLog,v 1.30 2014/01/18 18:44:01 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/Ice/ChangeLog,v 1.31 2014/02/19 12:27:25 pinkbyte Exp $
+
+ 19 Feb 2014; Sergey Popov <pinkbyte@gentoo.org> Ice-3.5.1.ebuild:
+ Respect compiler, skip mono tests cause they are badly broken, bug #498484
18 Jan 2014; Pacho Ramos <pacho@gentoo.org> Ice-3.5.1.ebuild:
Revert as I was hitting bug #498484 but this the stab with the wrong bug
diff --git a/dev-libs/Ice/Ice-3.5.1.ebuild b/dev-libs/Ice/Ice-3.5.1.ebuild
index 6af3cbc6fc50..75c255ffe304 100644
--- a/dev-libs/Ice/Ice-3.5.1.ebuild
+++ b/dev-libs/Ice/Ice-3.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/Ice/Ice-3.5.1.ebuild,v 1.5 2014/01/18 18:44:01 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/Ice/Ice-3.5.1.ebuild,v 1.6 2014/02/19 12:27:25 pinkbyte Exp $
EAPI=5
@@ -80,10 +80,15 @@ src_prepare() {
-e 's|-f -root|-f -gacdir $(GAC_DIR) -root|' \
cs/config/Make.rules.cs || die "sed failed"
+ # skip mono tests, bug #498484
+ sed -i \
+ -e 's|^\(SUBDIRS.*\)test|\1|' \
+ cs/Makefile || die "sed failed"
+
if ! use test ; then
sed -i \
-e 's|^\(SUBDIRS.*\)test|\1|' \
- {cpp,cs,php,py,rb}/Makefile || die "sed failed"
+ {cpp,php,py,rb}/Makefile || die "sed failed"
fi
}
@@ -100,7 +105,7 @@ src_configure() {
MAKE_RULES="${MAKE_RULES} DB_FLAGS=-I$(db_includedir)"
sed -i \
- -e "s|c++|$(tc-getCXX)|" \
+ -e "s|g++|$(tc-getCXX)|" \
-e "s|\(CFLAGS[[:space:]]*=\)|\1 ${CFLAGS}|" \
-e "s|\(CXXFLAGS[[:space:]]*=\)|\1 ${CXXFLAGS}|" \
-e "s|\(LDFLAGS[[:space:]]*=\)|\1 ${LDFLAGS}|" \
@@ -131,9 +136,8 @@ src_configure() {
}
src_compile() {
- if tc-is-cross-compiler ; then
- export CXX="${CHOST}-g++"
- fi
+ # Do not remove this export or build will break!
+ tc-export CXX
emake -C cpp ${MAKE_RULES} || die "emake failed"
@@ -257,7 +261,8 @@ src_test() {
fi
if use mono ; then
-# ewarn "Tests for C# are currently disabled."
- run_tests cs || die "emake cs test failed"
+ # skip mono tests, bug #498484
+ ewarn "Tests for C# are currently disabled."
+# run_tests cs || die "emake cs test failed"
fi
}