summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-11-15 02:30:51 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-11-15 02:30:51 +0000
commit1be953de7c13c3ea265a514bc23ebf2186425203 (patch)
treec9d4ab113713e3f98c3850938a40dcecc682a420 /dev-lisp/cl-flexi-streams/cl-flexi-streams-0.8.0.ebuild
parentAdded a patch to support python 2.5 on the configure script. Fixes bug #148833. (diff)
downloadgentoo-2-1be953de7c13c3ea265a514bc23ebf2186425203.tar.gz
gentoo-2-1be953de7c13c3ea265a514bc23ebf2186425203.tar.bz2
gentoo-2-1be953de7c13c3ea265a514bc23ebf2186425203.zip
New upstream version.
(Portage version: 2.1.2_rc1-r6)
Diffstat (limited to 'dev-lisp/cl-flexi-streams/cl-flexi-streams-0.8.0.ebuild')
-rw-r--r--dev-lisp/cl-flexi-streams/cl-flexi-streams-0.8.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-lisp/cl-flexi-streams/cl-flexi-streams-0.8.0.ebuild b/dev-lisp/cl-flexi-streams/cl-flexi-streams-0.8.0.ebuild
new file mode 100644
index 000000000000..c04f30567a6e
--- /dev/null
+++ b/dev-lisp/cl-flexi-streams/cl-flexi-streams-0.8.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-flexi-streams/cl-flexi-streams-0.8.0.ebuild,v 1.1 2006/11/15 02:30:51 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="FLEXI-STREAMS implements \"virtual\" bivalent streams that can be layered atop real binary or bivalent streams."
+HOMEPAGE="http://weitz.de/flexi-streams/
+ http://www.cliki.net/flexi-streams"
+SRC_URI="http://common-lisp.net/project/portage-overlay/distfiles/flexi-streams_${PV}.orig.tar.gz"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND=">=dev-lisp/cl-trivial-gray-streams-20060925"
+SLOT="0"
+
+S=${WORKDIR}/${P/cl-}
+
+CLPACKAGE=flexi-streams
+
+src_install() {
+ common-lisp-install *.{lisp,asd}
+ common-lisp-system-symlink
+ dodoc CHANGELOG
+ dohtml doc/index.html
+ insinto /usr/share/doc/${PF}/html
+ doins doc/foo.txt
+}