summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-10-16 04:20:59 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-10-16 04:20:59 +0000
commitb0daf917c0b3090d8eb493a1f842dd97b58d529a (patch)
treeaa3b552b6108645aa4cb50caec42fc1492ac6bd9 /dev-lisp/cl-png/cl-png-0.4-r1.ebuild
parentMark 0.2.36-r2 ~ia64. #141223 (diff)
downloadgentoo-2-b0daf917c0b3090d8eb493a1f842dd97b58d529a.tar.gz
gentoo-2-b0daf917c0b3090d8eb493a1f842dd97b58d529a.tar.bz2
gentoo-2-b0daf917c0b3090d8eb493a1f842dd97b58d529a.zip
Load /lib/libz.so
(Portage version: 2.1.2_pre2-r9)
Diffstat (limited to 'dev-lisp/cl-png/cl-png-0.4-r1.ebuild')
-rw-r--r--dev-lisp/cl-png/cl-png-0.4-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-lisp/cl-png/cl-png-0.4-r1.ebuild b/dev-lisp/cl-png/cl-png-0.4-r1.ebuild
new file mode 100644
index 000000000000..2224c924bfc1
--- /dev/null
+++ b/dev-lisp/cl-png/cl-png-0.4-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-png/cl-png-0.4-r1.ebuild,v 1.1 2006/10/16 04:20:59 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Common Lisp package to read and write PNG image files"
+HOMEPAGE="http://www.pvv.ntnu.no/~musum/lisp/code/
+ http://www.cliki.net/PNG
+ http://packages.debian.org/unstable/devel/cl-png.html"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-png/cl-png_${PV}.orig.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND="dev-lisp/cl-uffi"
+
+CLPACKAGE=png
+
+src_unpack() {
+ unpack $A
+ epatch ${FILESDIR}/libz-path-gentoo.patch
+}
+
+src_install() {
+ common-lisp-install *.cl *.asd
+ common-lisp-system-symlink
+ dodoc COPYING README
+}