summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-05-21 06:42:03 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-05-21 06:42:03 +0000
commit53907cd9e614e3fd32726603a7f3ceab081e67b2 (patch)
tree01ea419d80436759e835a7993d346f65c3dd05ed /dev-lisp/cl-s-xml-rpc/cl-s-xml-rpc-20060521.ebuild
parentInitial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>. (diff)
downloadgentoo-2-53907cd9e614e3fd32726603a7f3ceab081e67b2.tar.gz
gentoo-2-53907cd9e614e3fd32726603a7f3ceab081e67b2.tar.bz2
gentoo-2-53907cd9e614e3fd32726603a7f3ceab081e67b2.zip
Updated CVS snapshot.
(Portage version: 2.1_rc1-r2)
Diffstat (limited to 'dev-lisp/cl-s-xml-rpc/cl-s-xml-rpc-20060521.ebuild')
-rw-r--r--dev-lisp/cl-s-xml-rpc/cl-s-xml-rpc-20060521.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-lisp/cl-s-xml-rpc/cl-s-xml-rpc-20060521.ebuild b/dev-lisp/cl-s-xml-rpc/cl-s-xml-rpc-20060521.ebuild
new file mode 100644
index 000000000000..1dcb5e234af0
--- /dev/null
+++ b/dev-lisp/cl-s-xml-rpc/cl-s-xml-rpc-20060521.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-s-xml-rpc/cl-s-xml-rpc-20060521.ebuild,v 1.1 2006/05/21 06:42:03 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="S-XML-RPC is an implementation of XML-RPC in Common Lisp for both client and server."
+HOMEPAGE="http://www.common-lisp.net/project/s-xml-rpc/"
+SRC_URI="mirror://gentoo/${P#cl-}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND="dev-lisp/cl-s-xml
+ dev-lisp/cl-s-base64
+ dev-lisp/cl-s-sysdeps"
+
+S=${WORKDIR}/${P#cl-}
+
+CLPACKAGE=s-xml-rpc
+
+src_unpack() {
+ unpack ${A}
+ test -f ${S}/Makefile && rm ${S}/Makefile
+}
+
+src_install() {
+ dodir /usr/share/common-lisp/source/${CLPACKAGE}
+ dodir /usr/share/common-lisp/systems
+ cp -R src test ${D}/usr/share/common-lisp/source/${CLPACKAGE}/
+ common-lisp-install ${CLPACKAGE}.asd
+ common-lisp-system-symlink
+ dosym /usr/share/common-lisp/source/${CLPACKAGE}/${CLPACKAGE}.asd \
+ /usr/share/common-lisp/systems/
+ dodoc ChangeLog
+}