summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-05-21 06:26:21 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-05-21 06:26:21 +0000
commit85fbdf132eb03ae65cf2f23abd02f4b456dcc24e (patch)
tree96d0974134724aeb468adeb2de3ffd91c566b34e /dev-lisp/cl-s-xml/cl-s-xml-20060521.ebuild
parentInitial port. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>. (diff)
downloadgentoo-2-85fbdf132eb03ae65cf2f23abd02f4b456dcc24e.tar.gz
gentoo-2-85fbdf132eb03ae65cf2f23abd02f4b456dcc24e.tar.bz2
gentoo-2-85fbdf132eb03ae65cf2f23abd02f4b456dcc24e.zip
New snapshot from CVS.
(Portage version: 2.1_rc1-r2)
Diffstat (limited to 'dev-lisp/cl-s-xml/cl-s-xml-20060521.ebuild')
-rw-r--r--dev-lisp/cl-s-xml/cl-s-xml-20060521.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-lisp/cl-s-xml/cl-s-xml-20060521.ebuild b/dev-lisp/cl-s-xml/cl-s-xml-20060521.ebuild
new file mode 100644
index 000000000000..dac83b494541
--- /dev/null
+++ b/dev-lisp/cl-s-xml/cl-s-xml-20060521.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-s-xml/cl-s-xml-20060521.ebuild,v 1.1 2006/05/21 06:26:21 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="S-XML is a simple XML parser implemented in Common Lisp."
+HOMEPAGE="http://www.common-lisp.net/project/s-xml/"
+SRC_URI="mirror://gentoo/s-xml-20040709.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND="virtual/commonlisp
+ dev-lisp/common-lisp-controller"
+
+S=${WORKDIR}/${PN#cl-}
+
+CLPACKAGE=s-xml
+
+src_unpack() {
+ unpack ${A}
+ rm ${S}/Makefile
+}
+
+src_install() {
+ dodir /usr/share/common-lisp/source/s-xml
+ dodir /usr/share/common-lisp/systems
+ cp -R src ${D}/usr/share/common-lisp/source/s-xml/
+ common-lisp-install s-xml.asd
+ common-lisp-system-symlink
+ dosym /usr/share/common-lisp/source/s-xml/s-xml.asd \
+ /usr/share/common-lisp/systems/
+}