summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2002-08-16 14:35:06 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2002-08-16 14:35:06 +0000
commit02e859783b7a0a48488bcd575f9347d65637334f (patch)
treefc73168f9c2f7b530878e680121f300e4e71bd01 /dev-lisp
parentadding exceptions for virtuals and use.defaults (diff)
downloadgentoo-2-02e859783b7a0a48488bcd575f9347d65637334f.tar.gz
gentoo-2-02e859783b7a0a48488bcd575f9347d65637334f.tar.bz2
gentoo-2-02e859783b7a0a48488bcd575f9347d65637334f.zip
Fixes #6408.
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/bigloo/ChangeLog8
-rw-r--r--dev-lisp/bigloo/bigloo-2.5a.ebuild70
-rw-r--r--dev-lisp/bigloo/files/digest-bigloo-2.5a1
3 files changed, 78 insertions, 1 deletions
diff --git a/dev-lisp/bigloo/ChangeLog b/dev-lisp/bigloo/ChangeLog
index 6cd3c8a97b76..1584f1e0ac63 100644
--- a/dev-lisp/bigloo/ChangeLog
+++ b/dev-lisp/bigloo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lisp/bigloo
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/bigloo/ChangeLog,v 1.2 2002/08/01 19:02:05 karltk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/bigloo/ChangeLog,v 1.3 2002/08/16 14:35:06 karltk Exp $
+
+*bigloo-2.5a (16 Aug 2002)
+
+ 16 Aug 2002; Karl Trygve Kalleberg <karltk@gentoo.org> bigloo-2.4a.ebuild, files/digest-bigloo-2.5a :
+
+ New upstream version.
*bigloo-2.4c (11 Apr 2002)
diff --git a/dev-lisp/bigloo/bigloo-2.5a.ebuild b/dev-lisp/bigloo/bigloo-2.5a.ebuild
new file mode 100644
index 000000000000..c69bc0cf4459
--- /dev/null
+++ b/dev-lisp/bigloo/bigloo-2.5a.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/bigloo/bigloo-2.5a.ebuild,v 1.1 2002/08/16 14:35:06 karltk Exp $
+
+S=${WORKDIR}/${PN}${PV}
+DESCRIPTION="Bigloo Scheme compiler for x86, sparc, alpha, ppc and JVM"
+SRC_URI="ftp://ftp-sop.inria.fr/mimosa/fp/Bigloo/bigloo${PV}.tar.gz"
+HOMEPAGE="http://www-sop.inria.fr/mimosa/fp/Bigloo/bigloo.html"
+DEPEND=""
+#RDEPEND=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86"
+
+src_compile() {
+ local myconf
+ local myjava=`java-config --java`
+ local myjavac=`java-config --javac`
+
+ use java &&
+ myconf="--jvm=force --java=$myjava --javac=$myjavac" \
+ || myconf="--jvm=no"
+
+
+ ./configure \
+ --native=yes \
+ --cflags="${CFLAGS}" \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man/man1 \
+ --docdir=/usr/share/doc/${PV} \
+ $myconf || die "./configure failed"
+
+ cp Makefile.config Makefile.config.orig
+ sed "s/JCFLAGS=-O/JCFLAGS=/" \
+ < Makefile.config.orig \
+ > Makefile.config
+ echo LD_LIBRARY_PATH=${S}/lib/${PV} >> Makefile.config
+
+ cp bde/Makefile bde/Makefile.orig
+ sed "s/\$(BOOTBINDIR)\/afile jas/LD_LIBRARY_PATH=\$(LD_LIBRARY_PATH) \$(BOOTBINDIR)\/afile jas/" \
+ < bde/Makefile.orig \
+ > bde/Makefile
+
+ cp Makefile.config Makefile.config.fixed
+
+ make || die
+}
+
+src_install () {
+ dodir /usr/bin
+ dodir /usr/lib
+ dodir /usr/share/doc/${PF}
+ dodir /usr/share/man/man1
+ dodir /usr/share/info
+
+ sed \
+ -e "s:^BINDIR=\(.*\):BINDIR=${D}\1:" \
+ -e "s:^LIBDIR=\(.*\):LIBDIR=${D}\1:" \
+ -e "s:^MANDIR=\(.*\):MANDIR=${D}\1:" \
+ -e "s:^INFODIR=\(.*\):INFODIR=${D}\1:" \
+ -e "s:^DOCDIR=\(.*\):DOCDIR=${D}\1:" \
+ < Makefile.config.fixed \
+ > Makefile.config
+
+ dodir /etc/env.d
+ echo "LDPATH=/usr/lib/bigloo/${PV}/" \
+ > ${D}/etc/env.d/25bigloo
+ make install || die
+}
diff --git a/dev-lisp/bigloo/files/digest-bigloo-2.5a b/dev-lisp/bigloo/files/digest-bigloo-2.5a
new file mode 100644
index 000000000000..1dd3b1191c71
--- /dev/null
+++ b/dev-lisp/bigloo/files/digest-bigloo-2.5a
@@ -0,0 +1 @@
+MD5 3fbf13769c096e5ca2d0f927cfde4eff bigloo2.5a.tar.gz 8060988