summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-08-27 00:29:32 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-08-27 00:29:32 +0000
commit6f953729edc6e40bc1cdbb7dfc63280ac531e3fa (patch)
treee17693f07d4fdb16f550f3272b8e74eadf42719e /dev-lisp
parentversion bump (diff)
downloadgentoo-2-6f953729edc6e40bc1cdbb7dfc63280ac531e3fa.tar.gz
gentoo-2-6f953729edc6e40bc1cdbb7dfc63280ac531e3fa.tar.bz2
gentoo-2-6f953729edc6e40bc1cdbb7dfc63280ac531e3fa.zip
version bump
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/cl-uffi/ChangeLog7
-rw-r--r--dev-lisp/cl-uffi/Manifest6
-rw-r--r--dev-lisp/cl-uffi/cl-uffi-1.3.4.ebuild57
-rw-r--r--dev-lisp/cl-uffi/files/digest-cl-uffi-1.3.41
-rw-r--r--dev-lisp/cl-uffi/files/uffi-tests.asd37
-rw-r--r--dev-lisp/cl-uffi/files/uffi.asd48
6 files changed, 66 insertions, 90 deletions
diff --git a/dev-lisp/cl-uffi/ChangeLog b/dev-lisp/cl-uffi/ChangeLog
index 451ae4489dfc..4555a19cb10b 100644
--- a/dev-lisp/cl-uffi/ChangeLog
+++ b/dev-lisp/cl-uffi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lisp/cl-uffi
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-uffi/ChangeLog,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-uffi/ChangeLog,v 1.2 2003/08/27 00:29:29 mkennedy Exp $
+
+*cl-uffi-1.3.4 (26 Aug 2003)
+
+ 26 Aug 2003; Matthew Kennedy <mkennedy@gentoo.org> cl-uffi-1.3.4.ebuild:
+ version bump, install test suite and re-arrange installed structure
*cl-uffi-1.2.15 (07 Jul 2003)
diff --git a/dev-lisp/cl-uffi/Manifest b/dev-lisp/cl-uffi/Manifest
index f149804471f8..6e4e8a5d6600 100644
--- a/dev-lisp/cl-uffi/Manifest
+++ b/dev-lisp/cl-uffi/Manifest
@@ -1,7 +1,5 @@
-MD5 13cf8918d544b7faebeec1af306f441d cl-uffi-1.3.4.ebuild 1447
-MD5 0ea15a85b95e4fedb9957b94690ee220 ChangeLog 440
+MD5 2f062b9d8d5ed562fab6c986f2218948 cl-uffi-1.3.4.ebuild 1603
+MD5 4c6d9e6160414e02e20c78c8ab4dd248 ChangeLog 495
MD5 13cf8918d544b7faebeec1af306f441d cl-uffi-1.2.15.ebuild 1447
-MD5 ce1b5bdea8359eac972f36fd409c1d9e files/uffi-tests.asd 1441
MD5 8d8994078a8508087061fe8f385a1bea files/digest-cl-uffi-1.3.4 62
-MD5 175003894efc92fdaed39c27e2d98b8a files/uffi.asd 1953
MD5 dc8b389800029795c6c5fb5573049e89 files/digest-cl-uffi-1.2.15 63
diff --git a/dev-lisp/cl-uffi/cl-uffi-1.3.4.ebuild b/dev-lisp/cl-uffi/cl-uffi-1.3.4.ebuild
new file mode 100644
index 000000000000..7fe6c46ea776
--- /dev/null
+++ b/dev-lisp/cl-uffi/cl-uffi-1.3.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-uffi/cl-uffi-1.3.4.ebuild,v 1.1 2003/08/27 00:29:29 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="UFFI is a package to [portably] interface Common Lisp programs with C-language compatible libraries."
+HOMEPAGE="http://uffi.med-info.com/"
+SRC_URI="http://files.b9.com/uffi/uffi-${PV}.tar.gz"
+LICENSE="LLGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+S=${WORKDIR}/uffi-${PV}
+
+src_compile() {
+ make -C tests linux
+}
+
+src_install() {
+ dodir /usr/share/common-lisp/systems
+ insinto /usr/share/common-lisp/source/uffi/src
+ doins src/*.lisp
+ insinto /usr/share/common-lisp/source/uffi
+ doins uffi.asd
+ dosym /usr/share/common-lisp/source/uffi/uffi.asd /usr/share/common-lisp/systems/uffi.asd
+
+ insinto /usr/share/common-lisp/source/uffi-tests/tests
+ doins tests/*.lisp
+ insinto /usr/share/common-lisp/source/uffi-tests/
+ doins uffi-tests.asd
+ dosym /usr/share/common-lisp/source/uffi-tests/uffi-tests.asd /usr/share/common-lisp/systems/uffi-tests.asd
+
+ insinto /usr/lib/uffi
+ doins tests/*.so
+
+ dodoc AUTHORS ChangeLog INSTALL LICENSE NEWS README TODO doc/uffi.pdf doc/COPYING.GFDL
+ tar xfz doc/html.tar.gz
+ dohtml html/*
+
+ for i in examples benchmarks ; do
+ insinto /usr/share/doc/${P}/$i
+ doins $i/*
+ done
+}
+
+pkg_postinst() {
+ /usr/sbin/register-common-lisp-source uffi
+ /usr/sbin/register-common-lisp-source uffi-tests
+}
+
+pkg_prerm() {
+ /usr/sbin/unregister-common-lisp-source uffi
+ /usr/sbin/unregister-common-lisp-source uffi-tests
+}
+
diff --git a/dev-lisp/cl-uffi/files/digest-cl-uffi-1.3.4 b/dev-lisp/cl-uffi/files/digest-cl-uffi-1.3.4
new file mode 100644
index 000000000000..2c85ab636573
--- /dev/null
+++ b/dev-lisp/cl-uffi/files/digest-cl-uffi-1.3.4
@@ -0,0 +1 @@
+MD5 0bdd9827a9e01eb753d1af5b472faa0a uffi-1.3.4.tar.gz 216957
diff --git a/dev-lisp/cl-uffi/files/uffi-tests.asd b/dev-lisp/cl-uffi/files/uffi-tests.asd
deleted file mode 100644
index a140021faadf..000000000000
--- a/dev-lisp/cl-uffi/files/uffi-tests.asd
+++ /dev/null
@@ -1,37 +0,0 @@
-;;;; -*- Mode: Lisp; Syntax: ANSI-Common-Lisp; Base: 10 -*-
-;;;; *************************************************************************
-;;;; FILE IDENTIFICATION
-;;;;
-;;;; Name: uffi-tests.asd
-;;;; Purpose: ASDF system definitionf for uffi testing package
-;;;; Author: Kevin M. Rosenberg
-;;;; Date Started: Apr 2003
-;;;;
-;;;; $Id: uffi-tests.asd,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
-;;;; *************************************************************************
-
-(defpackage #:uffi-tests-system
- (:use #:asdf #:cl))
-(in-package #:uffi-tests-system)
-
-(defsystem uffi-tests
- :depends-on (:uffi)
- :components
- ((:file "rt")
- (:file "package" :depends-on ("rt"))
- (:file "strtol" :depends-on ("package"))
- (:file "atoifl" :depends-on ("package"))
- (:file "getenv" :depends-on ("package"))
- (:file "gethostname" :depends-on ("package"))
- (:file "union" :depends-on ("package"))
- (:file "arrays" :depends-on ("package"))
- (:file "time" :depends-on ("package"))
- (:file "foreign-loader" :depends-on ("package"))
- (:file "compress" :depends-on ("foreign-loader"))
- (:file "uffi-c-test-lib" :depends-on ("foreign-loader"))
- ))
-
-(defmethod perform ((o test-op) (c (eql (find-system :uffi-tests))))
- (or (funcall (intern (symbol-name '#:do-tests)
- (find-package '#:regression-test)))
- (error "test-op failed")))
diff --git a/dev-lisp/cl-uffi/files/uffi.asd b/dev-lisp/cl-uffi/files/uffi.asd
deleted file mode 100644
index 34c2ce468f80..000000000000
--- a/dev-lisp/cl-uffi/files/uffi.asd
+++ /dev/null
@@ -1,48 +0,0 @@
-;;;; -*- Mode: Lisp; Syntax: ANSI-Common-Lisp; Base: 10 -*-
-;;;; *************************************************************************
-;;;; FILE IDENTIFICATION
-;;;;
-;;;; Name: uffi.asd
-;;;; Purpose: ASDF system definition file for UFFI package
-;;;; Author: Kevin M. Rosenberg
-;;;; Date Started: Aug 2002
-;;;;
-;;;; $Id: uffi.asd,v 1.1 2003/06/10 04:53:04 mkennedy Exp $
-;;;;
-;;;; This file, part of UFFI, is Copyright (c) 2002 by Kevin M. Rosenberg
-;;;;
-;;;; UFFI users are granted the rights to distribute and use this software
-;;;; as governed by the terms of the Lisp Lesser GNU Public License
-;;;; (http://opensource.franz.com/preamble.html), also known as the LLGPL.
-;;;; *************************************************************************
-
-(defpackage #:uffi-system (:use #:asdf #:cl))
-(in-package #:uffi-system)
-
-#+(or allegro lispworks cmu mcl cormanlisp sbcl scl)
-(defsystem uffi
- :name "uffi"
- :author "Kevin Rosenberg <kevin@rosenberg.net>"
- :version "1.2.x"
- :maintainer "Kevin M. Rosenberg <kmr@debian.org>"
- :licence "Lessor Lisp General Public License"
- :description "Universal Foreign Function Library for Common Lisp"
- :long-description "UFFI provides a universal foreign function interface (FFI) for Common Lisp. UFFI supports CMUCL, Lispworks, and AllegroCL."
-
- :components
- ((:file "package")
- (:file "primitives" :depends-on ("package"))
- #+mcl (:file "readmacros-mcl" :depends-on ("package"))
- (:file "strings" :depends-on ("primitives"))
- (:file "objects" :depends-on ("primitives"))
- (:file "aggregates" :depends-on ("primitives"))
- (:file "functions" :depends-on ("primitives"))
- (:file "libraries" :depends-on ("package"))
- (:file "os" :depends-on ("package"))))
-
-#+(or allegro lispworks cmu mcl cormanlisp sbcl scl)
-(defmethod perform ((o test-op) (c (eql (find-system :uffi))))
- (oos 'load-op 'uffi-tests)
- (oos 'test-op 'uffi-tests))
-
-