summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2015-02-20 16:48:02 +0000
committerAndrey Grozin <grozin@gentoo.org>2015-02-20 16:48:02 +0000
commit80253259e7825e5848f7e4b2e8130c30ae4317a7 (patch)
tree2f4ce09d6a53b4a3a28eb522858d59e066e88f14 /dev-lisp
parentRemove old. (diff)
downloadgentoo-2-80253259e7825e5848f7e4b2e8130c30ae4317a7.tar.gz
gentoo-2-80253259e7825e5848f7e4b2e8130c30ae4317a7.tar.bz2
gentoo-2-80253259e7825e5848f7e4b2e8130c30ae4317a7.zip
Cleaning old (#540808)
(Portage version: 2.2.17/cvs/Linux i686, signed Manifest commit with key 0x3AFFCE974D34BD8C!)
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/clisp/ChangeLog8
-rw-r--r--dev-lisp/clisp/clisp-2.47-r1.ebuild136
-rw-r--r--dev-lisp/clisp/files/pari.patch25
3 files changed, 6 insertions, 163 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
index 39bc4b7bdf3a..7a08eada0be7 100644
--- a/dev-lisp/clisp/ChangeLog
+++ b/dev-lisp/clisp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/clisp
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.114 2014/12/28 15:36:16 titanofold Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.115 2015/02/20 16:48:02 grozin Exp $
+
+ 20 Feb 2015; Andrey Grozin <grozin@gentoo.org> -clisp-2.47-r1.ebuild,
+ -files/pari.patch:
+ Cleaning old (#540808)
28 Dec 2014; Aaron W. Swenson <titanofold@gentoo.org> clisp-2.47-r1.ebuild,
clisp-2.48-r1.ebuild, clisp-2.48-r2.ebuild, clisp-2.49-r8.ebuild:
diff --git a/dev-lisp/clisp/clisp-2.47-r1.ebuild b/dev-lisp/clisp/clisp-2.47-r1.ebuild
deleted file mode 100644
index b7ec1537765c..000000000000
--- a/dev-lisp/clisp/clisp-2.47-r1.ebuild
+++ /dev/null
@@ -1,136 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.47-r1.ebuild,v 1.10 2014/12/28 15:36:16 titanofold Exp $
-
-EAPI=1
-inherit flag-o-matic eutils toolchain-funcs multilib
-
-DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
-HOMEPAGE="http://clisp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
-LICENSE="GPL-2"
-
-# EAPI="1"
-SLOT="2"
-KEYWORDS="alpha amd64 ia64 ppc -sparc x86"
-IUSE="hyperspec X new-clx dbus fastcgi gdbm gtk pari pcre postgres readline svm zlib"
-
-RDEPEND="virtual/libiconv
- >=dev-libs/libsigsegv-2.4
- >=dev-libs/ffcall-1.10
- dbus? ( sys-apps/dbus )
- fastcgi? ( dev-libs/fcgi )
- gdbm? ( sys-libs/gdbm )
- gtk? ( >=x11-libs/gtk+-2.10:2 >=gnome-base/libglade-2.6:2.0 )
- pari? ( >=sci-mathematics/pari-2.3.0 )
- postgres? ( >=dev-db/postgresql-8.0 )
- readline? ( >=sys-libs/readline-5.0 )
- pcre? ( dev-libs/libpcre )
- svm? ( sci-libs/libsvm )
- zlib? ( sys-libs/zlib )
- X? ( new-clx? ( x11-libs/libXpm ) )
- hyperspec? ( dev-lisp/hyperspec )"
-# berkdb? ( sys-libs/db:4.5 )
-
-DEPEND="${RDEPEND} X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
-
-PDEPEND="dev-lisp/gentoo-init"
-
-enable_modules() {
- [[ $# = 0 ]] && die "${FUNCNAME[0]} must receive at least one argument"
- for m in "$@" ; do
- einfo "enabling module $m"
- myconf="${myconf} --with-module=${m}"
- done
-}
-
-BUILDDIR="builddir"
-
-# modules not enabled:
-# * berkdb: must figure out a way to make the configure script pick up the
-# currect version of the library and headers
-# * dirkey: fails to compile, requiring windows.h, possibly wrong #ifdefs
-# * matlab, netica: not in portage
-# * oracle: can't install oracle-instantclient
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/pari.patch #bug 246074
-
- # More than -O1 breaks alpha/ia64
- use alpha || use ia64 && sed -i -e 's/-O2//g' src/makemake.in
-}
-
-src_compile() {
- # built-in features
- local myconf="--with-ffcall --with-dynamic-modules"
- use readline || myconf="${myconf} --with-noreadline"
-
- # We need this to build on alpha/ia64
- if use alpha || use ia64; then
- replace-flags -O? -O1
- append-flags '-D NO_MULTIMAP_SHM -D NO_MULTIMAP_FILE -D NO_SINGLEMAP -D NO_TRIVIALMAP'
- fi
- # default modules
- enable_modules wildcard rawsock
- # optional modules
- use elibc_glibc && enable_modules bindings/glibc
- if use X; then
- if use new-clx; then
- enable_modules clx/new-clx
- else
- enable_modules clx/mit-clx
- fi
- fi
- if use postgres; then
- enable_modules postgresql
- CPPFLAGS="-I $(pg_config --includedir)"
- fi
-# if use berkdb; then
-# enable_modules berkley-db
-# CPPFLAGS="${CPPFLAGS} -I /usr/include/db4.5"
-# fi
- use dbus && enable_modules dbus
- use fastcgi && enable_modules fastcgi
- use gdbm && enable_modules gdbm
- use gtk && enable_modules gtk2
- use pari && enable_modules pari
- use pcre && enable_modules pcre
- use svm && enable_modules libsvm
- use zlib && enable_modules zlib
-
- if use hyperspec; then
- CLHSROOT="file:///usr/share/doc/hyperspec/HyperSpec/"
- else
- CLHSROOT="http://www.lispworks.com/reference/HyperSpec/"
- fi
-
- # configure chokes on --infodir option
- local configure="./configure --prefix=/usr --libdir=/usr/$(get_libdir) \
- ${myconf} --hyperspec=${CLHSROOT} ${BUILDDIR}"
- einfo "${configure}"
- ${configure} || die "./configure failed"
-
- cd ${BUILDDIR}
- sed -i 's,"vi","nano",g' config.lisp
- IMPNOTES="file://${ROOT%/}/usr/share/doc/${PN}-${PVR}/html/impnotes.html"
- sed -i "s,http://clisp.cons.org/impnotes/,${IMPNOTES},g" config.lisp
- # parallel build fails
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- pushd ${BUILDDIR}
- make DESTDIR="${D}" prefix=/usr install-bin || die
- doman clisp.1
- dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE clisp.dvi clisp.html
- chmod a+x "${D}"/usr/$(get_libdir)/clisp-${PV/_*/}/clisp-link
- # stripping them removes common symbols (defined but unitialised variables)
- # which are then needed to build modules...
- export STRIP_MASK="*/usr/$(get_libdir)/clisp-${PV}/*/*"
- popd
- dohtml doc/impnotes.{css,html} doc/regexp.html doc/clisp.png
- dodoc doc/{editors,CLOS-guide,LISP-tutorial}.txt
-}
diff --git a/dev-lisp/clisp/files/pari.patch b/dev-lisp/clisp/files/pari.patch
deleted file mode 100644
index 420dd0a5b2fb..000000000000
--- a/dev-lisp/clisp/files/pari.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-commit d6d89b33bee20879c4cef3b7fcc9c4d42c4b6eff
-Author: sds <sds>
-Date: Thu Jan 8 02:56:33 2009 +0000
-
- fix bug #[ 2492106 ]: CLISP 2.47/amd64 can't build "pari" module
- (new_galois_format, factor_add_primes): fix type declarations
-
-diff --git a/modules/pari/pari.lisp b/modules/pari/pari.lisp
-index d5cf89d..d5586d3 100644
---- a/modules/pari/pari.lisp
-+++ b/modules/pari/pari.lisp
-@@ -165,9 +165,9 @@
- (and e (foreign-value e))))
-
- ;; extern int new_galois_format;
--(def-c-var new_galois_format (:type (c-ptr int)))
-+(def-c-var new_galois_format (:type int))
- ;; extern int factor_add_primes;
--(def-c-var factor_add_primes (:type (c-ptr int)))
-+(def-c-var factor_add_primes (:type int))
-
- ;; extern ulong DEBUGFILES, DEBUGLEVEL, DEBUGMEM
- (def-c-var debugfiles (:name "DEBUGFILES") (:type ulong))
-diff --git a/src/ChangeLog b/src/ChangeLog
-index 4f386a3..410b02b 100644