summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2005-03-27 15:18:54 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2005-03-27 15:18:54 +0000
commit8b15362c7efb64a7c1ffbce8fa1b9747e0356549 (patch)
tree4f8b1762f28822f8bef8c9c7aa03bebfbcfe9d77 /dev-ml/netclient/netclient-0.90.4.ebuild
parentCleanup dir, add ppc keyword to latest version. (Manifest recommit) (diff)
downloadgentoo-2-8b15362c7efb64a7c1ffbce8fa1b9747e0356549.tar.gz
gentoo-2-8b15362c7efb64a7c1ffbce8fa1b9747e0356549.tar.bz2
gentoo-2-8b15362c7efb64a7c1ffbce8fa1b9747e0356549.zip
Added experimental version, moved stable one to stable on ppc.
Diffstat (limited to 'dev-ml/netclient/netclient-0.90.4.ebuild')
-rw-r--r--dev-ml/netclient/netclient-0.90.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/netclient/netclient-0.90.4.ebuild b/dev-ml/netclient/netclient-0.90.4.ebuild
new file mode 100644
index 000000000000..72cb4775b541
--- /dev/null
+++ b/dev-ml/netclient/netclient-0.90.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/netclient/netclient-0.90.4.ebuild,v 1.1 2005/03/27 15:18:54 mattam Exp $
+
+inherit findlib
+
+DESCRIPTION="HTTP 1.0/1.1 client OCaml component"
+HOMEPAGE="http://www.ocaml-programming.de/programming/netclient.html"
+LICENSE="as-is"
+DEPEND=">=dev-lang/ocaml-3.08
+ dev-ml/equeue
+ dev-ml/ocamlnet
+ threads? ( dev-ml/xstr )"
+SRC_URI="http://www.ocaml-programming.de/packages/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="doc threads"
+
+src_compile() {
+ local targets="all opt"
+ use threads || targets="non_mt non_mt_opt "
+ make ${targets} || die "Compilation failed"
+}
+
+src_install () {
+ findlib_src_install
+ dodoc LICENSE README
+ if use doc ; then
+ for dir in examples/*
+ do
+ insinto /usr/share/doc/${PF}/$dir
+ doins $dir/*
+ done
+ fi
+}