summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-05-23 23:36:02 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-05-23 23:36:02 +0000
commitf67d21d55b75e638c1749423d6499953ab068fba (patch)
tree800f416b453aa2cbc61dd4bedfd6d859b8d4e4be /dev-ml/ocaml-mysql
parentVersion bump for stable channel release. (diff)
downloadgentoo-2-f67d21d55b75e638c1749423d6499953ab068fba.tar.gz
gentoo-2-f67d21d55b75e638c1749423d6499953ab068fba.tar.bz2
gentoo-2-f67d21d55b75e638c1749423d6499953ab068fba.zip
version bump
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/ocaml-mysql')
-rw-r--r--dev-ml/ocaml-mysql/ChangeLog9
-rw-r--r--dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-ml/ocaml-mysql/ChangeLog b/dev-ml/ocaml-mysql/ChangeLog
index 5714e58b36c0..680d638b42b6 100644
--- a/dev-ml/ocaml-mysql/ChangeLog
+++ b/dev-ml/ocaml-mysql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocaml-mysql
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-mysql/ChangeLog,v 1.10 2009/09/28 16:54:47 betelgeuse Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-mysql/ChangeLog,v 1.11 2012/05/23 23:36:02 aballier Exp $
+
+*ocaml-mysql-1.1.1 (23 May 2012)
+
+ 23 May 2012; Alexis Ballier <aballier@gentoo.org> +ocaml-mysql-1.1.1.ebuild:
+ version bump
28 Sep 2009; Petteri Räty <betelgeuse@gentoo.org>
ocaml-mysql-1.0.4.ebuild:
diff --git a/dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild b/dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild
new file mode 100644
index 000000000000..c1031ffc88b9
--- /dev/null
+++ b/dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild,v 1.1 2012/05/23 23:36:02 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to mysql databases."
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/870/${P}.tar.gz"
+HOMEPAGE="http://ocaml-mysql.forge.ocamlcore.org/"
+
+DEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ sys-libs/zlib
+ >=virtual/mysql-4.0"
+
+RDEPEND="$DEPEND"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile()
+{
+ emake all || die "make failed"
+ if use ocamlopt; then
+ emake opt || die "make opt failed"
+ fi
+}
+
+src_install()
+{
+ findlib_src_preinst
+ emake install || die "make install failed"
+
+ dodoc CHANGES README VERSION || die
+}