summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-08-21 19:27:30 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-08-21 19:27:30 +0000
commit3098ef41e895e12dd23cea18bf1a586987df8a08 (patch)
treefd77c7e5bfa391b94c88f23bc9847f3a4b6c9efc /dev-ml/res/res-2.1.1.ebuild
parentcorresponding changelog entry (Manifest recommit) (diff)
downloadgentoo-2-3098ef41e895e12dd23cea18bf1a586987df8a08.tar.gz
gentoo-2-3098ef41e895e12dd23cea18bf1a586987df8a08.tar.bz2
gentoo-2-3098ef41e895e12dd23cea18bf1a586987df8a08.zip
Initial import, fixes bug #60921.
Diffstat (limited to 'dev-ml/res/res-2.1.1.ebuild')
-rw-r--r--dev-ml/res/res-2.1.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/res/res-2.1.1.ebuild b/dev-ml/res/res-2.1.1.ebuild
new file mode 100644
index 000000000000..99b95ce7e8b5
--- /dev/null
+++ b/dev-ml/res/res-2.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/res/res-2.1.1.ebuild,v 1.1 2004/08/21 19:27:30 mattam Exp $
+
+inherit findlib
+
+DESCRIPTION="Resizable Array and Buffer modules for O'Caml"
+HOMEPAGE="http://www.oefai.at/~markus/home/ocaml_sources.html"
+SRC_URI="http://www.oefai.at/~markus/ocaml_sources/${P}.tar.bz2"
+LICENSE="LGPL-2.1"
+
+DEPEND=">=dev-lang/ocaml-3.07"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+IUSE="doc"
+
+src_compile() {
+ make all || die
+
+ if use doc; then
+ cd lib && make htdoc
+ fi
+}
+
+src_install () {
+ findlib_src_install
+
+ # install documentation
+ dodoc LICENSE README TODO VERSION Changes
+
+ if use doc; then
+ dohtml lib/doc/html/*
+ fi
+}