summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-06-25 18:55:39 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-06-25 18:55:39 +0000
commit0f58f7f51a7d0c91bce5a0b745d1b2807cb03d42 (patch)
treef75b11409b929070eeccf71908dd53976e04ec8e /dev-ml/type-conv
parentalpha/sparc stable wrt #369897 (diff)
downloadgentoo-2-0f58f7f51a7d0c91bce5a0b745d1b2807cb03d42.tar.gz
gentoo-2-0f58f7f51a7d0c91bce5a0b745d1b2807cb03d42.tar.bz2
gentoo-2-0f58f7f51a7d0c91bce5a0b745d1b2807cb03d42.zip
version bump, by Vladimir Ivanov, bug #361153
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/type-conv')
-rw-r--r--dev-ml/type-conv/ChangeLog9
-rw-r--r--dev-ml/type-conv/type-conv-2.3.0.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/dev-ml/type-conv/ChangeLog b/dev-ml/type-conv/ChangeLog
index 1b66cf934217..7df8b0cd62c8 100644
--- a/dev-ml/type-conv/ChangeLog
+++ b/dev-ml/type-conv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/type-conv
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/type-conv/ChangeLog,v 1.9 2010/12/23 16:40:13 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/type-conv/ChangeLog,v 1.10 2011/06/25 18:55:39 aballier Exp $
+
+*type-conv-2.3.0 (25 Jun 2011)
+
+ 25 Jun 2011; Alexis Ballier <aballier@gentoo.org> +type-conv-2.3.0.ebuild:
+ version bump, by Vladimir Ivanov, bug #361153
*type-conv-2.0.2 (23 Dec 2010)
diff --git a/dev-ml/type-conv/type-conv-2.3.0.ebuild b/dev-ml/type-conv/type-conv-2.3.0.ebuild
new file mode 100644
index 000000000000..0e2b016b19b7
--- /dev/null
+++ b/dev-ml/type-conv/type-conv-2.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/type-conv/type-conv-2.3.0.ebuild,v 1.1 2011/06/25 18:55:39 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils multilib
+
+DESCRIPTION="Mini library required for some other preprocessing libraries"
+HOMEPAGE="http://www.janestreet.com/ocaml/"
+SRC_URI="http://www.janestreet.com/ocaml/${P}.tar.gz"
+
+LICENSE="LGPL-2.1-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug doc +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-3.12[ocamlopt?]"
+
+DEPEND="${RDEPEND}"
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --destdir "${D}" \
+ $(oasis_use_enable debug debug) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}/_build/lib" emake test || die
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc README Changelog || die
+}