summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-01-13 20:47:29 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-01-13 20:47:29 +0000
commit3d93fae4fc9748822a6a8805d7e775475a85fd33 (patch)
tree3f6342c6497b346c154aa9f92b20d0b8cb9cd4bb /dev-ml
parentMarked stable for amd64 wrt bug #450904 (diff)
downloadgentoo-2-3d93fae4fc9748822a6a8805d7e775475a85fd33.tar.gz
gentoo-2-3d93fae4fc9748822a6a8805d7e775475a85fd33.tar.bz2
gentoo-2-3d93fae4fc9748822a6a8805d7e775475a85fd33.zip
version bump
(Portage version: 2.2.0_alpha151/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/lwt/ChangeLog9
-rw-r--r--dev-ml/lwt/lwt-2.4.3.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/dev-ml/lwt/ChangeLog b/dev-ml/lwt/ChangeLog
index 4c7fc26462a4..8db8224278c6 100644
--- a/dev-ml/lwt/ChangeLog
+++ b/dev-ml/lwt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/lwt
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lwt/ChangeLog,v 1.22 2012/10/08 12:06:52 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lwt/ChangeLog,v 1.23 2013/01/13 20:47:29 aballier Exp $
+
+*lwt-2.4.3 (13 Jan 2013)
+
+ 13 Jan 2013; Alexis Ballier <aballier@gentoo.org> +lwt-2.4.3.ebuild:
+ version bump
*lwt-2.4.2 (08 Oct 2012)
diff --git a/dev-ml/lwt/lwt-2.4.3.ebuild b/dev-ml/lwt/lwt-2.4.3.ebuild
new file mode 100644
index 000000000000..9a3a9c4c786a
--- /dev/null
+++ b/dev-ml/lwt/lwt-2.4.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lwt/lwt-2.4.3.ebuild,v 1.1 2013/01/13 20:47:29 aballier Exp $
+
+EAPI=4
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Cooperative light-weight thread library for OCaml"
+SRC_URI="http://ocsigen.org/download/${P}.tar.gz"
+HOMEPAGE="http://ocsigen.org/lwt"
+
+IUSE="gtk +react +ssl"
+
+DEPEND="react? ( dev-ml/react )
+ dev-libs/libev
+ ssl? ( >=dev-ml/ocaml-ssl-0.4.0 )
+ gtk? ( dev-ml/lablgtk dev-libs/glib:2 )"
+
+RDEPEND="${DEPEND}
+ !<www-servers/ocsigen-1.1"
+
+SLOT="0"
+LICENSE="LGPL-2.1-with-linking-exception"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+DOCS=( "CHANGES" "CHANGES.darcs" "README" )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable gtk glib)
+ $(use_enable react)
+ $(use_enable ssl)" \
+ oasis_src_configure
+}