summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-11-13 14:02:56 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-11-13 14:02:56 +0000
commitacfba95d26b039678dabfc243880a70469a90d48 (patch)
tree44118316dce9a063d10f1a743996f016dbbd7afb /dev-ml
parentversion bump (diff)
downloadgentoo-2-acfba95d26b039678dabfc243880a70469a90d48.tar.gz
gentoo-2-acfba95d26b039678dabfc243880a70469a90d48.tar.bz2
gentoo-2-acfba95d26b039678dabfc243880a70469a90d48.zip
version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlnet/ChangeLog7
-rw-r--r--dev-ml/ocamlnet/files/digest-ocamlnet-2.2.93
-rw-r--r--dev-ml/ocamlnet/ocamlnet-2.2.9.ebuild64
3 files changed, 73 insertions, 1 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index ab37b5555ec7..265802976aea 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocamlnet
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.21 2007/10/11 20:32:17 cla Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.22 2007/11/13 14:02:55 aballier Exp $
+
+*ocamlnet-2.2.9 (13 Nov 2007)
+
+ 13 Nov 2007; Alexis Ballier <aballier@gentoo.org> +ocamlnet-2.2.9.ebuild:
+ version bump
11 Oct 2007; Dawid Węgliński <cla@gentoo.org> ocamlnet-2.2.8.1.ebuild:
Stable on x86 (bug #195535)
diff --git a/dev-ml/ocamlnet/files/digest-ocamlnet-2.2.9 b/dev-ml/ocamlnet/files/digest-ocamlnet-2.2.9
new file mode 100644
index 000000000000..9ae1f22a612c
--- /dev/null
+++ b/dev-ml/ocamlnet/files/digest-ocamlnet-2.2.9
@@ -0,0 +1,3 @@
+MD5 3655e3be3bb2806e0a1f48bb7ce16fb3 ocamlnet-2.2.9.tar.gz 1877257
+RMD160 1299e1316e0547171089b0caaa9deb13c4c67c31 ocamlnet-2.2.9.tar.gz 1877257
+SHA256 134530a4357879e095bdbbb5f21f78634a16ef4d787eb151676b7fee7e4c0dc9 ocamlnet-2.2.9.tar.gz 1877257
diff --git a/dev-ml/ocamlnet/ocamlnet-2.2.9.ebuild b/dev-ml/ocamlnet/ocamlnet-2.2.9.ebuild
new file mode 100644
index 000000000000..6d3407b73df8
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-2.2.9.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-2.2.9.ebuild,v 1.1 2007/11/13 14:02:55 aballier Exp $
+
+inherit eutils findlib
+
+DESCRIPTION="Modules for OCaml application-level Internet protocols"
+HOMEPAGE="http://ocamlnet.sourceforge.net"
+SRC_URI="mirror://sourceforge/ocamlnet/${P}.tar.gz"
+
+LICENSE="as-is GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gtk ssl tk httpd"
+
+# the auth-dh compile flag has been disabled as well, since it depends on
+# ocaml-cryptgps, which is not available.
+
+DEPEND="!dev-ml/equeue
+ !dev-ml/rpc
+ !dev-ml/netclient
+ >=dev-ml/findlib-1.0
+ >=dev-ml/pcre-ocaml-5
+ gtk? ( >=dev-ml/lablgtk-2 )
+ ssl? ( dev-ml/ocaml-ssl )"
+
+pkg_setup() {
+ if use tk && ! built_with_use 'dev-lang/ocaml' tk ;
+ then die "If you want to enable tcl/tk, you need to rebuild dev-lang/ocaml with the 'tk' USE flag";
+ fi
+}
+
+ocamlnet_use_with() {
+ if use $1; then
+ echo "-with-$2"
+ else
+ echo "-without-$2"
+ fi
+}
+
+ocamlnet_use_enable() {
+ if use $1; then
+ echo "-enable-$2"
+ else
+ echo "-disable-$2"
+ fi
+}
+
+src_compile() {
+ ./configure \
+ -bindir /usr/bin \
+ -datadir /usr/share/${PN} \
+ $(ocamlnet_use_enable gtk gtk2) \
+ $(ocamlnet_use_enable ssl ssl) \
+ $(ocamlnet_use_enable tk tcl) \
+ $(ocamlnet_use_with httpd nethttpd) \
+ || die "Error : econf failed!"
+
+ emake -j1 all opt || die "make failed"
+}
+
+src_install() {
+ findlib_src_install
+}