summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-02-02 15:17:01 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-02-02 15:17:01 +0000
commit5d5d482aa980472ec98db1149d4ea8906e569ee4 (patch)
treeb50f3b381653d15fb9ece2c611bed2707162112b /dev-perl/Apache-Test
parentStable for HPPA (bug #208356). (diff)
downloadgentoo-2-5d5d482aa980472ec98db1149d4ea8906e569ee4.tar.gz
gentoo-2-5d5d482aa980472ec98db1149d4ea8906e569ee4.tar.bz2
gentoo-2-5d5d482aa980472ec98db1149d4ea8906e569ee4.zip
use depend.apache eclass wrt #208033
(Portage version: 2.1.4)
Diffstat (limited to 'dev-perl/Apache-Test')
-rw-r--r--dev-perl/Apache-Test/Apache-Test-1.29.ebuild15
-rw-r--r--dev-perl/Apache-Test/ChangeLog7
2 files changed, 13 insertions, 9 deletions
diff --git a/dev-perl/Apache-Test/Apache-Test-1.29.ebuild b/dev-perl/Apache-Test/Apache-Test-1.29.ebuild
index 2ea42089e118..cb85a4cc5a3b 100644
--- a/dev-perl/Apache-Test/Apache-Test-1.29.ebuild
+++ b/dev-perl/Apache-Test/Apache-Test-1.29.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Apache-Test/Apache-Test-1.29.ebuild,v 1.8 2007/07/29 16:52:14 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Apache-Test/Apache-Test-1.29.ebuild,v 1.9 2008/02/02 15:17:01 hollow Exp $
-inherit perl-module
+inherit depend.apache perl-module
DESCRIPTION="Test.pm wrapper with helpers for testing Apache"
SRC_URI="mirror://cpan/authors/id/P/PG/PGOLLUCCI/${P}.tar.gz"
@@ -13,15 +13,16 @@ LICENSE="Artistic"
KEYWORDS="alpha amd64 ia64 ~mips ppc ppc64 sparc x86"
SRC_TEST="skip"
-DEPEND="www-servers/apache
- dev-lang/perl"
+DEPEND="dev-lang/perl"
+
+need_apache
src_install() {
# This is to avoid conflicts with a deprecated Apache::Test stepping
# in and causing problems/install errors
- if [ -f ${S}/.mypacklist ];
+ if [ -f "${S}"/.mypacklist ];
then
- rm -f ${S}/.mypacklist
+ rm -f "${S}"/.mypacklist
fi
perl-module_src_install
}
diff --git a/dev-perl/Apache-Test/ChangeLog b/dev-perl/Apache-Test/ChangeLog
index 9f4d25a18862..b73c8c503ade 100644
--- a/dev-perl/Apache-Test/ChangeLog
+++ b/dev-perl/Apache-Test/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-perl/Apache-Test
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Apache-Test/ChangeLog,v 1.58 2007/07/29 16:52:14 phreak Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Apache-Test/ChangeLog,v 1.59 2008/02/02 15:17:01 hollow Exp $
+
+ 02 Feb 2008; Benedikt Böhm <hollow@gentoo.org> Apache-Test-1.29.ebuild:
+ use depend.apache eclass wrt #208033
29 Jul 2007; Christian Heim <phreak@gentoo.org> Apache-Test-1.29.ebuild:
Fixing the DEPEND/RDEPEND for the move of net-www/apache to