summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-04-22 06:02:34 +0000
committerTorsten Veller <tove@gentoo.org>2010-04-22 06:02:34 +0000
commit2f1ccc403810f50ca5700f4c1d286dcff080e230 (patch)
tree0d44fcad0693ba36006cfea95a5bd9feadd40091 /dev-perl/App-Nopaste
parentVersion bump (diff)
downloadgentoo-2-2f1ccc403810f50ca5700f4c1d286dcff080e230.tar.gz
gentoo-2-2f1ccc403810f50ca5700f4c1d286dcff080e230.tar.bz2
gentoo-2-2f1ccc403810f50ca5700f4c1d286dcff080e230.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/App-Nopaste')
-rw-r--r--dev-perl/App-Nopaste/App-Nopaste-0.20.ebuild35
-rw-r--r--dev-perl/App-Nopaste/ChangeLog7
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-perl/App-Nopaste/App-Nopaste-0.20.ebuild b/dev-perl/App-Nopaste/App-Nopaste-0.20.ebuild
new file mode 100644
index 000000000000..35d6f22338b2
--- /dev/null
+++ b/dev-perl/App-Nopaste/App-Nopaste-0.20.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/App-Nopaste/App-Nopaste-0.20.ebuild,v 1.1 2010/04/22 06:02:34 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=SARTAK
+inherit perl-module
+
+DESCRIPTION="easy access to any pastebin"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pastebin +clipboard +github"
+
+DEPEND="
+ dev-perl/WWW-Mechanize
+ virtual/perl-Module-Pluggable
+ >=dev-perl/Moose-0.74
+ >=dev-perl/MooseX-Getopt-0.17
+ pastebin? (
+ dev-perl/WWW-Pastebin-PastebinCom-Create
+ )
+ clipboard? (
+ dev-perl/Clipboard
+ )
+ github? (
+ || (
+ dev-vcs/git[perl]
+ dev-perl/Config-INI
+ )
+ )
+"
+RDEPEND="${DEPEND}"
+SRC_TEST="do"
diff --git a/dev-perl/App-Nopaste/ChangeLog b/dev-perl/App-Nopaste/ChangeLog
index 63ac1430a2b9..4ed37cc92193 100644
--- a/dev-perl/App-Nopaste/ChangeLog
+++ b/dev-perl/App-Nopaste/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/App-Nopaste
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/App-Nopaste/ChangeLog,v 1.11 2010/04/09 06:53:49 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/App-Nopaste/ChangeLog,v 1.12 2010/04/22 06:02:34 tove Exp $
+
+*App-Nopaste-0.20 (22 Apr 2010)
+
+ 22 Apr 2010; Torsten Veller <tove@gentoo.org> +App-Nopaste-0.20.ebuild:
+ Version bump
09 Apr 2010; Torsten Veller <tove@gentoo.org> -App-Nopaste-0.17.ebuild,
-App-Nopaste-0.18.ebuild: