summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-09-01 11:49:39 +0000
committerTorsten Veller <tove@gentoo.org>2011-09-01 11:49:39 +0000
commit1baf26326f88d6371164cf2f2576bee0b79e1274 (patch)
treeefd52280059f1c9f2b7db10dcf44f8af7beadf95 /dev-perl/CPAN-Mini-Phalanx
parentChange version scheme (diff)
downloadgentoo-2-1baf26326f88d6371164cf2f2576bee0b79e1274.tar.gz
gentoo-2-1baf26326f88d6371164cf2f2576bee0b79e1274.tar.bz2
gentoo-2-1baf26326f88d6371164cf2f2576bee0b79e1274.zip
Change version scheme
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/CPAN-Mini-Phalanx')
-rw-r--r--dev-perl/CPAN-Mini-Phalanx/CPAN-Mini-Phalanx-0.10.0.ebuild31
-rw-r--r--dev-perl/CPAN-Mini-Phalanx/ChangeLog10
2 files changed, 39 insertions, 2 deletions
diff --git a/dev-perl/CPAN-Mini-Phalanx/CPAN-Mini-Phalanx-0.10.0.ebuild b/dev-perl/CPAN-Mini-Phalanx/CPAN-Mini-Phalanx-0.10.0.ebuild
new file mode 100644
index 000000000000..7ed96a747394
--- /dev/null
+++ b/dev-perl/CPAN-Mini-Phalanx/CPAN-Mini-Phalanx-0.10.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/CPAN-Mini-Phalanx/CPAN-Mini-Phalanx-0.10.0.ebuild,v 1.1 2011/09/01 11:49:39 tove Exp $
+
+EAPI=4
+
+MY_PN=CPAN-Mini-Phalanx100
+MODULE_AUTHOR=SMPETERS
+MODULE_VERSION=0.01
+inherit perl-module
+
+DESCRIPTION="create a minimal mirror of CPAN containing the modules in the Phalanx 100"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="dev-perl/CPAN-Mini"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )"
+
+SRC_TEST="do"
+
+src_prepare() {
+ perl-module_src_prepare
+ sed -i 's,^L<Phalanx Project|,L<,' "${S}"/lib/CPAN/Mini/Phalanx100.pm || die
+}
diff --git a/dev-perl/CPAN-Mini-Phalanx/ChangeLog b/dev-perl/CPAN-Mini-Phalanx/ChangeLog
index cf1dc4ab70b0..fc37ad513a28 100644
--- a/dev-perl/CPAN-Mini-Phalanx/ChangeLog
+++ b/dev-perl/CPAN-Mini-Phalanx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/CPAN-Mini-Phalanx
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/CPAN-Mini-Phalanx/ChangeLog,v 1.8 2010/01/01 22:54:03 tove Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/CPAN-Mini-Phalanx/ChangeLog,v 1.9 2011/09/01 11:49:39 tove Exp $
+
+*CPAN-Mini-Phalanx-0.10.0 (01 Sep 2011)
+
+ 01 Sep 2011; Torsten Veller <tove@gentoo.org>
+ +CPAN-Mini-Phalanx-0.10.0.ebuild:
+ Change version scheme
01 Jan 2010; Torsten Veller <tove@gentoo.org>
CPAN-Mini-Phalanx-0.01.ebuild: