summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-05-07 09:31:15 +0000
committerTorsten Veller <tove@gentoo.org>2009-05-07 09:31:15 +0000
commit929fc9984fd2e49f6e6d4793f158c12959cd19b3 (patch)
tree5cea1d2459499a8aa13527713b31b92fd2c0c15c /dev-perl/Curses
parentstable x86, bug 268690 (diff)
downloadgentoo-2-929fc9984fd2e49f6e6d4793f158c12959cd19b3.tar.gz
gentoo-2-929fc9984fd2e49f6e6d4793f158c12959cd19b3.tar.bz2
gentoo-2-929fc9984fd2e49f6e6d4793f158c12959cd19b3.zip
Version bump. Add unicode support (#217096). Remove GEN and add FORMS
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'dev-perl/Curses')
-rw-r--r--dev-perl/Curses/ChangeLog9
-rw-r--r--dev-perl/Curses/Curses-1.27.ebuild39
2 files changed, 46 insertions, 2 deletions
diff --git a/dev-perl/Curses/ChangeLog b/dev-perl/Curses/ChangeLog
index 363e67644b85..7bf52e3ee930 100644
--- a/dev-perl/Curses/ChangeLog
+++ b/dev-perl/Curses/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-perl/Curses
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Curses/ChangeLog,v 1.48 2009/05/02 11:37:08 tove Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Curses/ChangeLog,v 1.49 2009/05/07 09:31:15 tove Exp $
+
+*Curses-1.27 (07 May 2009)
+
+ 07 May 2009; Torsten Veller <tove@gentoo.org> +Curses-1.27.ebuild:
+ Version bump. Add unicode support (#217096). Remove GEN and add FORMS
02 May 2009; Torsten Veller <tove@gentoo.org> -Curses-1.24.ebuild:
Cleanup
diff --git a/dev-perl/Curses/Curses-1.27.ebuild b/dev-perl/Curses/Curses-1.27.ebuild
new file mode 100644
index 000000000000..4c1e33db3d22
--- /dev/null
+++ b/dev-perl/Curses/Curses-1.27.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Curses/Curses-1.27.ebuild,v 1.1 2009/05/07 09:31:15 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=GIRAFFED
+MODULE_A=${P}.tgz
+inherit perl-module
+
+DESCRIPTION="Curses interface modules for Perl"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="unicode"
+
+DEPEND=">=sys-libs/ncurses-5[unicode?]"
+RDEPEND="${DEPEND}"
+
+SRC_TEST="do"
+
+my_curses_version() {
+ echo ncurses$(use unicode && echo w)
+}
+
+pkg_setup() {
+ myconf="${myconf} FORMS PANELS MENUS"
+ mydoc=HISTORY
+ export CURSES_LIBTYPE=$(my_curses_version)
+ export CURSES_LDFLAGS=$($(my_curses_version)5-config --libs)
+ export CURSES_CFLAGS=$( $(my_curses_version)5-config --cflags)
+}
+
+src_configure(){
+ perl-module_src_configure
+ if ! use unicode ; then
+ sed -i 's:<form.h>:"/usr/include/form.h":' "${S}"/c-config.h || die
+ fi
+}