summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2007-03-31 00:21:21 +0000
committerMichael Cummings <mcummings@gentoo.org>2007-03-31 00:21:21 +0000
commit07773f444ad7a52490bc722f9cb2d726226411c3 (patch)
treea4dae994012cdab78af2b5f11f69e5e9e2507785 /dev-perl/Inline-Java
parentFixes for mod_perl-2.0.3 re: bug 172676 (diff)
downloadgentoo-2-07773f444ad7a52490bc722f9cb2d726226411c3.tar.gz
gentoo-2-07773f444ad7a52490bc722f9cb2d726226411c3.tar.bz2
gentoo-2-07773f444ad7a52490bc722f9cb2d726226411c3.zip
Tweak to jdk checks thanks to nichoj
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-perl/Inline-Java')
-rw-r--r--dev-perl/Inline-Java/ChangeLog6
-rw-r--r--dev-perl/Inline-Java/Inline-Java-0.50.ebuild17
-rw-r--r--dev-perl/Inline-Java/Inline-Java-0.51.ebuild18
-rw-r--r--dev-perl/Inline-Java/Inline-Java-0.52.ebuild18
4 files changed, 31 insertions, 28 deletions
diff --git a/dev-perl/Inline-Java/ChangeLog b/dev-perl/Inline-Java/ChangeLog
index 5d3ffb8381b7..1ca05c754f24 100644
--- a/dev-perl/Inline-Java/ChangeLog
+++ b/dev-perl/Inline-Java/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/Inline-Java
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline-Java/ChangeLog,v 1.12 2007/03/30 21:02:18 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline-Java/ChangeLog,v 1.13 2007/03/31 00:21:21 mcummings Exp $
+
+ 31 Mar 2007; Michael Cummings <mcummings@gentoo.org>
+ Inline-Java-0.50.ebuild, Inline-Java-0.51.ebuild, Inline-Java-0.52.ebuild:
+ Tweak to jdk checks thanks to nichoj
30 Mar 2007; Andrej Kacian <ticho@gentoo.org> Inline-Java-0.51.ebuild:
Stable on x86, bug #169152.
diff --git a/dev-perl/Inline-Java/Inline-Java-0.50.ebuild b/dev-perl/Inline-Java/Inline-Java-0.50.ebuild
index 38b4f41adae3..26bbaf71e9ff 100644
--- a/dev-perl/Inline-Java/Inline-Java-0.50.ebuild
+++ b/dev-perl/Inline-Java/Inline-Java-0.50.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline-Java/Inline-Java-0.50.ebuild,v 1.8 2007/03/30 20:09:17 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline-Java/Inline-Java-0.50.ebuild,v 1.9 2007/03/31 00:21:21 mcummings Exp $
-inherit perl-module
+inherit perl-module java-pkg-2
DESCRIPTION="Easy implimentaiton of Java extensions"
HOMEPAGE="http://search.cpan.org/~patl/"
@@ -19,18 +19,17 @@ SRC_TEST="do"
DEPEND=">=dev-perl/Inline-0.44
>=virtual/perl-Test-1.13
>=virtual/jdk-1.4
- dev-java/java-config
dev-lang/perl"
myconf="J2SDK=$JAVA_HOME"
mymake="java all"
pkg_setup() {
- if [ $(java-config -O | grep jdk ) ]; then
- true
- else
- eerror "Please use java-config -S to set your system vm to a JDK"
- die "Active VM is not a JDK"
- fi
+ java-pkg-2_pkg_setup
+ perl-module_pkg_setup
}
+src_compile() {
+ java-pkg-2_src_compile
+ perl-module_src_compile
+}
diff --git a/dev-perl/Inline-Java/Inline-Java-0.51.ebuild b/dev-perl/Inline-Java/Inline-Java-0.51.ebuild
index b044dd020e4a..be62d484a027 100644
--- a/dev-perl/Inline-Java/Inline-Java-0.51.ebuild
+++ b/dev-perl/Inline-Java/Inline-Java-0.51.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline-Java/Inline-Java-0.51.ebuild,v 1.7 2007/03/30 21:02:18 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline-Java/Inline-Java-0.51.ebuild,v 1.8 2007/03/31 00:21:21 mcummings Exp $
-inherit perl-module
+inherit perl-module java-pkg-2
DESCRIPTION="Easy implimentaiton of Java extensions"
HOMEPAGE="http://search.cpan.org/~patl/"
@@ -19,17 +19,17 @@ SRC_TEST="do"
DEPEND=">=dev-perl/Inline-0.44
>=virtual/perl-Test-1.13
>=virtual/jdk-1.4
- dev-java/java-config
dev-lang/perl"
myconf="J2SDK=$JAVA_HOME"
mymake="java all"
pkg_setup() {
- if [ $(java-config -O | grep jdk ) ]; then
- true
- else
- eerror "Please use java-config -S to set your system vm to a JDK"
- die "Active VM is not a JDK"
- fi
+ java-pkg-2_pkg_setup
+ perl-module_pkg_setup
+}
+
+src_compile() {
+ java-pkg-2_src_compile
+ perl-module_src_compile
}
diff --git a/dev-perl/Inline-Java/Inline-Java-0.52.ebuild b/dev-perl/Inline-Java/Inline-Java-0.52.ebuild
index bb034da63f28..2641019e3986 100644
--- a/dev-perl/Inline-Java/Inline-Java-0.52.ebuild
+++ b/dev-perl/Inline-Java/Inline-Java-0.52.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline-Java/Inline-Java-0.52.ebuild,v 1.2 2007/03/30 20:09:17 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Inline-Java/Inline-Java-0.52.ebuild,v 1.3 2007/03/31 00:21:21 mcummings Exp $
-inherit perl-module
+inherit perl-module java-pkg-2
DESCRIPTION="Easy implimentaiton of Java extensions"
HOMEPAGE="http://search.cpan.org/~patl/"
@@ -19,17 +19,17 @@ SRC_TEST="do"
DEPEND=">=dev-perl/Inline-0.44
>=virtual/perl-Test-1.13
>=virtual/jdk-1.4
- dev-java/java-config
dev-lang/perl"
myconf="J2SDK=$JAVA_HOME"
mymake="java all"
pkg_setup() {
- if [ $(java-config -O | grep jdk ) ]; then
- true
- else
- eerror "Please use java-config -S to set your system vm to a JDK"
- die "Active VM is not a JDK"
- fi
+ java-pkg-2_pkg_setup
+ perl-module_pkg_setup
+}
+
+src_compile() {
+ java-pkg-2_src_compile
+ perl-module_src_compile
}