summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2015-01-20 10:08:24 +0000
committerTony Vroon <chainsaw@gentoo.org>2015-01-20 10:08:24 +0000
commitb68eba9d0be6c1d5e9b43e93210951d04a53091c (patch)
treebf58fb4996c31bab71848c000fbac41496e29834 /dev-perl/Net-DNS
parentCleanup due to #213900 (diff)
downloadgentoo-2-b68eba9d0be6c1d5e9b43e93210951d04a53091c.tar.gz
gentoo-2-b68eba9d0be6c1d5e9b43e93210951d04a53091c.tar.bz2
gentoo-2-b68eba9d0be6c1d5e9b43e93210951d04a53091c.zip
Version bump in an attempt to address intermittent "zone file representation not defined for TSIG" errors in a LINX DNS update script occurring with 0.740.0; herd commit approval from Andreas "dilfridge" Huettel.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0xB5058F9A)
Diffstat (limited to 'dev-perl/Net-DNS')
-rw-r--r--dev-perl/Net-DNS/ChangeLog9
-rw-r--r--dev-perl/Net-DNS/Net-DNS-0.810.0.ebuild46
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-perl/Net-DNS/ChangeLog b/dev-perl/Net-DNS/ChangeLog
index c3a46d9a61e3..7e803af5827b 100644
--- a/dev-perl/Net-DNS/ChangeLog
+++ b/dev-perl/Net-DNS/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-perl/Net-DNS
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-DNS/ChangeLog,v 1.176 2015/01/18 08:42:55 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-DNS/ChangeLog,v 1.177 2015/01/20 10:08:24 chainsaw Exp $
+
+*Net-DNS-0.810.0 (20 Jan 2015)
+
+ 20 Jan 2015; Tony Vroon <chainsaw@gentoo.org> +Net-DNS-0.810.0.ebuild:
+ Version bump in an attempt to address intermittent "zone file representation
+ not defined for TSIG" errors in a LINX DNS update script occurring with
+ 0.740.0; herd commit approval from Andreas "dilfridge" Huettel.
18 Jan 2015; Agostino Sarubbo <ago@gentoo.org> Net-DNS-0.740.0.ebuild:
Stable for ppc64, wrt bug #535210
diff --git a/dev-perl/Net-DNS/Net-DNS-0.810.0.ebuild b/dev-perl/Net-DNS/Net-DNS-0.810.0.ebuild
new file mode 100644
index 000000000000..628f6cd50392
--- /dev/null
+++ b/dev-perl/Net-DNS/Net-DNS-0.810.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Net-DNS/Net-DNS-0.810.0.ebuild,v 1.1 2015/01/20 10:08:24 chainsaw Exp $
+
+EAPI=5
+
+MODULE_AUTHOR=NLNETLABS
+MODULE_VERSION=0.81
+inherit toolchain-funcs perl-module
+
+DESCRIPTION="Perl Net::DNS - Perl DNS Resolver Module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="ipv6 test"
+
+RDEPEND="
+ virtual/perl-Digest-MD5
+ dev-perl/Digest-HMAC
+ virtual/perl-Digest-SHA
+ dev-perl/Net-IP
+ virtual/perl-MIME-Base64
+ ipv6? (
+ dev-perl/IO-Socket-INET6
+ )
+"
+DEPEND="${RDEPEND}
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-Pod
+ )"
+
+PATCHES=( ${FILESDIR}/${PN}-0.68-ar.patch )
+SRC_TEST="do"
+
+src_prepare() {
+ perl-module_src_prepare
+ mydoc="TODO"
+ # --IPv6-tests requires that you have external IPv6 connectivity
+ # as it connects to 2001:7b8:206:1:0:1234:be21:e31e
+ myconf="${myconf} --no-online-tests --no-IPv6-tests"
+}
+
+src_compile() {
+ emake FULL_AR="$(tc-getAR)" OTHERLDFLAGS="${LDFLAGS}"
+}