summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-04 06:41:14 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-04 06:41:14 +0000
commit7bccea6a9acc26c9c0c2c800b7a84094890c9a29 (patch)
tree9b5b36d6b92c1bda2bf2c7bda81abc01c26df605 /dev-perl/PDL
parent*** empty log message *** (diff)
downloadgentoo-2-7bccea6a9acc26c9c0c2c800b7a84094890c9a29.tar.gz
gentoo-2-7bccea6a9acc26c9c0c2c800b7a84094890c9a29.tar.bz2
gentoo-2-7bccea6a9acc26c9c0c2c800b7a84094890c9a29.zip
*** empty log message ***
Diffstat (limited to 'dev-perl/PDL')
-rw-r--r--dev-perl/PDL/PDL-2.2.1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/dev-perl/PDL/PDL-2.2.1.ebuild b/dev-perl/PDL/PDL-2.2.1.ebuild
new file mode 100644
index 000000000000..e0a45fc9bded
--- /dev/null
+++ b/dev-perl/PDL/PDL-2.2.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.2.1.ebuild,v 1.1 2001/06/04 06:41:14 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="PDL Perl Module"
+SRC_URI="http://cpan.valueclick.com/modules/by-module/PDL/${A}"
+HOMEPAGE="http://cpan.valueclick.com/modules/by-module/PDL/${P}.readme"
+
+DEPEND=">=sys-devel/perl-5
+ >=sys-libs/ncurses-5.2
+ >=dev-perl/ExtUtils-F77-1.13
+ opengl? ( virtual/opengl virtual/glu )"
+
+src_unpack() {
+
+ unpack ${A}
+ cp ${FILESDIR}/perldl.conf ${S}
+ #open gl does not work at the moment
+ if [ "`use opengl`" ]
+ then
+ echo "Disabled at the moment"
+ sed -e "s:WITH_3D => undef:WITH_3D => 1:" ${FILESDIR}/perldl.conf > ${S}/perldl.conf
+ else
+ sed -e "s:WITH_3D => undef:WITH_3D => 0:" ${FILESDIR}/perldl.conf > ${S}/perldl.conf
+ fi
+
+}
+
+src_compile() {
+
+ perl Makefile.PL
+ try make
+ make test
+
+}
+
+src_install () {
+
+ try make PREFIX=${D}/usr INSTALLMAN3DIR=/usr/share/man/man3 \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 install
+
+ dodoc COPYING Changes DEPENDENCIES DEVELOPMENT README MANIFEST*
+ dodoc Release_Notes TODO
+ mv ${D}/usr/lib/perl5/site_perl/5.6.0/${CHOST%%-*}-linux/PDL/HtmlDocs ${D}/usr/doc/${P}/html
+ mydir=${D}/usr/doc/${P}/html/PDL
+ for i in ${mydir}/* ${mydir}/IO/* ${mydir}/Fit/* ${mydir}/Pod/* ${mydir}/Graphics/*
+ do
+ dosed ${i/${D}}
+ done
+ dosed /usr/lib/perl5/site_perl/5.6.0/${CHOST%%-*}-linux/PDL/pdldoc.db
+
+}
+
+
+
+
+
+