summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-05-05 18:47:51 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-05-05 18:47:51 +0000
commitf4d5d0243c318bdda81c53e0944663cb9caa2ec5 (patch)
tree218c1fc2f417916f22dfa2e63b9e9500b8909064 /dev-perl/PDL
parentppc fix for standalone mkisofs (diff)
downloadgentoo-2-f4d5d0243c318bdda81c53e0944663cb9caa2ec5.tar.gz
gentoo-2-f4d5d0243c318bdda81c53e0944663cb9caa2ec5.tar.bz2
gentoo-2-f4d5d0243c318bdda81c53e0944663cb9caa2ec5.zip
More conversions to eclasses
Diffstat (limited to 'dev-perl/PDL')
-rw-r--r--dev-perl/PDL/ChangeLog9
-rw-r--r--dev-perl/PDL/PDL-2.3.2-r1.ebuild (renamed from dev-perl/PDL/PDL-2.3.2.ebuild)44
-rw-r--r--dev-perl/PDL/files/digest-PDL-2.3.2-r1 (renamed from dev-perl/PDL/files/digest-PDL-2.3.2)0
3 files changed, 26 insertions, 27 deletions
diff --git a/dev-perl/PDL/ChangeLog b/dev-perl/PDL/ChangeLog
index d10729d320f7..2fc736dcc80e 100644
--- a/dev-perl/PDL/ChangeLog
+++ b/dev-perl/PDL/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-perl/PDL
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/ChangeLog,v 1.1 2002/02/01 21:53:27 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/ChangeLog,v 1.2 2002/05/05 18:47:51 seemant Exp $
+
+*PDL-2.3.2-r1 (5 May 2002)
+
+ 5 May 2002; Seemant Kulleen <seemant@gentoo.org> PDL-2.3.2-r1.ebuild
+ files/digest-PDL-2.3.2-r1 :
+
+ eclass conversion
*PDL-2.3.2 (1 Feb 2002)
diff --git a/dev-perl/PDL/PDL-2.3.2.ebuild b/dev-perl/PDL/PDL-2.3.2-r1.ebuild
index 5ef7360dcf9e..5a59b2a43ac1 100644
--- a/dev-perl/PDL/PDL-2.3.2.ebuild
+++ b/dev-perl/PDL/PDL-2.3.2-r1.ebuild
@@ -1,48 +1,46 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.3.2.ebuild,v 1.1 2002/01/28 18:25:50 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/PDL/PDL-2.3.2-r1.ebuild,v 1.1 2002/05/05 18:47:51 seemant Exp $
+
+. /usr/portage/eclass/inherit.eclass || die
+inherit perl-module
S=${WORKDIR}/${P}
DESCRIPTION="PDL Perl Module"
SRC_URI="http://cpan.valueclick.com/modules/by-module/PDL/${P}.tar.gz"
HOMEPAGE="http://cpan.valueclick.com/modules/by-module/PDL/${P}.readme"
-DEPEND=">=sys-devel/perl-5
+DEPEND="${DEPEND}
>=sys-libs/ncurses-5.2
- >=dev-perl/ExtUtils-F77-1.13"
-# opengl? ( virtual/opengl virtual/glu )
+ >=dev-perl/ExtUtils-F77-1.13
+ opengl? ( virtual/opengl virtual/glu )"
+
+mydoc="DEPNDENCIES DEVELOPMENT MANIFEST* COPYING Release_Notes TODO"
src_unpack() {
+
unpack ${A}
#open gl does not work at the moment
if [ "`use opengl`" ]
then
echo "OpenGL support is current disabled due to build issues"
- sed -e "s:WITH_3D => undef:WITH_3D => 0:" ${FILESDIR}/perldl.conf > ${S}/perldl.conf
+ sed -e "s:WITH_3D => undef:WITH_3D => 0:" \
+ ${FILESDIR}/perldl.conf > ${S}/perldl.conf
else
- sed -e "s:WITH_3D => undef:WITH_3D => 0:" ${FILESDIR}/perldl.conf > ${S}/perldl.conf
+ sed -e "s:WITH_3D => undef:WITH_3D => 0:" \
+ ${FILESDIR}/perldl.conf > ${S}/perldl.conf
fi
}
-src_compile() {
- perl Makefile.PL
-
- make || die
- make test || die
-}
-
src_install () {
- make PREFIX=${D}/usr \
- INSTALLMAN1DIR=${D}/usr/share/man/man1 \
- INSTALLMAN3DIR=${D}/usr/share/man/man3 \
- install || die
+
+ base_src_install
- dodoc COPYING Changes DEPENDENCIES DEVELOPMENT README MANIFEST*
+ mv ${D}/usr/lib/perl5/site_perl/5.6.0/${CHOST%%-*}-linux/PDL/HtmlDocs \
+ ${D}/usr/doc/${P}/html
- dodoc Release_Notes TODO
- mv ${D}/usr/lib/perl5/site_perl/5.6.0/${CHOST%%-*}-linux/PDL/HtmlDocs ${D}/usr/doc/${P}/html
mydir=${D}/usr/doc/${P}/html/PDL
for i in ${mydir}/* ${mydir}/IO/* ${mydir}/Fit/* ${mydir}/Pod/* ${mydir}/Graphics/*
@@ -52,9 +50,3 @@ src_install () {
dosed /usr/lib/perl5/site_perl/5.6.0/${CHOST%%-*}-linux/PDL/pdldoc.db
}
-
-
-
-
-
-
diff --git a/dev-perl/PDL/files/digest-PDL-2.3.2 b/dev-perl/PDL/files/digest-PDL-2.3.2-r1
index cfdaa1a92a4d..cfdaa1a92a4d 100644
--- a/dev-perl/PDL/files/digest-PDL-2.3.2
+++ b/dev-perl/PDL/files/digest-PDL-2.3.2-r1