summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2004-07-30 12:49:42 +0000
committerMichael Cummings <mcummings@gentoo.org>2004-07-30 12:49:42 +0000
commitf1095e491a97375b69d2196233f61a26aa1f1574 (patch)
tree5cfea2b64f07041316867aaf2d906aa4a5ee9d71 /dev-perl/libwww-perl/libwww-perl-5.800.ebuild
parentPPC fixes. (Manifest recommit) (diff)
downloadgentoo-2-f1095e491a97375b69d2196233f61a26aa1f1574.tar.gz
gentoo-2-f1095e491a97375b69d2196233f61a26aa1f1574.tar.bz2
gentoo-2-f1095e491a97375b69d2196233f61a26aa1f1574.zip
new version on cpan
Diffstat (limited to 'dev-perl/libwww-perl/libwww-perl-5.800.ebuild')
-rw-r--r--dev-perl/libwww-perl/libwww-perl-5.800.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/libwww-perl/libwww-perl-5.800.ebuild b/dev-perl/libwww-perl/libwww-perl-5.800.ebuild
new file mode 100644
index 000000000000..fc9b3cb1ca63
--- /dev/null
+++ b/dev-perl/libwww-perl/libwww-perl-5.800.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-5.800.ebuild,v 1.1 2004/07/30 12:49:42 mcummings Exp $
+
+inherit perl-module
+
+DESCRIPTION="A collection of Perl Modules for the WWW"
+SRC_URI="http://cpan.org/modules/by-module/WWW/${P}.tar.gz"
+HOMEPAGE="http://cpan.org/modules/by-module/WWW/${P}.readme"
+IUSE="ssl"
+SLOT="0"
+LICENSE="Artistic | GPL-2"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha ~hppa ~ia64"
+
+DEPEND=">=dev-perl/libnet-1.16
+ >=dev-perl/HTML-Parser-3.34
+ >=dev-perl/URI-1.10
+ >=dev-perl/Digest-MD5-2.12
+ >=dev-perl/MIME-Base64-2.12
+ ssl? ( dev-perl/Crypt-SSLeay )"
+
+src_compile() {
+ yes "" | perl Makefile.PL ${myconf} \
+ PREFIX=${D}/usr INSTALLDIRS=vendor
+}
+
+pkg_postinst() {
+ perl-module_pkg_postinst
+}