summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-03-17 07:23:22 +0000
committerTorsten Veller <tove@gentoo.org>2011-03-17 07:23:22 +0000
commit73c8e3f9f65d52eeb7108901cd40c35ec4e0db3c (patch)
tree6b6a6560a17ab7c6ae037f15bcea8910102ee8e9 /dev-perl/libwww-perl
parentUpdate netlink patch from git. (diff)
downloadgentoo-2-73c8e3f9f65d52eeb7108901cd40c35ec4e0db3c.tar.gz
gentoo-2-73c8e3f9f65d52eeb7108901cd40c35ec4e0db3c.tar.bz2
gentoo-2-73c8e3f9f65d52eeb7108901cd40c35ec4e0db3c.zip
Use certificates from app-misc/ca-certificates (#358081)
(Portage version: 2.2.0_alpha27/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/libwww-perl')
-rw-r--r--dev-perl/libwww-perl/ChangeLog6
-rw-r--r--dev-perl/libwww-perl/files/ca-certs.patch30
-rw-r--r--dev-perl/libwww-perl/libwww-perl-6.0.0.ebuild54
-rw-r--r--dev-perl/libwww-perl/libwww-perl-6.10.0.ebuild9
4 files changed, 42 insertions, 57 deletions
diff --git a/dev-perl/libwww-perl/ChangeLog b/dev-perl/libwww-perl/ChangeLog
index 1e37f995e15e..7a1c5c3bb87b 100644
--- a/dev-perl/libwww-perl/ChangeLog
+++ b/dev-perl/libwww-perl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-perl/libwww-perl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.138 2011/03/11 07:01:11 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/ChangeLog,v 1.139 2011/03/17 07:23:22 tove Exp $
+
+ 17 Mar 2011; Torsten Veller <tove@gentoo.org> -libwww-perl-6.0.0.ebuild,
+ libwww-perl-6.10.0.ebuild, +files/ca-certs.patch:
+ Use certificates from app-misc/ca-certificates (#358081)
*libwww-perl-6.10.0 (11 Mar 2011)
diff --git a/dev-perl/libwww-perl/files/ca-certs.patch b/dev-perl/libwww-perl/files/ca-certs.patch
new file mode 100644
index 000000000000..b0565f0fdba0
--- /dev/null
+++ b/dev-perl/libwww-perl/files/ca-certs.patch
@@ -0,0 +1,30 @@
+X-Bugs-Gentoo: https://bugs.gentoo.org/358081
+--- libwww-perl-6.01/lib/LWP/Protocol/https.pm
++++ libwww-perl-6.01/lib/LWP/Protocol/https.pm
+@@ -21,25 +21,7 @@
+ }
+ if ($ssl_opts{SSL_verify_mode}) {
+ unless (exists $ssl_opts{SSL_ca_file} || exists $ssl_opts{SSL_ca_path}) {
+- eval {
+- require Mozilla::CA;
+- };
+- if ($@) {
+- if ($@ =! /^Can't locate Mozilla\/CA\.pm/) {
+- $@ = <<'EOT';
+-Can't verify SSL peers without knowning which Certificate Authorities to trust
+-
+-This problem can be fixed by either setting the PERL_LWP_SSL_CA_FILE
+-envirionment variable or by installing the Mozilla::CA module.
+-
+-To disable verification of SSL peers set the PERL_LWP_SSL_VERIFY_HOSTNAME
+-envirionment variable to 0. If you do this you can't be sure that you
+-communicate with the expected peer.
+-EOT
+- }
+- die $@;
+- }
+- $ssl_opts{SSL_ca_file} = Mozilla::CA::SSL_ca_file();
++ $ssl_opts{SSL_ca_path} = '/etc/ssl/certs';
+ }
+ }
+ $self->{ssl_opts} = \%ssl_opts;
diff --git a/dev-perl/libwww-perl/libwww-perl-6.0.0.ebuild b/dev-perl/libwww-perl/libwww-perl-6.0.0.ebuild
deleted file mode 100644
index 0b238cd7d834..000000000000
--- a/dev-perl/libwww-perl/libwww-perl-6.0.0.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-6.0.0.ebuild,v 1.1 2011/03/09 14:58:17 tove Exp $
-
-EAPI=3
-
-MODULE_AUTHOR=GAAS
-MODULE_VERSION=6.00
-inherit perl-module
-
-DESCRIPTION="A collection of Perl Modules for the WWW"
-
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="ssl"
-
-RDEPEND="
- >=dev-perl/File-Listing-6.0.0
- >=dev-perl/HTTP-Cookies-6.0.0
- >=dev-perl/HTTP-Date-6.0.0
- >=dev-perl/HTTP-Negotiate-6.0.0
- >=dev-perl/HTTP-Message-6.0.0
- >=dev-perl/LWP-MediaTypes-6.0.0
- >=dev-perl/Net-HTTP-6.0.0
- >=dev-perl/WWW-RobotRules-6.0.0
- >=virtual/perl-Digest-MD5-2.12
- dev-perl/Encode-Locale
- >=dev-perl/HTML-Parser-3.34
- >=virtual/perl-MIME-Base64-2.12
- virtual/perl-libnet
- >=dev-perl/URI-1.10
- ssl? ( dev-perl/Crypt-SSLeay )
-"
-DEPEND="${RDEPEND}"
-
-src_install() {
- perl-module_src_install
-
- # Perform a check to see if the live filesystem is case-INsensitive
- # or not. If it is, the symlinks GET, POST and in particular HEAD
- # will collide with e.g. head from coreutils. While under Linux
- # having a case-INsensitive filesystem is really unusual, most Mac
- # OS X users are on it, and also Interix users deal with
- # case-INsensitivity since Windows is underneath.
-
- # bash should always be there, if we can find it in capitals, we're
- # on a case-INsensitive filesystem.
- if [[ ! -f ${EROOT}/BIN/BASH ]] ; then
- dosym /usr/bin/lwp-request /usr/bin/GET
- dosym /usr/bin/lwp-request /usr/bin/POST
- dosym /usr/bin/lwp-request /usr/bin/HEAD
- fi
-}
-#SRC_TEST=do
diff --git a/dev-perl/libwww-perl/libwww-perl-6.10.0.ebuild b/dev-perl/libwww-perl/libwww-perl-6.10.0.ebuild
index 3162fc6fa9e0..a279baa81272 100644
--- a/dev-perl/libwww-perl/libwww-perl-6.10.0.ebuild
+++ b/dev-perl/libwww-perl/libwww-perl-6.10.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-6.10.0.ebuild,v 1.1 2011/03/11 07:01:11 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/libwww-perl/libwww-perl-6.10.0.ebuild,v 1.2 2011/03/17 07:23:22 tove Exp $
EAPI=3
@@ -30,10 +30,15 @@ RDEPEND="
>=virtual/perl-MIME-Base64-2.12
virtual/perl-libnet
>=dev-perl/URI-1.10
- ssl? ( dev-perl/Crypt-SSLeay )
+ ssl? (
+ dev-perl/Crypt-SSLeay
+ app-misc/ca-certificates
+ )
"
DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}"/ca-certs.patch )
+
src_install() {
perl-module_src_install