summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2002-09-17 20:10:55 +0000
committerMichael Cummings <mcummings@gentoo.org>2002-09-17 20:10:55 +0000
commit2e00143dd3ec4c00d9a605e359ddc756c533b041 (patch)
treed302e2800d0a19832303f43c31b5d907b53832e6 /dev-perl
parentmasked PyQT 3.4 (diff)
downloadgentoo-2-2e00143dd3ec4c00d9a605e359ddc756c533b041.tar.gz
gentoo-2-2e00143dd3ec4c00d9a605e359ddc756c533b041.tar.bz2
gentoo-2-2e00143dd3ec4c00d9a605e359ddc756c533b041.zip
Corrected infinite loop dependancy
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/ExtUtils-MakeMaker/ChangeLog6
-rw-r--r--dev-perl/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.03-r1.ebuild41
2 files changed, 41 insertions, 6 deletions
diff --git a/dev-perl/ExtUtils-MakeMaker/ChangeLog b/dev-perl/ExtUtils-MakeMaker/ChangeLog
index af45a5525d3c..c352200d56ab 100644
--- a/dev-perl/ExtUtils-MakeMaker/ChangeLog
+++ b/dev-perl/ExtUtils-MakeMaker/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for dev-perl/ExtUtils-MakeMaker
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/ExtUtils-MakeMaker/ChangeLog,v 1.3 2002/09/14 21:29:14 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/ExtUtils-MakeMaker/ChangeLog,v 1.4 2002/09/17 20:10:55 mcummings Exp $
*ExtUtils-MakeMaker-6.03-r1 (16 Aug 2002)
+ 17 Sep 2002; <mcummings@gentoo.org> : Made the ebuild independant of the
+ perl-module.eclass - was causing recursive loops since it is required by
+ the same eclass.
+
14 Sep 2002; <mcummings@gentoo.org> : corrected syntax
*ExtUtils-MakeMaker-6.03 (16 Aug 2002)
diff --git a/dev-perl/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.03-r1.ebuild b/dev-perl/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.03-r1.ebuild
index a28dd587447f..5690c7ffd3ff 100644
--- a/dev-perl/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.03-r1.ebuild
+++ b/dev-perl/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.03-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.03-r1.ebuild,v 1.1 2002/09/14 21:29:14 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/ExtUtils-MakeMaker/ExtUtils-MakeMaker-6.03-r1.ebuild,v 1.2 2002/09/17 20:10:55 mcummings Exp $
-inherit perl-module
+inherit perl-post
S=${WORKDIR}/${P}
DESCRIPTION="MakeMaker Perl Module"
@@ -15,12 +15,43 @@ KEYWORDS="x86 sparc sparc64 ppc"
src_compile() {
cd ${S}
- perl Makefile.PL ${myconf}
+ perl Makefile.PL ${myconf} PREFIX=${D}/usr
- perl-module_src_compile
}
src_install () {
- perl-module_src_install
+perl-post_perlinfo
+ dodir ${POD_DIR}
+
+ test -z ${mytargets} && mytargets="install"
+ make \
+ PREFIX=${D}/usr \
+ INSTALLMAN1DIR=${D}/usr/share/man/man1 \
+ INSTALLMAN2DIR=${D}/usr/share/man/man2 \
+ INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ INSTALLMAN4DIR=${D}/usr/share/man/man4 \
+ INSTALLMAN5DIR=${D}/usr/share/man/man5 \
+ INSTALLMAN6DIR=${D}/usr/share/man/man6 \
+ INSTALLMAN7DIR=${D}/usr/share/man/man7 \
+ INSTALLMAN8DIR=${D}/usr/share/man/man8 \
+ ${myinst} \
+ ${mytargets} || die
+ if [ -f ${D}${ARCH_LIB}/perllocal.pod ];
+ then
+ touch ${D}/${POD_DIR}/${P}.pod
+ sed -e "s:${D}::g" ${D}${ARCH_LIB}/perllocal.pod >> ${D}/${POD_DIR}/${P}.pod
+ touch ${D}/${POD_DIR}/${P}.pod.arch
+ cat ${D}/${POD_DIR}/${P}.pod >>${D}/${POD_DIR}/${P}.pod.arch
+ rm -f ${D}/${ARCH_LIB}/perllocal.pod
+ fi
+ if [ -f ${D}${SITE_LIB}/perllocal.pod ];
+ then
+ touch ${D}/${POD_DIR}/${P}.pod
+ sed -e "s:${D}::g" ${D}${SITE_LIB}/perllocal.pod >> ${D}/${POD_DIR}/${P}.pod
+ touch ${D}/${POD_DIR}/${P}.pod.site
+ cat ${D}/${POD_DIR}/${P}.pod >>${D}/${POD_DIR}/${P}.pod.site
+ rm -f ${D}/${SITE_LIB}/perllocal.pod
+ fi
+ dodoc Change* MANIFEST* README* ${mydoc}
}