summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-01-09 15:26:53 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-01-09 15:26:53 +0000
commit571b3cf4ca58777c0c753764b247726c70674c9a (patch)
tree4e18bd839caf2445a51125e5adea93faa3a9cf86 /dev-php/ffmpeg-php
parentx86 stable wrt bug #396359 (diff)
downloadgentoo-2-571b3cf4ca58777c0c753764b247726c70674c9a.tar.gz
gentoo-2-571b3cf4ca58777c0c753764b247726c70674c9a.tar.bz2
gentoo-2-571b3cf4ca58777c0c753764b247726c70674c9a.zip
look for metadata closer to what the test suite expects, disable logging outside of php so that most of the testsuite passes now
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/ffmpeg-php')
-rw-r--r--dev-php/ffmpeg-php/ChangeLog7
-rw-r--r--dev-php/ffmpeg-php/ffmpeg-php-0.6.0-r1.ebuild3
-rw-r--r--dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-ffmpeg.patch4
-rw-r--r--dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-log.patch12
4 files changed, 22 insertions, 4 deletions
diff --git a/dev-php/ffmpeg-php/ChangeLog b/dev-php/ffmpeg-php/ChangeLog
index 915899ce0177..981540b733f4 100644
--- a/dev-php/ffmpeg-php/ChangeLog
+++ b/dev-php/ffmpeg-php/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-php/ffmpeg-php
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/ffmpeg-php/ChangeLog,v 1.2 2012/01/09 14:53:06 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/ffmpeg-php/ChangeLog,v 1.3 2012/01/09 15:26:53 aballier Exp $
+
+ 09 Jan 2012; Alexis Ballier <aballier@gentoo.org> ffmpeg-php-0.6.0-r1.ebuild,
+ files/ffmpeg-php-0.6.0-ffmpeg.patch, +files/ffmpeg-php-0.6.0-log.patch:
+ look for metadata closer to what the test suite expects, disable logging
+ outside of php so that most of the testsuite passes now
09 Jan 2012; Alexis Ballier <aballier@gentoo.org> ffmpeg-php-0.6.0-r1.ebuild,
+files/ffmpeg-php-0.6.0-ffmpeg.patch:
diff --git a/dev-php/ffmpeg-php/ffmpeg-php-0.6.0-r1.ebuild b/dev-php/ffmpeg-php/ffmpeg-php-0.6.0-r1.ebuild
index 0c107bab2567..393fd5fe13a4 100644
--- a/dev-php/ffmpeg-php/ffmpeg-php-0.6.0-r1.ebuild
+++ b/dev-php/ffmpeg-php/ffmpeg-php-0.6.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/ffmpeg-php/ffmpeg-php-0.6.0-r1.ebuild,v 1.2 2012/01/09 14:53:06 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/ffmpeg-php/ffmpeg-php-0.6.0-r1.ebuild,v 1.3 2012/01/09 15:26:53 aballier Exp $
EAPI="3"
@@ -35,6 +35,7 @@ src_prepare() {
cd "${WORKDIR}/${slot}"
epatch "${FILESDIR}/${P}-avutil50.patch"
epatch "${FILESDIR}/${P}-ffmpeg.patch"
+ epatch "${FILESDIR}/${P}-log.patch"
done
php-ext-source-r2_src_prepare
}
diff --git a/dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-ffmpeg.patch b/dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-ffmpeg.patch
index 5de51efa8727..9e8c864afcf5 100644
--- a/dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-ffmpeg.patch
+++ b/dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-ffmpeg.patch
@@ -131,7 +131,7 @@ Index: work/php5.3/ffmpeg_movie.c
- RETURN_STRINGL(ffmovie_ctx->fmt_ctx->album,
- strlen(ffmovie_ctx->fmt_ctx->album), 1);
-+ val = get_metadata(ffmovie_ctx->fmt_ctx->metadata, "ALBUMTITLE");
++ val = get_metadata(ffmovie_ctx->fmt_ctx->metadata, "ALBUM");
+ RETURN_STRINGL(val, strlen(val), 1);
}
/* }}} */
@@ -174,7 +174,7 @@ Index: work/php5.3/ffmpeg_movie.c
GET_MOVIE_RESOURCE(ffmovie_ctx);
- RETURN_LONG(ffmovie_ctx->fmt_ctx->year);
-+ val = get_metadata(ffmovie_ctx->fmt_ctx->metadata, "YEAR");
++ val = get_metadata(ffmovie_ctx->fmt_ctx->metadata, "DATE");
+ RETURN_STRINGL(val, strlen(val), 1);
}
/* }}} */
diff --git a/dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-log.patch b/dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-log.patch
new file mode 100644
index 000000000000..3b5bb88322e9
--- /dev/null
+++ b/dev-php/ffmpeg-php/files/ffmpeg-php-0.6.0-log.patch
@@ -0,0 +1,12 @@
+Index: work/php5.3/ffmpeg-php.c
+===================================================================
+--- work.orig/php5.3/ffmpeg-php.c
++++ work/php5.3/ffmpeg-php.c
+@@ -101,6 +101,7 @@ PHP_MINIT_FUNCTION(ffmpeg)
+ if (INI_BOOL("ffmpeg.show_warnings")) {
+ av_log_set_callback(ffmpeg_errorhandler);
+ }
++ else av_log_set_level(AV_LOG_QUIET);
+
+ register_ffmpeg_movie_class(module_number);
+ register_ffmpeg_frame_class(module_number);