summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-09-14 17:08:51 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-09-14 17:08:51 +0000
commitd1f3f6ad45cc3154439505030ae6851d75dabea9 (patch)
treeac8276f7b0792063b3b8c0f9b105a1e912db2171 /dev-php/mod_php
parentstable on amd64, bug #63187 (Manifest recommit) (diff)
downloadgentoo-2-d1f3f6ad45cc3154439505030ae6851d75dabea9.tar.gz
gentoo-2-d1f3f6ad45cc3154439505030ae6851d75dabea9.tar.bz2
gentoo-2-d1f3f6ad45cc3154439505030ae6851d75dabea9.zip
Fix bug #63702, remove the old workaround.
Diffstat (limited to 'dev-php/mod_php')
-rw-r--r--dev-php/mod_php/ChangeLog6
-rw-r--r--dev-php/mod_php/files/70_mod_php.conf68
-rw-r--r--dev-php/mod_php/files/70_mod_php5.conf50
3 files changed, 53 insertions, 71 deletions
diff --git a/dev-php/mod_php/ChangeLog b/dev-php/mod_php/ChangeLog
index d14dc27cc8e6..e3e4e5e02997 100644
--- a/dev-php/mod_php/ChangeLog
+++ b/dev-php/mod_php/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/mod_php
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.180 2004/09/12 21:41:15 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/mod_php/ChangeLog,v 1.181 2004/09/14 17:08:51 robbat2 Exp $
+
+ 14 Sep 2004; Robin H. Johnson <robbat2@gentoo.org> files/70_mod_php.conf,
+ files/70_mod_php5.conf:
+ Fix bug #63702, remove the old workaround.
12 Sep 2004; Robin H. Johnson <robbat2@gentoo.org> mod_php-5.0.0-r1.ebuild,
mod_php-5.0.0.ebuild, mod_php-5.0.1.ebuild:
diff --git a/dev-php/mod_php/files/70_mod_php.conf b/dev-php/mod_php/files/70_mod_php.conf
index 9f7c17c7a8d2..1bb3a229d505 100644
--- a/dev-php/mod_php/files/70_mod_php.conf
+++ b/dev-php/mod_php/files/70_mod_php.conf
@@ -1,44 +1,40 @@
+# vim: ft=apache sw=4 ts=4
<IfDefine PHP4>
-
- # Load the module first
- <IfModule !sapi_apache2.c>
- LoadModule php4_module extramodules/libphp4.so
- </IfModule>
-
- # Set it to handle the files
- <IfModule mod_mime.c>
- AddType application/x-httpd-php .php
- AddType application/x-httpd-php .phtml
- AddType application/x-httpd-php .php3
- AddType application/x-httpd-php .php4
- AddType application/x-httpd-php-source .phps
- </IfModule>
-
- # Fix some bugs
- <Files *.php>
+
+ # Load the module first
+ <IfModule !sapi_apache2.c>
+ LoadModule php4_module extramodules/libphp4.so
+ </IfModule>
+
+ # Set it to handle the files
+ <IfModule mod_mime.c>
+ AddType application/x-httpd-php .php
+ AddType application/x-httpd-php .phtml
+ AddType application/x-httpd-php .php3
+ AddType application/x-httpd-php .php4
+ AddType application/x-httpd-php-source .phps
+ </IfModule>
+
+ # Fix some bugs
+ <Files *.php>
# keep this the same size as post_max_size in php.ini
- # LimitRequestBody 8388608
- RequestHeader unset If-Modified-Since
- </Files>
- <Files *.php3>
+ # LimitRequestBody 8388608
+ </Files>
+ <Files *.php3>
# keep this the same size as post_max_size in php.ini
- # LimitRequestBody 8388608
- RequestHeader unset If-Modified-Since
- </Files>
- <Files *.php4>
+ # LimitRequestBody 8388608
+ </Files>
+ <Files *.php4>
# keep this the same size as post_max_size in php.ini
- # LimitRequestBody 8388608
- RequestHeader unset If-Modified-Since
- </Files>
- <Files *.phps>
+ # LimitRequestBody 8388608
+ </Files>
+ <Files *.phps>
# keep this the same size as post_max_size in php.ini
- # LimitRequestBody 8388608
- RequestHeader unset If-Modified-Since
- </Files>
- <Files *.phtml>
+ # LimitRequestBody 8388608
+ </Files>
+ <Files *.phtml>
# keep this the same size as post_max_size in php.ini
- # LimitRequestBody 8388608
- RequestHeader unset If-Modified-Since
- </Files>
+ # LimitRequestBody 8388608
+ </Files>
</IfDefine>
diff --git a/dev-php/mod_php/files/70_mod_php5.conf b/dev-php/mod_php/files/70_mod_php5.conf
index b86f2c2280a3..37a8e41c88a7 100644
--- a/dev-php/mod_php/files/70_mod_php5.conf
+++ b/dev-php/mod_php/files/70_mod_php5.conf
@@ -1,37 +1,19 @@
+# vim: ft=apache sw=4 ts=4
<IfDefine PHP5>
-
- # Load the module first
- <IfModule !sapi_apache2.c>
- LoadModule php5_module modules/libphp5.so
- </IfModule>
-
- # Set it to handle the files
- <IfModule mod_mime.c>
- AddType application/x-httpd-php .php
- AddType application/x-httpd-php .phtml
- AddType application/x-httpd-php .php3
- AddType application/x-httpd-php .php4
- AddType application/x-httpd-php .php5
- AddType application/x-httpd-php-source .phps
- </IfModule>
-
- <Files *.php>
- RequestHeader unset If-Modified-Since
- </Files>
- <Files *.php3>
- RequestHeader unset If-Modified-Since
- </Files>
- <Files *.php4>
- RequestHeader unset If-Modified-Since
- </Files>
- <Files *.php5>
- RequestHeader unset If-Modified-Since
- </Files>
- <Files *.phps>
- RequestHeader unset If-Modified-Since
- </Files>
- <Files *.phtml>
- RequestHeader unset If-Modified-Since
- </Files>
+
+ # Load the module first
+ <IfModule !sapi_apache2.c>
+ LoadModule php5_module modules/libphp5.so
+ </IfModule>
+
+ # Set it to handle the files
+ <IfModule mod_mime.c>
+ AddType application/x-httpd-php .php
+ AddType application/x-httpd-php .phtml
+ AddType application/x-httpd-php .php3
+ AddType application/x-httpd-php .php4
+ AddType application/x-httpd-php .php5
+ AddType application/x-httpd-php-source .phps
+ </IfModule>
</IfDefine>