summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-02-17 01:07:11 +0000
committerBrian Evans <grknight@gentoo.org>2015-02-17 01:07:11 +0000
commitdc0e9f299f8d72b14cdf3053c334d920db2b6cc7 (patch)
treefdf534e0e5eb91f87b976d1a4234e428c5340107 /dev-php/pecl-drizzle
parentFile collision with gnome-common, bug #540138 (diff)
downloadgentoo-2-dc0e9f299f8d72b14cdf3053c334d920db2b6cc7.tar.gz
gentoo-2-dc0e9f299f8d72b14cdf3053c334d920db2b6cc7.tar.bz2
gentoo-2-dc0e9f299f8d72b14cdf3053c334d920db2b6cc7.zip
Revbump with 5.4+ support. Lightly tested and may be removed if it breaks since dev-db/drizzle needs help
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key 0xD1F781EFF9F4A3B6)
Diffstat (limited to 'dev-php/pecl-drizzle')
-rw-r--r--dev-php/pecl-drizzle/ChangeLog12
-rw-r--r--dev-php/pecl-drizzle/files/pecl-drizzle-0.4.2-php54.patch73
-rw-r--r--dev-php/pecl-drizzle/pecl-drizzle-0.4.2-r2.ebuild21
-rw-r--r--dev-php/pecl-drizzle/pecl-drizzle-0.4.2-r3.ebuild35
4 files changed, 118 insertions, 23 deletions
diff --git a/dev-php/pecl-drizzle/ChangeLog b/dev-php/pecl-drizzle/ChangeLog
index 31a1dd006b78..c91ce23a38fb 100644
--- a/dev-php/pecl-drizzle/ChangeLog
+++ b/dev-php/pecl-drizzle/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-php/pecl-drizzle
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-drizzle/ChangeLog,v 1.6 2013/03/17 15:57:08 hwoarang Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-drizzle/ChangeLog,v 1.7 2015/02/17 01:07:11 grknight Exp $
+
+*pecl-drizzle-0.4.2-r3 (17 Feb 2015)
+
+ 17 Feb 2015; Brian Evans <grknight@gentoo.org>
+ +files/pecl-drizzle-0.4.2-php54.patch, +pecl-drizzle-0.4.2-r3.ebuild,
+ -pecl-drizzle-0.4.2-r2.ebuild:
+ Revbump with 5.4+ support. Lightly tested and may be removed if it breaks
+ since dev-db/drizzle needs help
17 Mar 2013; Markos Chandras <hwoarang@gentoo.org> metadata.xml:
Add proxy-maintainers to metadata.xml
diff --git a/dev-php/pecl-drizzle/files/pecl-drizzle-0.4.2-php54.patch b/dev-php/pecl-drizzle/files/pecl-drizzle-0.4.2-php54.patch
new file mode 100644
index 000000000000..42c27103a67b
--- /dev/null
+++ b/dev-php/pecl-drizzle/files/pecl-drizzle-0.4.2-php54.patch
@@ -0,0 +1,73 @@
+diff -aurN drizzle-0.4.2.orig/php_drizzle.c drizzle-0.4.2/php_drizzle.c
+--- drizzle-0.4.2.orig/php_drizzle.c 1970-01-01 04:13:08.000000000 -0500
++++ drizzle-0.4.2/php_drizzle.c 2014-10-22 21:38:21.882838493 -0400
+@@ -1314,9 +1314,13 @@
+ }
+
+ zend_object_std_init(&(obj->std), class_type TSRMLS_CC);
++#if PHP_VERSION_ID < 50399
+ zend_hash_copy(obj->std.properties, &(class_type->default_properties),
+ (copy_ctor_func_t)zval_add_ref, (void *)(&tmp),
+ sizeof(zval *));
++#else
++ object_properties_init((zend_object*) &(obj->std), class_type);
++#endif
+
+ value.handle= zend_objects_store_put(obj,
+ (zend_objects_store_dtor_t)zend_objects_destroy_object,
+@@ -1582,9 +1586,13 @@
+ }
+
+ zend_object_std_init(&(obj->std), class_type TSRMLS_CC);
++#if PHP_VERSION_ID < 50399
+ zend_hash_copy(obj->std.properties, &(class_type->default_properties),
+ (copy_ctor_func_t)zval_add_ref, (void *)(&tmp),
+ sizeof(zval *));
++#else
++ object_properties_init((zend_object*) &(obj->std), class_type);
++#endif
+
+ obj->value.handle= zend_objects_store_put(obj,
+ (zend_objects_store_dtor_t)zend_objects_destroy_object,
+@@ -2505,9 +2513,13 @@
+ }
+
+ zend_object_std_init(&(obj->std), class_type TSRMLS_CC);
++#if PHP_VERSION_ID < 50399
+ zend_hash_copy(obj->std.properties, &(class_type->default_properties),
+ (copy_ctor_func_t)zval_add_ref, (void *)(&tmp),
+ sizeof(zval *));
++#else
++ object_properties_init((zend_object*) &(obj->std), class_type);
++#endif
+
+ obj->value.handle= zend_objects_store_put(obj,
+ (zend_objects_store_dtor_t)zend_objects_destroy_object,
+@@ -3017,9 +3029,13 @@
+ }
+
+ zend_object_std_init(&(result->std), class_type TSRMLS_CC);
++#if PHP_VERSION_ID < 50399
+ zend_hash_copy(result->std.properties, &(class_type->default_properties),
+ (copy_ctor_func_t)zval_add_ref, (void *)(&tmp),
+ sizeof(zval *));
++#else
++ object_properties_init((zend_object*) &(result->std), class_type);
++#endif
+
+ value.handle= zend_objects_store_put(result,
+ (zend_objects_store_dtor_t)zend_objects_destroy_object,
+@@ -3382,9 +3398,13 @@
+ }
+
+ zend_object_std_init(&(obj->std), class_type TSRMLS_CC);
++#if PHP_VERSION_ID < 50399
+ zend_hash_copy(obj->std.properties, &(class_type->default_properties),
+ (copy_ctor_func_t)zval_add_ref, (void *)(&tmp),
+ sizeof(zval *));
++#else
++ object_properties_init((zend_object*) &(obj->std), class_type);
++#endif
+
+ value.handle= zend_objects_store_put(obj,
+ (zend_objects_store_dtor_t)zend_objects_destroy_object,
diff --git a/dev-php/pecl-drizzle/pecl-drizzle-0.4.2-r2.ebuild b/dev-php/pecl-drizzle/pecl-drizzle-0.4.2-r2.ebuild
deleted file mode 100644
index 524047e449c8..000000000000
--- a/dev-php/pecl-drizzle/pecl-drizzle-0.4.2-r2.ebuild
+++ /dev/null
@@ -1,21 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-drizzle/pecl-drizzle-0.4.2-r2.ebuild,v 1.2 2012/08/23 15:59:13 olemarkus Exp $
-
-EAPI="4"
-
-PHP_EXT_NAME="drizzle"
-PHP_EXT_INI="yes"
-PHP_EXT_ZENDEXT="no"
-
-inherit php-ext-pecl-r2
-
-KEYWORDS="~amd64"
-
-DESCRIPTION="PHP extension using libdrizzle library to provide communcation with Drizzle and MySQL databases"
-LICENSE="PHP-3"
-SLOT="0"
-IUSE=""
-
-DEPEND="dev-db/drizzle"
-RDEPEND="${DEPEND}"
diff --git a/dev-php/pecl-drizzle/pecl-drizzle-0.4.2-r3.ebuild b/dev-php/pecl-drizzle/pecl-drizzle-0.4.2-r3.ebuild
new file mode 100644
index 000000000000..1a3be8321f35
--- /dev/null
+++ b/dev-php/pecl-drizzle/pecl-drizzle-0.4.2-r3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/pecl-drizzle/pecl-drizzle-0.4.2-r3.ebuild,v 1.1 2015/02/17 01:07:11 grknight Exp $
+
+EAPI="5"
+
+PHP_EXT_NAME="drizzle"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+
+USE_PHP="php5-6 php5-5 php5-4"
+
+inherit php-ext-pecl-r2 eutils
+
+KEYWORDS="~amd64"
+
+DESCRIPTION="PHP extension using libdrizzle library to provide communcation with Drizzle and MySQL databases"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-db/drizzle"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ local slot orig_s="${PHP_EXT_S}"
+ for slot in $(php_get_slots); do
+ php_init_slot_env ${slot}
+ epatch "${FILESDIR}/${P}-php54.patch"
+ #Fix tests
+ mkdir ext || die
+ mv drizzle_*.phpt ext || die
+ done
+ php-ext-source-r2_src_prepare
+}