summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2010-01-01 21:38:07 +0000
committerBen de Groot <yngwin@gentoo.org>2010-01-01 21:38:07 +0000
commitd6267d4eb502649695a1527cdc83380e9f264739 (patch)
treeabe44e7c078f5057072520b93d7036de6187bf69 /dev-php/php-openid/php-openid-2.1.3.ebuild
parentTransfer Prefix keywords (diff)
downloadgentoo-2-d6267d4eb502649695a1527cdc83380e9f264739.tar.gz
gentoo-2-d6267d4eb502649695a1527cdc83380e9f264739.tar.bz2
gentoo-2-d6267d4eb502649695a1527cdc83380e9f264739.zip
Initial commit. Ebuild based on the one by Nathan Phillip Brink in his ohnobinki overlay.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-php/php-openid/php-openid-2.1.3.ebuild')
-rw-r--r--dev-php/php-openid/php-openid-2.1.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/php-openid/php-openid-2.1.3.ebuild b/dev-php/php-openid/php-openid-2.1.3.ebuild
new file mode 100644
index 000000000000..00938704b1f4
--- /dev/null
+++ b/dev-php/php-openid/php-openid-2.1.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/php-openid/php-openid-2.1.3.ebuild,v 1.1 2010/01/01 21:38:07 yngwin Exp $
+
+EAPI="2"
+inherit php-lib-r1
+
+PHP_LIB_NAME="Auth"
+DESCRIPTION="PHP OpenID implementation"
+HOMEPAGE="http://openidenabled.com/php-openid/"
+SRC_URI="http://openidenabled.com/files/php-openid/packages/${P}.tar.bz2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="|| ( virtual/php[bcmath] virtual/php[gmp] )
+ virtual/php[curl]"
+
+src_install() {
+ cd "${S}"/Auth
+ php-lib-r1_src_install . * */*
+
+ if use examples; then
+ cd "${S}"
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ fi
+}