summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2003-05-11 13:14:53 +0000
committerTom William Payne <twp@gentoo.org>2003-05-11 13:14:53 +0000
commit046c07efb1ea488ec9c47abf27e9189e75112c7b (patch)
tree22b7c5736085337c0d4a1f69bb38395286272d30 /dev-php
parentInitial commit (diff)
downloadgentoo-2-046c07efb1ea488ec9c47abf27e9189e75112c7b.tar.gz
gentoo-2-046c07efb1ea488ec9c47abf27e9189e75112c7b.tar.bz2
gentoo-2-046c07efb1ea488ec9c47abf27e9189e75112c7b.zip
Initial commit
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/smarty/ChangeLog8
-rw-r--r--dev-php/smarty/Manifest4
-rw-r--r--dev-php/smarty/files/digest-smarty-2.5.02
-rw-r--r--dev-php/smarty/smarty-2.5.0.ebuild32
4 files changed, 44 insertions, 2 deletions
diff --git a/dev-php/smarty/ChangeLog b/dev-php/smarty/ChangeLog
new file mode 100644
index 000000000000..63ea8128c76f
--- /dev/null
+++ b/dev-php/smarty/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-php/smarty
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/ChangeLog,v 1.1 2003/05/11 13:14:35 twp Exp $
+
+*smarty-2.5.0 (11 May 2003)
+
+ 11 May 2003; Tom Payne <twp@gentoo.org> smarty-2.5.0.ebuild :
+ Initial version.
diff --git a/dev-php/smarty/Manifest b/dev-php/smarty/Manifest
index cb032e307ee8..b27264569b8a 100644
--- a/dev-php/smarty/Manifest
+++ b/dev-php/smarty/Manifest
@@ -1,3 +1,3 @@
-MD5 b566bd64eac9631d8ce8aab68c312e9e smarty-2.5.0.ebuild 902
-MD5 555ce70751b9cacd155c0d6a614b3a18 ChangeLog 235
+MD5 43d5731b78f6d99e3ff4791b1ce3dc25 smarty-2.5.0.ebuild 996
+MD5 ac7d8ccca264e19847e4629d3c22e5f5 ChangeLog 319
MD5 74ae938ca9097670a89c5f2ff6ad28f8 files/digest-smarty-2.5.0 133
diff --git a/dev-php/smarty/files/digest-smarty-2.5.0 b/dev-php/smarty/files/digest-smarty-2.5.0
new file mode 100644
index 000000000000..cc763efc1623
--- /dev/null
+++ b/dev-php/smarty/files/digest-smarty-2.5.0
@@ -0,0 +1,2 @@
+MD5 9acb557dc4e344fadc2ab2270c74dfa2 Smarty-2.5.0.tar.gz 101763
+MD5 22bd33a9b9cf497e80eb21659b4c2163 Smarty-2.5.0-docs.tar.gz 101422
diff --git a/dev-php/smarty/smarty-2.5.0.ebuild b/dev-php/smarty/smarty-2.5.0.ebuild
new file mode 100644
index 000000000000..c758f133f394
--- /dev/null
+++ b/dev-php/smarty/smarty-2.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/smarty/smarty-2.5.0.ebuild,v 1.1 2003/05/11 13:14:35 twp Exp $
+
+MY_P=Smarty-${PV}
+DESCRIPTION="A template engine for PHP"
+HOMEPAGE="http://smarty.php.net/"
+SRC_URI="http://smarty.php.net/distributions/${MY_P}.tar.gz
+ http://smarty.php.net/distributions/manual/en/${MY_P}-docs.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha arm hppa mips ppc sparc x86"
+IUSE="doc"
+DEPEND="virtual/php"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ dodoc [A-Z]*
+ insinto /usr/lib/php/Smarty
+ doins libs/*
+ insinto /usr/lib/php/Smarty/plugins
+ doins libs/plugins/*
+ dohtml -r ../manual/*
+}
+
+pkg_postinst() {
+ einfo "Smarty has been installed in /usr/lib/php/Smarty."
+ einfo "To use it in your scripts, either"
+ einfo "1. define(SMARTY_DIR, \"/usr/lib/php/Smarty\") in your scripts, or"
+ einfo "2. add /usr/lib/php/Smarty to includes= in /etc/php4/php.ini"
+}