summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2008-01-01 18:00:31 +0000
committerMarijn Schouten <hkbst@gentoo.org>2008-01-01 18:00:31 +0000
commit28e4c51a091a22d57de8bca382bf1613710164be (patch)
treeb3890c4e0463b2b5456e984a5a0f9aa11fb7a70f /dev-php
parentMarking libcdio-0.78.2-r2 ppc64 for bug 203777 (diff)
downloadgentoo-2-28e4c51a091a22d57de8bca382bf1613710164be.tar.gz
gentoo-2-28e4c51a091a22d57de8bca382bf1613710164be.tar.bz2
gentoo-2-28e4c51a091a22d57de8bca382bf1613710164be.zip
add bump, 2.9.3 should support all core PHP5 stuff
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/roadsend-php/ChangeLog10
-rw-r--r--dev-php/roadsend-php/files/digest-roadsend-php-2.9.33
-rw-r--r--dev-php/roadsend-php/roadsend-php-2.9.3.ebuild50
3 files changed, 61 insertions, 2 deletions
diff --git a/dev-php/roadsend-php/ChangeLog b/dev-php/roadsend-php/ChangeLog
index 26b46a7e877f..1980c1ea90e0 100644
--- a/dev-php/roadsend-php/ChangeLog
+++ b/dev-php/roadsend-php/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/roadsend-php
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/roadsend-php/ChangeLog,v 1.3 2007/08/20 10:18:28 hkbst Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/roadsend-php/ChangeLog,v 1.4 2008/01/01 18:00:30 hkbst Exp $
+
+*roadsend-php-2.9.3 (01 Jan 2008)
+
+ 01 Jan 2008; Marijn Schouten <hkBst@gentoo.org>
+ +roadsend-php-2.9.3.ebuild:
+ add bump, 2.9.3 should support all core PHP5 stuff
*roadsend-php-2.9.2 (20 Aug 2007)
diff --git a/dev-php/roadsend-php/files/digest-roadsend-php-2.9.3 b/dev-php/roadsend-php/files/digest-roadsend-php-2.9.3
new file mode 100644
index 000000000000..e0429ff20515
--- /dev/null
+++ b/dev-php/roadsend-php/files/digest-roadsend-php-2.9.3
@@ -0,0 +1,3 @@
+MD5 1a1512220395745d0a96cbb80bf9daf8 roadsend-php-2.9.3.tar.bz2 2842446
+RMD160 9bb7d7f5cb05882996a6e661ff6d8c4577c0be1b roadsend-php-2.9.3.tar.bz2 2842446
+SHA256 fc44d27a2123134e0fdfe24c9c44a95071c47c12c13087b11e7060ccf839555d roadsend-php-2.9.3.tar.bz2 2842446
diff --git a/dev-php/roadsend-php/roadsend-php-2.9.3.ebuild b/dev-php/roadsend-php/roadsend-php-2.9.3.ebuild
new file mode 100644
index 000000000000..79c9cd599446
--- /dev/null
+++ b/dev-php/roadsend-php/roadsend-php-2.9.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/roadsend-php/roadsend-php-2.9.3.ebuild,v 1.1 2008/01/01 18:00:30 hkbst Exp $
+
+MY_PVL=${PV/_p/-r}
+MY_PV=${PV%%_p[0-9]}
+MY_PL=${PN}-${MY_PVL}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Roadsend PHP compiler"
+HOMEPAGE="http://code.roadsend.com/pcc"
+SRC_URI="http://code.roadsend.com/snaps/${MY_PL}.tar.bz2"
+LICENSE="GPL-2 LGPL-2.1"
+
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=dev-scheme/bigloo-3.0c
+ >=net-misc/curl-7.15.1-r1
+ mysql? ( dev-db/mysql )
+ sqlite3? ( >=dev-db/sqlite-3.3.12 )
+ pcre? ( >=dev-libs/libpcre-6.6 )
+ xml? ( dev-libs/libxml2 )
+ odbc? ( dev-db/unixODBC )
+ fastcgi? ( dev-libs/fcgi )"
+
+RDEPEND="${DEPEND}"
+SLOT="0"
+
+IUSE="debug fastcgi mysql odbc pcre sqlite3 xml"
+#IUSE="fastcgi mysql odbc pcre sqlite3 xml"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf $(use_with pcre) $(use_with fastcgi fcgi) $(use_with xml) $(use_with mysql) $(use_with sqlite3) $(use_with odbc)
+
+ if use debug; then
+ emake -j1 || die "make debug failed"
+ else
+ emake -j1 unsafe || die "make failed"
+ fi
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}/libs/" emake -j1 test || die "standalone tests failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die "make install failed"
+}