summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-09-21 08:23:51 +0000
committerIan Delaney <idella4@gentoo.org>2014-09-21 08:23:51 +0000
commit81a3292a27643f329575e091fe2630837cecc69f (patch)
tree9434f991a1c2b0c5a15e8dd6688628953397aa21 /dev-python/Djblets/Djblets-0.7.31.ebuild
parentWhitespace (diff)
downloadgentoo-2-81a3292a27643f329575e091fe2630837cecc69f.tar.gz
gentoo-2-81a3292a27643f329575e091fe2630837cecc69f.tar.bz2
gentoo-2-81a3292a27643f329575e091fe2630837cecc69f.zip
bump; ebuild based on graaf's verion in his overlay, see Bug 512668, remove affected prior version
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/Djblets/Djblets-0.7.31.ebuild')
-rw-r--r--dev-python/Djblets/Djblets-0.7.31.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/Djblets/Djblets-0.7.31.ebuild b/dev-python/Djblets/Djblets-0.7.31.ebuild
new file mode 100644
index 000000000000..5e9c1df97df3
--- /dev/null
+++ b/dev-python/Djblets/Djblets-0.7.31.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/Djblets/Djblets-0.7.31.ebuild,v 1.1 2014/09/21 08:23:51 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 versionator
+
+DESCRIPTION="A collection of useful extensions for Django"
+HOMEPAGE="http://github.com/djblets/djblets"
+SRC_URI="http://downloads.reviewboard.org/releases/${PN}/$(get_version_component_range 1-2)/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-python/django-1.4.13[${PYTHON_USEDEP}]
+ =dev-python/django-1.4*[${PYTHON_USEDEP}]
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ >=dev-python/django-pipeline-1.2.24[${PYTHON_USEDEP}]
+ >=dev-python/feedparser-5.1.2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/django-evolution[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # use pillow, not PIL
+ sed -e 's/PIL/pillow/' -i setup.py Djblets.egg-info/requires.txt || die
+ distutils-r1_python_prepare_all
+}