summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2010-08-07 14:32:46 +0000
committerBrian Harring <ferringb@gentoo.org>2010-08-07 14:32:46 +0000
commite1cac4fd40e5510dd8c7d2d615f136d04169dac7 (patch)
tree47293733db85fc5c12948fb3e4c9229ff116c418 /dev-python/PyQrcodec
parentChange virtual/ruby to dev-lang/ruby, bug 265054. (diff)
downloadgentoo-2-e1cac4fd40e5510dd8c7d2d615f136d04169dac7.tar.gz
gentoo-2-e1cac4fd40e5510dd8c7d2d615f136d04169dac7.tar.bz2
gentoo-2-e1cac4fd40e5510dd8c7d2d615f136d04169dac7.zip
fix compilation bug 331433; namely, import ml.h
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/PyQrcodec')
-rw-r--r--dev-python/PyQrcodec/ChangeLog8
-rw-r--r--dev-python/PyQrcodec/PyQrcodec-1.0.ebuild11
-rw-r--r--dev-python/PyQrcodec/files/opencv-2.0-compat.patch11
3 files changed, 25 insertions, 5 deletions
diff --git a/dev-python/PyQrcodec/ChangeLog b/dev-python/PyQrcodec/ChangeLog
index fc21308a95c2..aa3e1da323a7 100644
--- a/dev-python/PyQrcodec/ChangeLog
+++ b/dev-python/PyQrcodec/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/PyQrcodec
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQrcodec/ChangeLog,v 1.4 2009/07/26 19:16:23 bangert Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQrcodec/ChangeLog,v 1.5 2010/08/07 14:32:46 ferringb Exp $
+
+ 07 Aug 2010; Brian Harring <ferringb@gentoo.org> PyQrcodec-1.0.ebuild,
+ +files/opencv-2.0-compat.patch:
+ bug 331433- update for opencv 2.0 header changes.
26 Jul 2009; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd> tag
diff --git a/dev-python/PyQrcodec/PyQrcodec-1.0.ebuild b/dev-python/PyQrcodec/PyQrcodec-1.0.ebuild
index d4cc52293cd9..f859ead673d5 100644
--- a/dev-python/PyQrcodec/PyQrcodec-1.0.ebuild
+++ b/dev-python/PyQrcodec/PyQrcodec-1.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQrcodec/PyQrcodec-1.0.ebuild,v 1.2 2009/02/15 21:58:47 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQrcodec/PyQrcodec-1.0.ebuild,v 1.3 2010/08/07 14:32:46 ferringb Exp $
-inherit distutils
+inherit distutils eutils
DESCRIPTION="PyQrCodec is a Python module for encoding and decoding QrCode images."
HOMEPAGE="http://www.pedemonte.eu/pyqr/index.py/pyqrhome"
@@ -17,3 +17,8 @@ DEPEND="dev-python/imaging
media-libs/opencv"
S="${WORKDIR}/PyQrCodec"
+
+src_unpack() {
+ distutils_src_unpack
+ epatch "$FILESDIR"/opencv-2.0-compat.patch
+}
diff --git a/dev-python/PyQrcodec/files/opencv-2.0-compat.patch b/dev-python/PyQrcodec/files/opencv-2.0-compat.patch
new file mode 100644
index 000000000000..ff675a0403e9
--- /dev/null
+++ b/dev-python/PyQrcodec/files/opencv-2.0-compat.patch
@@ -0,0 +1,11 @@
+diff -urN PyQrCodec/qr_dec/imagereader.h PyQrCodec-new/qr_dec/imagereader.h
+--- PyQrCodec/qr_dec/imagereader.h 2007-02-21 15:22:02.000000000 -0800
++++ PyQrCodec-new/qr_dec/imagereader.h 2010-08-07 07:24:52.800113738 -0700
+@@ -19,6 +19,7 @@
+ #endif
+
+ #include <cv.h>
++#include <ml.h>
+ #include <memory.h>
+ #include "qrerror.h"
+ #include "container.h"