summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2009-10-28 15:49:19 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2009-10-28 15:49:19 +0000
commit12449d242dab1bf4e47133c073305f32391510a8 (patch)
tree5d5c9cd9545934bb0b9982406ac4358becb50db8 /dev-python/PyQt4
parentVersion bump (diff)
downloadgentoo-2-12449d242dab1bf4e47133c073305f32391510a8.tar.gz
gentoo-2-12449d242dab1bf4e47133c073305f32391510a8.tar.bz2
gentoo-2-12449d242dab1bf4e47133c073305f32391510a8.zip
Version bump. Add new configuration patch
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/PyQt4')
-rw-r--r--dev-python/PyQt4/ChangeLog8
-rw-r--r--dev-python/PyQt4/PyQt4-4.6.1.ebuild155
-rw-r--r--dev-python/PyQt4/files/configure-4.6.1.py.patch36
3 files changed, 198 insertions, 1 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index ada627d8dc77..f119ddcb1664 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.93 2009/10/18 14:46:26 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.94 2009/10/28 15:49:19 hwoarang Exp $
+
+*PyQt4-4.6.1 (28 Oct 2009)
+
+ 28 Oct 2009; Markos Chandras <hwoarang@gentoo.org> +PyQt4-4.6.1.ebuild,
+ +files/configure-4.6.1.py.patch:
+ Version bump. Add new configuration patch
18 Oct 2009; Raúl Porcel <armin76@gentoo.org> PyQt4-4.5.4-r4.ebuild:
alpha/ia64/sparc stable wrt #284707
diff --git a/dev-python/PyQt4/PyQt4-4.6.1.ebuild b/dev-python/PyQt4/PyQt4-4.6.1.ebuild
new file mode 100644
index 000000000000..069289a52df1
--- /dev/null
+++ b/dev-python/PyQt4/PyQt4-4.6.1.ebuild
@@ -0,0 +1,155 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.6.1.ebuild,v 1.1 2009/10/28 15:49:19 hwoarang Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit python qt4 toolchain-funcs
+
+MY_P="PyQt-x11-gpl-${PV/_pre/-snapshot-}"
+QTVER="4.5.1"
+
+DESCRIPTION="A set of Python bindings for the Qt toolkit"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
+SRC_URI="http://www.riverbankcomputing.com/static/Downloads/${PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( GPL-2 GPL-3 )"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="X assistant +dbus debug doc examples kde opengl phonon sql svg webkit xmlpatterns"
+
+DEPEND=">=dev-python/sip-4.9
+ >=x11-libs/qt-core-${QTVER}:4
+ >=x11-libs/qt-script-${QTVER}:4
+ >=x11-libs/qt-test-${QTVER}:4
+ X? ( >=x11-libs/qt-gui-${QTVER}:4[dbus?] )
+ assistant? ( >=x11-libs/qt-assistant-${QTVER}:4 )
+ dbus? (
+ >=dev-python/dbus-python-0.80
+ >=x11-libs/qt-dbus-${QTVER}:4
+ )
+ opengl? ( >=x11-libs/qt-opengl-${QTVER}:4 )
+ phonon? (
+ !kde? ( || ( >=x11-libs/qt-phonon-${QTVER}:4 media-sound/phonon ) )
+ kde? ( media-sound/phonon )
+ )
+ sql? ( >=x11-libs/qt-sql-${QTVER}:4 )
+ svg? ( >=x11-libs/qt-svg-${QTVER}:4 )
+ webkit? ( >=x11-libs/qt-webkit-${QTVER}:4 )
+ xmlpatterns? ( >=x11-libs/qt-xmlpatterns-${QTVER}:4 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/configure-${PV}.py.patch"
+)
+
+src_prepare() {
+ if ! use dbus; then
+ sed -i -e 's,^\([[:blank:]]\+\)check_dbus(),\1pass,' \
+ "${S}"/configure.py || die
+ fi
+ qt4_src_prepare
+
+ python_copy_sources
+
+ preparation() {
+ if [[ "${PYTHON_ABI:0:1}" == "3" ]]; then
+ rm -fr pyuic/uic/port_v2
+ else
+ rm -fr pyuic/uic/port_v3
+ fi
+ }
+ python_execute_function -s preparation
+}
+
+pyqt4_use_enable() {
+ use $1 && echo "--enable=${2:-$1}"
+}
+
+src_configure() {
+ configuration() {
+ local myconf="$(PYTHON) configure.py
+ --confirm-license
+ --bindir=/usr/bin
+ --destdir=$(python_get_sitedir)
+ --sipdir=/usr/share/sip
+ $(use debug && echo '--debug')
+ --enable=QtCore
+ --enable=QtNetwork
+ --enable=QtScript
+ --enable=QtTest
+ --enable=QtXml
+ $(pyqt4_use_enable X QtGui)
+ $(pyqt4_use_enable X QtDesigner)
+ $(pyqt4_use_enable X QtScriptTools)
+ $(pyqt4_use_enable assistant QtAssistant)
+ $(pyqt4_use_enable assistant QtHelp)
+ $(pyqt4_use_enable opengl QtOpenGL)
+ $(pyqt4_use_enable phonon)
+ $(pyqt4_use_enable sql QtSql)
+ $(pyqt4_use_enable svg QtSvg)
+ $(pyqt4_use_enable webkit QtWebKit)
+ $(pyqt4_use_enable xmlpatterns QtXmlPatterns)
+ CC=$(tc-getCC) CXX=$(tc-getCXX)
+ LINK=$(tc-getCXX) LINK_SHLIB=$(tc-getCXX)
+ CFLAGS='${CFLAGS}' CXXFLAGS='${CXXFLAGS}' LFLAGS='${LDFLAGS}'"
+ echo ${myconf}
+ eval ${myconf} || return 1
+
+ for mod in QtCore $(use X && echo 'QtDesigner QtGui'); do
+ # Run eqmake4 inside the qpy subdirs to prevent
+ # stripping and many other QA issues
+ pushd qpy/${mod} > /dev/null || die
+ eqmake4 $(ls w_qpy*.pro)
+ popd > /dev/null || die
+
+ # Fix insecure runpaths
+ sed -i -e "/^LFLAGS/s:-Wl,-rpath,${BUILDDIR}/qpy/${mod}::" \
+ ${mod}/Makefile || die "failed to fix rpath issues"
+ done
+
+ # Fix pre-stripping of libpythonplugin.so
+ if use X; then
+ cd "${BUILDDIR}"/designer
+ eqmake4 python.pro
+ fi
+ }
+ python_execute_function -s configuration
+}
+
+src_compile() {
+ python_execute_function -d -s
+}
+
+src_install() {
+ python_need_rebuild
+
+ installation() {
+ # INSTALL_ROOT is needed for the QtDesigner module,
+ # the other Makefiles use DESTDIR.
+ emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
+ }
+ python_execute_function -s installation
+
+ dodoc ChangeLog doc/pyqt4ref.txt NEWS THANKS || die
+
+ if use doc; then
+ dohtml -r doc/* || die
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize PyQt4
+}
+
+pkg_postrm() {
+ python_mod_cleanup PyQt4
+}
diff --git a/dev-python/PyQt4/files/configure-4.6.1.py.patch b/dev-python/PyQt4/files/configure-4.6.1.py.patch
new file mode 100644
index 000000000000..b9d3db7dbd70
--- /dev/null
+++ b/dev-python/PyQt4/files/configure-4.6.1.py.patch
@@ -0,0 +1,36 @@
+--- PyQt-x11-gpl-4.6.1~orig/configure.py 2009-10-23 23:03:13.000000000 +0200
++++ PyQt-x11-gpl-4.6.1/configure.py 2009-10-23 23:33:06.000000000 +0200
+@@ -341,7 +341,7 @@
+ check_module("QtWebKit", "qwebpage.h", "new QWebPage()")
+ check_module("QtXml", "qdom.h", "new QDomDocument()")
+ check_module("QtXmlPatterns", "qxmlname.h", "new QXmlName()")
+- check_module("phonon", "Phonon/VideoWidget",
++ check_module("phonon", "phonon/videowidget.h",
+ "new Phonon::VideoWidget()")
+ check_module("QtAssistant", "qassistantclient.h",
+ "new QAssistantClient(\"foo\")", extra_lib_dirs=ass_lib_dirs,
+@@ -451,7 +451,7 @@
+ generate_code("QtXmlPatterns")
+
+ if "phonon" in pyqt_modules:
+- generate_code("phonon")
++ generate_code("phonon", extra_include_dirs=["/usr/include/phonon"])
+
+ if "QtAssistant" in pyqt_modules:
+ generate_code("QtAssistant")
+@@ -759,6 +759,7 @@
+ install_dir=pydbusmoddir,
+ qt=["QtCore"],
+ debug=opts.debug,
++ strip=0,
+ universal=sipcfg.universal,
+ arch=sipcfg.arch
+ )
+@@ -1468,6 +1469,7 @@
+ warnings=1,
+ static=opts.static,
+ debug=opts.debug,
++ strip=0,
+ universal=sipcfg.universal,
+ arch=sipcfg.arch
+ )