summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-08-24 16:28:35 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-08-24 16:28:35 +0000
commitcc54f7fca075df8241477dd52ae8951a1fae46a4 (patch)
treec033f5b2c91b6d09d5b747dc44e8e2e3dd2ed260 /dev-python/PyQt4
parent[bump] dev-perl/Devel-Declare-0.6.6 (diff)
downloadgentoo-2-cc54f7fca075df8241477dd52ae8951a1fae46a4.tar.gz
gentoo-2-cc54f7fca075df8241477dd52ae8951a1fae46a4.tar.bz2
gentoo-2-cc54f7fca075df8241477dd52ae8951a1fae46a4.zip
Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483). Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from python overlay.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/PyQt4')
-rw-r--r--dev-python/PyQt4/ChangeLog7
-rw-r--r--dev-python/PyQt4/PyQt4-4.8.5.ebuild12
2 files changed, 14 insertions, 5 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index 5ee2216f8b71..4759902e4832 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.159 2011/08/19 10:12:33 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.160 2011/08/24 16:28:35 hwoarang Exp $
+
+ 24 Aug 2011; Markos Chandras <hwoarang@gentoo.org> PyQt4-4.8.5.ebuild:
+ Restrict PyPy ABIs. Avoid warnings about insecure runpaths (bug #376483).
+ Print useful warning in pkg_postinst(). Patch by Arfrever. Backported from
+ python overlay.
*PyQt4-4.8.5 (19 Aug 2011)
diff --git a/dev-python/PyQt4/PyQt4-4.8.5.ebuild b/dev-python/PyQt4/PyQt4-4.8.5.ebuild
index f330f3d7dd5d..b4ed3ee84b3d 100644
--- a/dev-python/PyQt4/PyQt4-4.8.5.ebuild
+++ b/dev-python/PyQt4/PyQt4-4.8.5.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.8.5.ebuild,v 1.1 2011/08/19 10:12:33 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.8.5.ebuild,v 1.2 2011/08/24 16:28:35 hwoarang Exp $
EAPI="3"
PYTHON_DEPEND="*"
PYTHON_EXPORT_PHASE_FUNCTIONS="1"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython"
+RESTRICT_PYTHON_ABIS="*-jython *-pypy-*"
inherit python qt4-r2 toolchain-funcs
@@ -47,7 +47,7 @@ DEPEND=">=dev-python/sip-4.12.2
xmlpatterns? ( >=x11-libs/qt-xmlpatterns-${QT_VER}:4 )"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}/${PN}-4.7.2-configure.py.patch"
@@ -122,7 +122,7 @@ src_configure() {
"${myconf[@]}" || return 1
local mod
- for mod in QtCore $(use X && echo QtDesigner QtGui) $(use declarative && echo QtDeclarative); do
+ for mod in QtCore $(use X && echo QtDesigner QtGui) $(use declarative && echo QtDeclarative) $(use opengl && echo QtOpenGL); do
# Run eqmake4 inside the qpy subdirectories to respect CC, CXX, CFLAGS, CXXFLAGS and LDFLAGS and avoid stripping.
pushd qpy/${mod} > /dev/null || return 1
eqmake4 $(ls w_qpy*.pro)
@@ -167,6 +167,10 @@ src_install() {
pkg_postinst() {
python_mod_optimize PyQt4
+
+ ewarn "When updating dev-python/PyQt4, you usually need to rebuild packages, which depend on"
+ ewarn "dev-python/PyQt4, such as dev-python/qscintilla-python. If you have app-portage/gentoolkit"
+ ewarn "installed, you can find these packages with \`equery d dev-python/PyQt4\`."
}
pkg_postrm() {