summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2015-06-29 21:07:51 +0000
committerDavide Pesavento <pesa@gentoo.org>2015-06-29 21:07:51 +0000
commitffd97f9743a42d6e9bed5fccf0865daeab5f5de1 (patch)
tree061a97ae13846385fb098aeaf6ddc359e3909efa /dev-python/PyQt4
parentDrop to ~sparc because the sparc team is not going to stabilize newer version... (diff)
downloadgentoo-2-ffd97f9743a42d6e9bed5fccf0865daeab5f5de1.tar.gz
gentoo-2-ffd97f9743a42d6e9bed5fccf0865daeab5f5de1.tar.bz2
gentoo-2-ffd97f9743a42d6e9bed5fccf0865daeab5f5de1.zip
Drop old version. As of now, sparc no longer has a stable PyQt4, see bug #523322 comment #15.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xDADED6B2671CB57D!)
Diffstat (limited to 'dev-python/PyQt4')
-rw-r--r--dev-python/PyQt4/ChangeLog6
-rw-r--r--dev-python/PyQt4/PyQt4-4.10.3-r2.ebuild207
2 files changed, 5 insertions, 208 deletions
diff --git a/dev-python/PyQt4/ChangeLog b/dev-python/PyQt4/ChangeLog
index af22a4dd9839..37934e61dc78 100644
--- a/dev-python/PyQt4/ChangeLog
+++ b/dev-python/PyQt4/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/PyQt4
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.291 2015/06/17 17:25:08 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/ChangeLog,v 1.292 2015/06/29 21:07:51 pesa Exp $
+
+ 29 Jun 2015; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.10.3-r2.ebuild:
+ Drop old version. As of now, sparc no longer has a stable PyQt4, see bug
+ #523322 comment #15.
17 Jun 2015; Davide Pesavento <pesa@gentoo.org> -PyQt4-4.11.3.ebuild:
Drop version that is not going to get stabilized.
diff --git a/dev-python/PyQt4/PyQt4-4.10.3-r2.ebuild b/dev-python/PyQt4/PyQt4-4.10.3-r2.ebuild
deleted file mode 100644
index f90ca3baf986..000000000000
--- a/dev-python/PyQt4/PyQt4-4.10.3-r2.ebuild
+++ /dev/null
@@ -1,207 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt4/PyQt4-4.10.3-r2.ebuild,v 1.13 2015/04/08 08:05:00 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3} )
-
-inherit eutils python-r1 qmake-utils toolchain-funcs
-
-DESCRIPTION="Python bindings for the Qt toolkit"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/ https://pypi.python.org/pypi/PyQt4"
-
-if [[ ${PV} == *_pre* ]]; then
- MY_P="PyQt-x11-gpl-snapshot-${PV%_pre*}-${REVISION}"
- SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${MY_P}.tar.gz"
-else
- MY_P="PyQt-x11-gpl-${PV}"
- SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
-fi
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-
-IUSE="X dbus debug declarative designer doc examples help kde multimedia opengl phonon script scripttools sql svg webkit xmlpatterns"
-REQUIRED_USE="
- ${PYTHON_REQUIRED_USE}
- declarative? ( X )
- designer? ( X )
- help? ( X )
- multimedia? ( X )
- opengl? ( X )
- phonon? ( X )
- scripttools? ( X script )
- sql? ( X )
- svg? ( X )
- webkit? ( X )
-"
-
-# Minimal supported version of Qt.
-QT_PV="4.8.0:4"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-lang/python-exec:2[${PYTHON_USEDEP}]
- =dev-python/sip-4.15*:=[${PYTHON_USEDEP}]
- >=dev-qt/qtcore-${QT_PV}
- X? (
- >=dev-qt/qtgui-${QT_PV}
- >=dev-qt/qttest-${QT_PV}
- )
- dbus? (
- >=dev-python/dbus-python-0.80[${PYTHON_USEDEP}]
- >=dev-qt/qtdbus-${QT_PV}
- )
- declarative? ( >=dev-qt/qtdeclarative-${QT_PV} )
- designer? ( || ( dev-qt/designer:4 <dev-qt/qtgui-4.8.5:4 ) )
- help? ( >=dev-qt/qthelp-${QT_PV} )
- multimedia? ( >=dev-qt/qtmultimedia-${QT_PV} )
- opengl? ( >=dev-qt/qtopengl-${QT_PV} )
- phonon? (
- kde? ( media-libs/phonon[qt4] )
- !kde? ( || ( >=dev-qt/qtphonon-${QT_PV} media-libs/phonon[qt4] ) )
- )
- script? ( >=dev-qt/qtscript-${QT_PV} )
- sql? ( >=dev-qt/qtsql-${QT_PV} )
- svg? ( >=dev-qt/qtsvg-${QT_PV} )
- webkit? ( >=dev-qt/qtwebkit-${QT_PV} )
- xmlpatterns? ( >=dev-qt/qtxmlpatterns-${QT_PV} )
-"
-DEPEND="${RDEPEND}
- dbus? ( virtual/pkgconfig )
-"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- # Support qreal on arm architecture (bug 322349).
- use arm && epatch "${FILESDIR}/${PN}-4.7.3-qreal_float_support.patch"
-
- # Allow building against KDE's phonon (bug 433944 and others).
- sed -i \
- -e "s:VideoWidget()\":&, extra_include_dirs=[\"${EPREFIX}/usr/include/qt4/QtGui\"]:" \
- -e "s:^\s\+generate_code(\"phonon\":&, extra_include_dirs=[\"${EPREFIX}/usr/include/phonon\"]:" \
- configure.py || die
-
- if ! use dbus; then
- sed -i -e 's/^\(\s\+\)check_dbus()/\1pass/' configure.py || die
- fi
-
- python_copy_sources
-
- preparation() {
- if [[ ${EPYTHON} == python3.* ]]; then
- rm -fr pyuic/uic/port_v2
- else
- rm -fr pyuic/uic/port_v3
- fi
- }
- python_foreach_impl run_in_build_dir preparation
-}
-
-pyqt4_use_enable() {
- use $1 && echo --enable=${2:-Qt$(tr 'a-z' 'A-Z' <<< ${1:0:1})${1:1}}
-}
-
-src_configure() {
- configuration() {
- local myconf=(
- "${PYTHON}" configure.py
- --confirm-license
- --bindir="${EPREFIX}/usr/bin"
- --destdir="$(python_get_sitedir)"
- --sipdir="${EPREFIX}/usr/share/sip"
- --assume-shared
- --no-timestamp
- --qsci-api
- $(use debug && echo --debug)
- --enable=QtCore
- --enable=QtNetwork
- --enable=QtXml
- $(pyqt4_use_enable X QtGui)
- $(pyqt4_use_enable X QtTest)
- $(pyqt4_use_enable dbus QtDBus)
- $(pyqt4_use_enable declarative)
- $(pyqt4_use_enable designer) $(use designer || echo --no-designer-plugin)
- $(pyqt4_use_enable help)
- $(pyqt4_use_enable multimedia)
- $(pyqt4_use_enable opengl QtOpenGL)
- $(pyqt4_use_enable phonon phonon)
- $(pyqt4_use_enable script)
- $(pyqt4_use_enable scripttools QtScriptTools)
- $(pyqt4_use_enable sql)
- $(pyqt4_use_enable svg)
- $(pyqt4_use_enable webkit QtWebKit)
- $(pyqt4_use_enable xmlpatterns QtXmlPatterns)
- AR="$(tc-getAR) cqs"
- CC="$(tc-getCC)"
- CFLAGS="${CFLAGS}"
- CFLAGS_RELEASE=
- CXX="$(tc-getCXX)"
- CXXFLAGS="${CXXFLAGS}"
- CXXFLAGS_RELEASE=
- LINK="$(tc-getCXX)"
- LINK_SHLIB="$(tc-getCXX)"
- LFLAGS="${LDFLAGS}"
- LFLAGS_RELEASE=
- RANLIB=
- STRIP=
- )
- echo "${myconf[@]}"
- "${myconf[@]}" || die
-
- local mod
- for mod in QtCore \
- $(use X && echo QtGui) \
- $(use dbus && echo QtDBus) \
- $(use declarative && echo QtDeclarative) \
- $(use designer && echo QtDesigner) \
- $(use opengl && echo QtOpenGL); do
- # Run eqmake4 inside the qpy subdirectories to respect
- # CC, CXX, CFLAGS, CXXFLAGS, LDFLAGS and avoid stripping.
- pushd qpy/${mod} > /dev/null || return
- eqmake4 $(ls w_qpy*.pro)
- popd > /dev/null || return
-
- # Fix insecure runpaths.
- sed -i -e "/^LFLAGS\s*=/ s:-Wl,-rpath,${BUILD_DIR}/qpy/${mod}::" \
- ${mod}/Makefile || die "failed to fix rpath for ${mod}"
- done
-
- # Avoid stripping of libpythonplugin.so.
- if use designer; then
- pushd designer > /dev/null || return
- eqmake4 python.pro
- popd > /dev/null || return
- fi
- }
- python_parallel_foreach_impl run_in_build_dir configuration
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_install() {
- installation() {
- # INSTALL_ROOT is used by designer/Makefile, other Makefiles use DESTDIR.
- emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
- mkdir -p "${ED}"/usr/lib/python-exec/${EPYTHON} || die
- mv "${ED}"/usr/bin/pyuic4 "${ED}"/usr/lib/python-exec/${EPYTHON}/ || die
- python_optimize
- }
- python_foreach_impl run_in_build_dir installation
-
- dosym ../lib/python-exec/python-exec2 /usr/bin/pyuic4
- dodoc NEWS THANKS
-
- if use doc; then
- dohtml -r doc/html/*
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}