summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2008-10-06 16:24:03 +0000
committerAli Polatel <hawking@gentoo.org>2008-10-06 16:24:03 +0000
commit232104b7b0c55f9968c861e85a8254086edbd9ee (patch)
treee5225510a23a584f1e5fe69185ab4d0354dd17a0 /dev-python/PyQt
parentold (diff)
downloadgentoo-2-232104b7b0c55f9968c861e85a8254086edbd9ee.tar.gz
gentoo-2-232104b7b0c55f9968c861e85a8254086edbd9ee.tar.bz2
gentoo-2-232104b7b0c55f9968c861e85a8254086edbd9ee.zip
Drop old.
(Portage version: -svn/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'dev-python/PyQt')
-rw-r--r--dev-python/PyQt/ChangeLog8
-rw-r--r--dev-python/PyQt/PyQt-3.14.1-r1.ebuild54
-rw-r--r--dev-python/PyQt/PyQt-3.14.1-r2.ebuild56
-rw-r--r--dev-python/PyQt/PyQt-3.17.2.ebuild56
-rw-r--r--dev-python/PyQt/PyQt-3.17.ebuild56
-rw-r--r--dev-python/PyQt/files/PyQt-3.14.1-examples.diff24
-rw-r--r--dev-python/PyQt/files/PyQt-3.14.1-python-2.5-compat.diff87
7 files changed, 7 insertions, 334 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index ce5c5769ea84..e04b962ff63a 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/PyQt
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.105 2008/05/13 08:52:27 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.106 2008/10/06 16:24:03 hawking Exp $
+
+ 06 Oct 2008; Ali Polatel <hawking@gentoo.org>
+ -files/PyQt-3.14.1-examples.diff,
+ -files/PyQt-3.14.1-python-2.5-compat.diff, -PyQt-3.14.1-r1.ebuild,
+ -PyQt-3.14.1-r2.ebuild, -PyQt-3.17.ebuild, -PyQt-3.17.2.ebuild:
+ Drop old.
13 May 2008; Ali Polatel <hawking@gentoo.org> PyQt-3.14.1-r1.ebuild,
PyQt-3.14.1-r2.ebuild, PyQt-3.17.ebuild, PyQt-3.17.2.ebuild,
diff --git a/dev-python/PyQt/PyQt-3.14.1-r1.ebuild b/dev-python/PyQt/PyQt-3.14.1-r1.ebuild
deleted file mode 100644
index cd18517d98e0..000000000000
--- a/dev-python/PyQt/PyQt-3.14.1-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.14.1-r1.ebuild,v 1.14 2008/05/13 08:52:27 hawking Exp $
-
-inherit distutils eutils
-
-MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
-SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
-IUSE="debug doc examples"
-
-RDEPEND="=x11-libs/qt-3*
- ~dev-python/sip-4.2.1
- x11-libs/qscintilla"
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-src_unpack() {
- unpack ${A}
- sed -i -e "s: check_license():# check_license():" "${S}"/configure.py
- epatch "${FILESDIR}/PyQt-3.14.1-examples.diff"
-}
-
-src_compile() {
- distutils_python_version
- addpredict ${QTDIR}/etc/settings
-
- local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages \
- -b /usr/bin \
- -v /usr/share/sip \
- -n /usr/include \
- -o /usr/$(get_libdir)"
- use debug && myconf="${myconf} -u"
-
- python configure.py ${myconf}
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "install failed"
- dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
- use doc && dohtml doc/PyQt.html
- if use examples ; then
- dodir /usr/share/doc/${PF}/examples
- cp -r examples3/* "${D}"/usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/PyQt/PyQt-3.14.1-r2.ebuild b/dev-python/PyQt/PyQt-3.14.1-r2.ebuild
deleted file mode 100644
index 5e916d79c78b..000000000000
--- a/dev-python/PyQt/PyQt-3.14.1-r2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.14.1-r2.ebuild,v 1.13 2008/05/13 08:52:27 hawking Exp $
-
-inherit distutils eutils
-
-MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="set of Python bindings for the QT 3.x Toolkit"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
-SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~alpha -amd64 ppc ppc64 sparc x86"
-IUSE="debug doc examples"
-
-RDEPEND="=x11-libs/qt-3*
- ~dev-python/sip-4.2.1
- x11-libs/qscintilla"
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-src_unpack() {
- unpack ${A}
- sed -i -e "s: check_license():# check_license():" "${S}"/configure.py
- cd "${S}"
- epatch "${FILESDIR}/PyQt-3.14.1-examples.diff"
- epatch "${FILESDIR}/PyQt-3.14.1-python-2.5-compat.diff"
-}
-
-src_compile() {
- distutils_python_version
- addpredict ${QTDIR}/etc/settings
-
- local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages \
- -b /usr/bin \
- -v /usr/share/sip \
- -n /usr/include \
- -o /usr/$(get_libdir)"
- use debug && myconf="${myconf} -u"
-
- python configure.py ${myconf}
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "install failed"
- dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
- use doc && dohtml doc/PyQt.html
- if use examples ; then
- dodir /usr/share/doc/${PF}/examples
- cp -r examples3/* "${D}"/usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/PyQt/PyQt-3.17.2.ebuild b/dev-python/PyQt/PyQt-3.17.2.ebuild
deleted file mode 100644
index e4be8ae1d4c1..000000000000
--- a/dev-python/PyQt/PyQt-3.17.2.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.17.2.ebuild,v 1.7 2008/05/13 08:52:27 hawking Exp $
-
-inherit distutils
-
-MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="PyQt is a set of Python bindings for the Qt toolkit."
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
-#SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-SRC_URI="http://www.riverbankcomputing.com/Downloads/PyQt3/GPL/${MY_P}.tar.gz"
-#SRC_URI="http://www.riverbankcomputing.com/Downloads/Snapshots/PyQt3/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug doc examples"
-
-RDEPEND="=x11-libs/qt-3*
- ~dev-python/sip-4.6
- x11-libs/qscintilla"
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-src_unpack() {
- unpack ${A}
- sed -i -e "s: check_license():# check_license():" "${S}"/configure.py
-}
-
-src_compile() {
- distutils_python_version
- addpredict ${QTDIR}/etc/settings
-
- local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages \
- -b /usr/bin \
- -v /usr/share/sip \
- -n /usr/include \
- -o /usr/$(get_libdir) \
- -w -y qt-mt"
- use debug && myconf="${myconf} -u"
-
- python configure.py ${myconf}
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "install failed"
- dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
- use doc && dohtml doc/PyQt.html
- if use examples ; then
- dodir /usr/share/doc/${PF}/examples
- cp -r examples3/* "${D}"/usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/PyQt/PyQt-3.17.ebuild b/dev-python/PyQt/PyQt-3.17.ebuild
deleted file mode 100644
index c01e87edb193..000000000000
--- a/dev-python/PyQt/PyQt-3.17.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.17.ebuild,v 1.10 2008/05/13 08:52:27 hawking Exp $
-
-inherit distutils
-
-MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="PyQt is a set of Python bindings for the Qt toolkit."
-HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
-#SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
-SRC_URI="http://www.riverbankcomputing.com/Downloads/PyQt3/GPL/${MY_P}.tar.gz"
-#SRC_URI="http://www.riverbankcomputing.com/Downloads/Snapshots/PyQt3/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 ~ia64 ppc ppc64 sparc x86"
-IUSE="debug doc examples"
-
-RDEPEND="=x11-libs/qt-3*
- >=dev-python/sip-4.4.1
- x11-libs/qscintilla"
-DEPEND="${RDEPEND}
- sys-devel/libtool"
-
-src_unpack() {
- unpack ${A}
- sed -i -e "s: check_license():# check_license():" "${S}"/configure.py
-}
-
-src_compile() {
- distutils_python_version
- addpredict ${QTDIR}/etc/settings
-
- local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages \
- -b /usr/bin \
- -v /usr/share/sip \
- -n /usr/include \
- -o /usr/$(get_libdir) \
- -w -y qt-mt"
- use debug && myconf="${myconf} -u"
-
- python configure.py ${myconf}
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "install failed"
- dodoc ChangeLog LICENSE NEWS README README.Linux THANKS
- use doc && dohtml doc/PyQt.html
- if use examples ; then
- dodir /usr/share/doc/${PF}/examples
- cp -r examples3/* "${D}"/usr/share/doc/${PF}/examples
- fi
-}
diff --git a/dev-python/PyQt/files/PyQt-3.14.1-examples.diff b/dev-python/PyQt/files/PyQt-3.14.1-examples.diff
deleted file mode 100644
index 6e5a4785f4a5..000000000000
--- a/dev-python/PyQt/files/PyQt-3.14.1-examples.diff
+++ /dev/null
@@ -1,24 +0,0 @@
---- PyQt-x11-gpl-3.14.1/examples3/SQL/form1.ui 2005-03-06 11:30:50.000000000 +0100
-+++ /var/tmp/portage/pykde-3.5.0/work/pykde-3.5.0/python/pyqt/examples3/SQL/form1.ui 2005-11-30 15:59:01.000000000 +0100
-@@ -12,9 +12,6 @@
- <height>370</height>
- </rect>
- </property>
-- <property name="caption">
-- <string>Form1</string>
-- </property>
- <widget class="QDataTable">
- <column>
- <property name="text">
---- PyQt-x11-gpl-3.14.1/examples3/SQL/form2.ui 2005-03-06 11:30:50.000000000 +0100
-+++ /var/tmp/portage/pykde-3.5.0/work/pykde-3.5.0/python/pyqt/examples3/SQL/form2.ui 2005-11-30 15:59:01.000000000 +0100
-@@ -12,9 +12,6 @@
- <height>152</height>
- </rect>
- </property>
-- <property name="caption">
-- <string>Form2</string>
-- </property>
- <widget class="QDataBrowser">
- <property name="name">
- <cstring>DataBrowser1</cstring>
diff --git a/dev-python/PyQt/files/PyQt-3.14.1-python-2.5-compat.diff b/dev-python/PyQt/files/PyQt-3.14.1-python-2.5-compat.diff
deleted file mode 100644
index 60b99cbee1d3..000000000000
--- a/dev-python/PyQt/files/PyQt-3.14.1-python-2.5-compat.diff
+++ /dev/null
@@ -1,87 +0,0 @@
---- sip/qt/qdir.sip.orig 2006-10-12 17:28:37.000000000 +0200
-+++ sip/qt/qdir.sip 2006-10-12 17:29:43.000000000 +0200
-@@ -238,7 +238,7 @@
-
- QString operator[](int) const;
- %MethodCode
-- int len;
-+ ssize_t len;
-
- Py_BEGIN_ALLOW_THREADS
- len = sipCpp -> count();
-@@ -256,7 +256,7 @@
-
- QStringList operator[](SIP_PYSLICE) const;
- %MethodCode
-- int len, start, stop, step, slicelength;
-+ ssize_t len, start, stop, step, slicelength;
-
- Py_BEGIN_ALLOW_THREADS
- len = sipCpp -> count();
---- sip/qt/qstring.sip 2005/09/29 14:33:08 465369
-+++ sip/qt/qstring.sip 2006/10/11 22:54:45 594670
-@@ -746,7 +746,7 @@
-
- QString operator[](SIP_PYSLICE) const;
- %MethodCode
-- int len, start, stop, step, slicelength;
-+ ssize_t len, start, stop, step, slicelength;
-
- len = sipCpp -> length();
-
---- sip/qt/qstringlist.sip 2005/09/29 14:33:08 465369
-+++ sip/qt/qstringlist.sip 2006/10/11 22:54:45 594670
-@@ -99,7 +99,7 @@
-
- void __setitem__(int,const QString &);
- %MethodCode
-- int len;
-+ ssize_t len;
-
- len = sipCpp -> count();
-
-@@ -111,7 +111,7 @@
-
- void __setitem__(SIP_PYSLICE,const QStringList &);
- %MethodCode
-- int len, start, stop, step, slicelength;
-+ ssize_t len, start, stop, step, slicelength;
-
- len = sipCpp -> count();
-
-@@ -142,7 +142,7 @@
-
- void __delitem__(int);
- %MethodCode
-- int len;
-+ ssize_t len;
-
- len = sipCpp -> count();
-
-@@ -154,7 +154,7 @@
-
- void __delitem__(SIP_PYSLICE);
- %MethodCode
-- int len, start, stop, step, slicelength;
-+ ssize_t len, start, stop, step, slicelength;
-
- len = sipCpp -> count();
-
-@@ -170,7 +170,7 @@
-
- QString operator[](int);
- %MethodCode
-- int len;
-+ ssize_t len;
-
- len = sipCpp -> count();
-
-@@ -182,7 +182,7 @@
-
- QStringList operator[](SIP_PYSLICE);
- %MethodCode
-- int len, start, stop, step, slicelength;
-+ ssize_t len, start, stop, step, slicelength;
-
- len = sipCpp -> count();
-