summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2001-12-29 17:41:37 +0000
committerDan Armak <danarmak@gentoo.org>2001-12-29 17:41:37 +0000
commit31ea401556c658c3b023797bba71370f471437d6 (patch)
tree8675242200fdcbca6ae10a94064e5ff3fbe4c818 /dev-python/PyQt
parentunmasked fam (diff)
downloadgentoo-2-31ea401556c658c3b023797bba71370f471437d6.tar.gz
gentoo-2-31ea401556c658c3b023797bba71370f471437d6.tar.bz2
gentoo-2-31ea401556c658c3b023797bba71370f471437d6.zip
big commit :-) read gentoo-announce msg and eclass/doc/news.txt for details
Diffstat (limited to 'dev-python/PyQt')
-rw-r--r--dev-python/PyQt/PyQt-2.4.ebuild9
-rw-r--r--dev-python/PyQt/PyQt-3.0.ebuild7
2 files changed, 10 insertions, 6 deletions
diff --git a/dev-python/PyQt/PyQt-2.4.ebuild b/dev-python/PyQt/PyQt-2.4.ebuild
index bc7ef1e39b8e..1ac87e5eed8b 100644
--- a/dev-python/PyQt/PyQt-2.4.ebuild
+++ b/dev-python/PyQt/PyQt-2.4.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: tools@cvs.gentoo.org
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-2.4.ebuild,v 1.4 2001/11/10 12:14:29 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-2.4.ebuild,v 1.5 2001/12/29 17:41:37 danarmak Exp $
S=${WORKDIR}/${P}
DESCRIPTION="PyQt is a set of Python bindings for the Qt Toolkit."
SRC_URI="http://www.river-bank.demon.co.uk/software/${P}.tar.gz"
HOMEPAGE="http://www.thekompany.com/projects/pykde/"
-DEPEND=">=x11-libs/qt-x11-1.4.2
+# i don't suppose we'll ever have a x11-libs/qt-1* ebuild, so ive changed
+# the >1.4.2 dep to 2
+DEPEND=">=x11-libs/qt-2
=dev-python/sip-2.4
virtual/python"
@@ -16,7 +18,8 @@ src_compile() {
./configure --prefix=/usr \
--infodir=/usr/share/info \
--mandir=/usr/share/man \
- --with-doc-install=/usr/share/doc
+ --with-doc-install=/usr/share/doc \
+ --with-qt-dir=/usr/qt/2
assert
make || die
diff --git a/dev-python/PyQt/PyQt-3.0.ebuild b/dev-python/PyQt/PyQt-3.0.ebuild
index 606a46005066..4acad4ee3f79 100644
--- a/dev-python/PyQt/PyQt-3.0.ebuild
+++ b/dev-python/PyQt/PyQt-3.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Bart Verwilst <verwilst@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.0.ebuild,v 1.1 2001/12/04 18:17:22 verwilst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.0.ebuild,v 1.2 2001/12/29 17:41:37 danarmak Exp $
S="${WORKDIR}/PyQt-3.0"
DESCRIPTION="PyQt is a set of Python bindings for the Qt Toolkit( VERSION 3.x ONLY!!."
@@ -10,7 +10,7 @@ SRC_URI="http://www.river-bank.demon.co.uk/software/PyQt-3.0-Qt-3.0.0.tar.gz
HOMEPAGE="http://www.thekompany.com/projects/pykde/"
DEPEND="virtual/glibc
- >=x11-libs/qt-x11-3
+ >=x11-libs/qt-3
=dev-python/sip-3.0
>=dev-lang/python-2.0"
@@ -27,7 +27,8 @@ src_compile() {
./configure --prefix=/usr \
--infodir=/usr/share/info \
--mandir=/usr/share/man \
- --with-doc-install=/usr/share/doc
+ --with-doc-install=/usr/share/doc \
+ --with-qt-dir=/usr/qt/3
assert
make || die