summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-12-14 00:06:55 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-12-14 00:06:55 +0000
commit8a8856b674ccb0395b4253d7dd1a59015bc5c228 (patch)
tree2f4f21cee1420fcf6931d6e8f16f5664d5a8b4ac /dev-python/PyQt
parentbah, log all changes (diff)
downloadgentoo-2-8a8856b674ccb0395b4253d7dd1a59015bc5c228.tar.gz
gentoo-2-8a8856b674ccb0395b4253d7dd1a59015bc5c228.tar.bz2
gentoo-2-8a8856b674ccb0395b4253d7dd1a59015bc5c228.zip
new version
Diffstat (limited to 'dev-python/PyQt')
-rw-r--r--dev-python/PyQt/ChangeLog6
-rw-r--r--dev-python/PyQt/PyQt-3.3.2.ebuild42
-rw-r--r--dev-python/PyQt/PyQt-3.5.ebuild45
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.3.21
-rw-r--r--dev-python/PyQt/files/digest-PyQt-3.51
-rw-r--r--dev-python/PyQt/files/license-3.5.diff34
6 files changed, 85 insertions, 44 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index acd423c34cd0..c83250a077d8 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/PyQt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.8 2002/12/13 10:56:44 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.9 2002/12/14 00:04:50 verwilst Exp $
+
+*PyQt-3.5 (14 December 2002) Bart Verwilst <verwilst@gentoo.org>
+
+ New version, + changed license to GPL
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/dev-python/PyQt/PyQt-3.3.2.ebuild b/dev-python/PyQt/PyQt-3.3.2.ebuild
deleted file mode 100644
index 5cb5987a2e9a..000000000000
--- a/dev-python/PyQt/PyQt-3.3.2.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.3.2.ebuild,v 1.6 2002/12/09 04:21:12 manson Exp $
-
-S="${WORKDIR}/PyQt-snapshot-20020722"
-DESCRIPTION="PyQt is a set of Python bindings for the Qt Toolkit( VERSION 3.x ONLY!!)."
-SRC_URI="http://www.riverbankcomputing.co.uk/download/snapshots/PyQt/PyQt-snapshot-20020722.tar.gz"
-HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
-
-SLOT="0"
-LICENSE="MIT"
-KEYWORDS="x86 sparc alpha"
-
-DEPEND="virtual/glibc
- sys-devel/libtool
- >=x11-libs/qt-3.0.4.1
- >=dev-lang/python-2.2.1
- =dev-python/sip-3.3.2"
-
-src_compile() {
- # Fix for one installation problem. The libtool included with the
- # source package does not have the relink patch.
- # Use the system libtool instead.
- dodir /usr/lib/python2.2/site-packages
- dodir /usr/include/python2.2
- python build.py \
- -d ${D}/usr/lib/python2.2/site-packages \
- -b ${D}/usr/bin \
- -l qt-mt -c
- make || die
-}
-
-src_install() {
- make DESTDIR=${D} install || die
- make DESTDIR=${D} install-eric || die
- echo "#!/bin/sh" > ${D}/usr/bin/eric
- echo " " >> ${D}/usr/bin/eric
- echo "exec python /usr/lib/python2.2/site-packages/eric/eric.py $*" >> ${D}/usr/bin/eric
- chmod +x ${D}/usr/bin/eric
- dodir /usr/share/doc/${P}/
- mv ${D}/usr/share/doc/* ${D}/usr/share/doc/${P}/
-}
diff --git a/dev-python/PyQt/PyQt-3.5.ebuild b/dev-python/PyQt/PyQt-3.5.ebuild
new file mode 100644
index 000000000000..cf2a50f0be93
--- /dev/null
+++ b/dev-python/PyQt/PyQt-3.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.5.ebuild,v 1.1 2002/12/14 00:04:50 verwilst Exp $
+
+S="${WORKDIR}/PyQt-x11-gpl-${PV}"
+DESCRIPTION="PyQt is a set of Python bindings for the QT 3.x Toolkit"
+SRC_URI="http://www.river-bank.demon.co.uk/download/PyQt/PyQt-x11-gpl-${PV}.tar.gz"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/pyqt/"
+
+SLOT="0"
+LICENSE="GPL"
+KEYWORDS="x86 ppc sparc alpha"
+
+DEPEND="virtual/glibc
+ sys-devel/libtool
+ >=x11-libs/qt-3.0.4.1
+ >=dev-lang/python-2.2.1
+ =dev-python/sip-${PV}"
+
+src_unpack() {
+
+ unpack PyQt-x11-gpl-${PV}.tar.gz
+ cd ${S}
+ patch -p0 < ${FILESDIR}/license-3.5.diff
+
+}
+
+
+src_compile() {
+ dodir /usr/lib/python2.2/site-packages
+ dodir /usr/include/python2.2
+ python build.py \
+ -d ${D}/usr/lib/python2.2/site-packages \
+ -e /usr/include/python2.2 \
+ -b ${D}/usr/bin \
+ -l qt-mt -c
+ make || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README.Linux NEWS LICENSE README ChangeLog THANKS
+ dodir /usr/share/doc/${P}/
+ mv ${D}/usr/share/doc/* ${D}/usr/share/doc/${P}/
+}
diff --git a/dev-python/PyQt/files/digest-PyQt-3.3.2 b/dev-python/PyQt/files/digest-PyQt-3.3.2
deleted file mode 100644
index 6b7f8102e16f..000000000000
--- a/dev-python/PyQt/files/digest-PyQt-3.3.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 23a8975024f2b8f6e349c28075bd0a65 PyQt-snapshot-20020722.tar.gz 570991
diff --git a/dev-python/PyQt/files/digest-PyQt-3.5 b/dev-python/PyQt/files/digest-PyQt-3.5
new file mode 100644
index 000000000000..e681c54a20ce
--- /dev/null
+++ b/dev-python/PyQt/files/digest-PyQt-3.5
@@ -0,0 +1 @@
+MD5 3145f56f187d98147de20360b990da01 PyQt-x11-gpl-3.5.tar.gz 654406
diff --git a/dev-python/PyQt/files/license-3.5.diff b/dev-python/PyQt/files/license-3.5.diff
new file mode 100644
index 000000000000..82d3106b7212
--- /dev/null
+++ b/dev-python/PyQt/files/license-3.5.diff
@@ -0,0 +1,34 @@
+--- build.py.orig 2002-12-13 23:43:10.000000000 +0100
++++ build.py 2002-12-13 23:43:23.000000000 +0100
+@@ -646,31 +646,6 @@
+ licType = "GPL"
+ licname = "GNU General Public License"
+
+- inform("This is the %s version of PyQt and is licensed under the %s." % (licType,licname),0)
+-
+- print
+- print "Type 'L' to view the license."
+- print "Type 'yes' to accept the terms of the license."
+- print "Type 'no' to decline the terms of the license."
+- print
+-
+- while 1:
+- try:
+- resp = raw_input("Do you accept the terms of the license? ")
+- except:
+- resp = ""
+-
+- resp = resp.strip().lower()
+-
+- if resp == "yes":
+- break
+-
+- if resp == "no":
+- sys.exit(0)
+-
+- if resp == "l":
+- os.system("more LICENSE")
+-
+ inform("Building the %s version of PyQt 3.5 for Python %s on %s." % (licType,pyFullVers,sys.platform))
+
+ if licType != "GPL":