summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-11-25 23:09:48 +0000
committerBen de Groot <yngwin@gentoo.org>2008-11-25 23:09:48 +0000
commit9e4e48119e34ebac3785922bbdd987fb921ea08f (patch)
treea73a5b55f1b89e831d0fb23171143f882932c2cd /dev-python/PyQt
parentTypo (diff)
downloadgentoo-2-9e4e48119e34ebac3785922bbdd987fb921ea08f.tar.gz
gentoo-2-9e4e48119e34ebac3785922bbdd987fb921ea08f.tar.bz2
gentoo-2-9e4e48119e34ebac3785922bbdd987fb921ea08f.zip
Version bump, fixes bug 248044
(Portage version: 2.2_rc16/cvs/Linux 2.6.27-hh6 i686)
Diffstat (limited to 'dev-python/PyQt')
-rw-r--r--dev-python/PyQt/ChangeLog31
-rw-r--r--dev-python/PyQt/PyQt-3.17.6.ebuild57
2 files changed, 75 insertions, 13 deletions
diff --git a/dev-python/PyQt/ChangeLog b/dev-python/PyQt/ChangeLog
index e04b962ff63a..623a87d649ca 100644
--- a/dev-python/PyQt/ChangeLog
+++ b/dev-python/PyQt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/PyQt
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.106 2008/10/06 16:24:03 hawking Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/ChangeLog,v 1.107 2008/11/25 23:09:48 yngwin Exp $
+
+*PyQt-3.17.6 (25 Nov 2008)
+
+ 25 Nov 2008; Ben de Groot <yngwin@gentoo.org> +PyQt-3.17.6.ebuild:
+ Version bump, fixes bug 248044
06 Oct 2008; Ali Polatel <hawking@gentoo.org>
-files/PyQt-3.14.1-examples.diff,
@@ -319,7 +324,7 @@
27 Aug 2003; Caleb Tennis <caleb@gentoo.org> PyQt-3.8.ebuild:
Version bump
-
+
31 Jul 2003; Caleb Tennis <caleb@gentoo.org> PyQT-3.7.ebuild:
Upgrade dep on QScintilla-1.53
@@ -342,16 +347,16 @@
17 Apr 2003; Michele Balistreri <brain@gentoo.org> Changelog :
Added IUSE flag for policy compliance
-
+
17 Apr 2003; Michele Balistreri <brain@gentoo.org> Changelog :
Marked as stable on x86
-
+
12 Apr 2003; Michele Balistreri <brain@gentoo.org> ChangeLog :
Fix compilation bug with QT 3.1.2 (bug #19008)
-
+
26 Feb 2003; Dan Armak <danarmak@gentoo.org> ChangeLog :
Fix possible sandbox error as per bug #12393.
@@ -364,41 +369,41 @@
files are like headers for sip-based packages, such as PyQT and PyKDE. This
closes bug #10060.
-*PyQt-3.5 (14 Dec 2002)
+*PyQt-3.5 (14 Dec 2002)
14 Dec 2002; Bart Verwilst <verwilst@gentoo.org>
New version, + changed license to GPL
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
-
-*PyQt-3.4 (18 Sep 2002)
+
+*PyQt-3.4 (18 Sep 2002)
18 Sep 2002; Sascha Schwabbauer <cybersystem@gentoo.org> :
Added ppc to keywords.
-*PyQt-3.4 (17 Sep 2002)
+*PyQt-3.4 (17 Sep 2002)
17 Sep 2002; Bart Verwilst <verwilst@gentoo.org>
-*PyQt-3.3.2 (25 Jul 2002)
+*PyQt-3.3.2 (25 Jul 2002)
25 Jul 2002; Bart Verwilst <verwilst@gentoo.org>
-
+
13 Aug 2002; Bart Verwilst <verwilst@gentoo.org> ChangeLog :
Added "-c" flag to build.py, so the compilation time will be 80% less
from what it was before. More CPU/MEM usage though during compilation!
-*PyQt-3.2.4 (5 Jul 2002)
+*PyQt-3.2.4 (5 Jul 2002)
05 Jul 2002; Bart Verwilst <verwilst@gentoo.org>
*PyQt-3.0 (1 Feb 2002)
1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
+
Added initial ChangeLog which should be updated whenever the package is
updated in any way. This changelog is targetted to users. This means that the
comments should well explained and written in clean English. The details about
diff --git a/dev-python/PyQt/PyQt-3.17.6.ebuild b/dev-python/PyQt/PyQt-3.17.6.ebuild
new file mode 100644
index 000000000000..8ef883c94499
--- /dev/null
+++ b/dev-python/PyQt/PyQt-3.17.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyQt/PyQt-3.17.6.ebuild,v 1.1 2008/11/25 23:09:48 yngwin Exp $
+
+EAPI="1"
+inherit distutils
+
+MY_P="PyQt-x11-gpl-${PV/*_pre/snapshot-}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A set of Python bindings for Qt3"
+HOMEPAGE="http://www.riverbankcomputing.co.uk/software/pyqt/intro/"
+#SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+SRC_URI="http://www.riverbankcomputing.com/static/Downloads/PyQt3/${MY_P}.tar.gz"
+#SRC_URI="http://www.riverbankcomputing.com/Downloads/Snapshots/PyQt3/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples"
+
+RDEPEND="x11-libs/qt:3
+ >=dev-python/sip-4.7.3
+ x11-libs/qscintilla"
+DEPEND="${RDEPEND}
+ sys-devel/libtool"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s: check_license():# check_license():" "${S}"/configure.py
+}
+
+src_compile() {
+ distutils_python_version
+ addpredict ${QTDIR}/etc/settings
+
+ local myconf="-d /usr/$(get_libdir)/python${PYVER}/site-packages \
+ -b /usr/bin \
+ -v /usr/share/sip \
+ -n /usr/include \
+ -o /usr/$(get_libdir) \
+ -w -y qt-mt"
+ use debug && myconf="${myconf} -u"
+
+ python configure.py ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc ChangeLog NEWS README THANKS
+ use doc && dohtml doc/PyQt.html
+ if use examples ; then
+ dodir /usr/share/doc/${PF}/examples
+ cp -r examples3/* "${D}"/usr/share/doc/${PF}/examples
+ fi
+}