summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2011-08-26 05:56:00 +0000
committerMike Gilbert <floppym@gentoo.org>2011-08-26 05:56:00 +0000
commit0d2d6ffb02d6d7644243b5d7b11ba2897259696a (patch)
tree80d72e3777cdf1a2db56463bbc30eccbddd53624 /dev-python/PyRSS2Gen
parentInitial version of package -- provides a DTS decoder. (diff)
downloadgentoo-2-0d2d6ffb02d6d7644243b5d7b11ba2897259696a.tar.gz
gentoo-2-0d2d6ffb02d6d7644243b5d7b11ba2897259696a.tar.bz2
gentoo-2-0d2d6ffb02d6d7644243b5d7b11ba2897259696a.zip
Migrate from sunrise; resolves bug 56920 by Jacob Smullyan
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/PyRSS2Gen')
-rw-r--r--dev-python/PyRSS2Gen/ChangeLog10
-rw-r--r--dev-python/PyRSS2Gen/PyRSS2Gen-1.0.0.ebuild29
-rw-r--r--dev-python/PyRSS2Gen/metadata.xml9
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/PyRSS2Gen/ChangeLog b/dev-python/PyRSS2Gen/ChangeLog
new file mode 100644
index 000000000000..0bbd8de82e76
--- /dev/null
+++ b/dev-python/PyRSS2Gen/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/PyRSS2Gen
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyRSS2Gen/ChangeLog,v 1.1 2011/08/26 05:56:00 floppym Exp $
+
+*PyRSS2Gen-1.0.0 (26 Aug 2011)
+
+ 26 Aug 2011; Mike Gilbert <floppym@gentoo.org> +PyRSS2Gen-1.0.0.ebuild,
+ +metadata.xml:
+ Migrate from sunrise; resolves bug 56920 by Jacob Smullyan
+
diff --git a/dev-python/PyRSS2Gen/PyRSS2Gen-1.0.0.ebuild b/dev-python/PyRSS2Gen/PyRSS2Gen-1.0.0.ebuild
new file mode 100644
index 000000000000..6c3c0f90c283
--- /dev/null
+++ b/dev-python/PyRSS2Gen/PyRSS2Gen-1.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/PyRSS2Gen/PyRSS2Gen-1.0.0.ebuild,v 1.1 2011/08/26 05:56:00 floppym Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="RSS feed generator written in Python"
+HOMEPAGE="http://www.dalkescientific.com/Python/PyRSS2Gen.html"
+SRC_URI="http://www.dalkescientific.com/Python/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RESTRICT_PYTHON_ABIS="3.*"
+PYTHON_MODNAME="${PN}.py"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ dodoc example.py || die
+ fi
+}
diff --git a/dev-python/PyRSS2Gen/metadata.xml b/dev-python/PyRSS2Gen/metadata.xml
new file mode 100644
index 000000000000..e6093f985285
--- /dev/null
+++ b/dev-python/PyRSS2Gen/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>floppym@gentoo.org</email>
+ <name>Mike Gilbert</name>
+ </maintainer>
+</pkgmetadata>